summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-02-12 13:37:25 +0100
committerMartin T. H. Sandsmark2020-02-12 13:37:25 +0100
commit14bb527a3c34f64719647ddc0029cbf855c224f5 (patch)
tree5bca71729f26e1a7175add1624c67f60cd65dd96
downloadaur-depixelator-git.tar.gz
initial
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD26
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..566da268edd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = depixelator-git
+ pkgdesc = A small header-only c++ library to depixelize pixels to contours
+ pkgver = r8.c09fca8
+ pkgrel = 1
+ url = https://github.com/reMarkable/depixelator
+ arch = any
+ license = BSD
+ makedepends = git
+ provides = depixelator
+ conflicts = depixelator
+ source = git+https://github.com/reMarkable/depixelator.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = cdaee571ecbbc34f8d58891422dda7a7
+
+pkgname = depixelator-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..65ce55081b7e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+Copyright (c) 2019, reMarkable AS <technology@remarkable.no>
+Copyright (c) 2019, Gunnar Sletta <gunnar@crimson.no>
+All rights reserved.
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+1. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
+IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..314b1b3cfe0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=depixelator-git
+pkgver=r8.c09fca8
+pkgrel=1
+pkgdesc='A small header-only c++ library to depixelize pixels to contours'
+arch=('any')
+url='https://github.com/reMarkable/depixelator'
+license=('BSD')
+makedepends=('git')
+conflicts=(depixelator)
+provides=(depixelator)
+source=('git+https://github.com/reMarkable/depixelator.git' 'LICENSE')
+md5sums=('SKIP' 'cdaee571ecbbc34f8d58891422dda7a7')
+
+pkgver() {
+ cd depixelator
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm 0644 LICENSE -t "${pkgdir}/usr/share/licenses/depixelator-git"
+
+ cd depixelator
+ install -Dm 0644 depixelator.h -t "${pkgdir}/usr/include/"
+}