summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYassine Oudjana2021-09-12 09:34:08 +0400
committerYassine Oudjana2021-09-12 09:34:08 +0400
commit8adc29af8cbb6f99a51eea5a3f9c7dc2cc88ac18 (patch)
treecb921c0cc6f2f6249a5e3817d0c0cf521dc9321b
downloadaur-derelict-util.tar.gz
Add derelict-util package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..597a6ed90bd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = derelict-util
+ pkgdesc = Cross-platform shared library loader and a number of utility modules used by the Derelict libraries.
+ pkgver = 3.0.0_beta.2
+ pkgrel = 1
+ url = https://github.com/DerelictOrg/DerelictUtil
+ arch = x86_64
+ license = Boost
+ makedepends = dub
+ source = https://github.com/DerelictOrg/DerelictUtil/archive/refs/tags/v3.0.0-beta.2.tar.gz
+ sha256sums = d6407725cc202121f56382df62e0997b4067dd05ccda7b387cef5dcddbd6c3c4
+
+pkgname = derelict-util
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca5fa14e93a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Yassine Oudjana <y.oudjana@protonmail.com>
+
+pkgname=derelict-util
+_ver=3.0.0-beta.2
+pkgver=${_ver//-/_}
+pkgrel=1
+pkgdesc="Cross-platform shared library loader and a number of utility modules used by the Derelict libraries."
+arch=('x86_64')
+url="https://github.com/DerelictOrg/DerelictUtil"
+license=('Boost')
+makedepends=('dub')
+source=("https://github.com/DerelictOrg/DerelictUtil/archive/refs/tags/v$_ver.tar.gz")
+sha256sums=('d6407725cc202121f56382df62e0997b4067dd05ccda7b387cef5dcddbd6c3c4')
+
+build() {
+ cd DerelictUtil-$_ver
+
+ dub build
+}
+
+package() {
+ cd DerelictUtil-$_ver
+
+ install -Dm0755 -t "$pkgdir/usr/lib/" "lib/libDerelictUtil.a"
+ mkdir -p "$pkgdir/usr/include/d/derelict/util"
+ cp -R --no-dereference --preserve=mode,links "source/derelict/util" "$pkgdir/usr/include/d/derelict/"
+}
+