summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-16 10:52:34 +0800
committerzxp198210052024-04-16 10:52:34 +0800
commitf874394902a5de4db96016a742f610cb61b690dc (patch)
tree3aea876c39bc8940a3e57c6528707ef24b7d0746
downloadaur-devhub-bin.tar.gz
update to 0.102.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
-rw-r--r--devhub.sh16
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab039ed645d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = devhub-bin
+ pkgdesc = TweetDeck for GitHub - Filter Issues, Activities & Notifications - Web, Mobile & Desktop with 99% code sharing between them.Use system-wide electron.
+ pkgver = 0.102.0
+ pkgrel = 1
+ url = https://devhubapp.com/
+ arch = x86_64
+ license = AGPL-3.0-only
+ makedepends = fuse2
+ depends = electron11-bin
+ provides = devhub=0.102.0
+ conflicts = devhub
+ source = devhub-0.102.0.AppImage::https://github.com/devhubapp/devhub/releases/download/v0.102.0/DevHub-0.102.0.AppImage
+ source = devhub.sh
+ sha256sums = 28620433cf9d36151e21786ed67ba8efc5c0f84517bcbad879a30793e558d2c6
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+
+pkgname = devhub-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f35adda3e154
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=devhub-bin
+_pkgname=DevHub
+pkgver=0.102.0
+_electronversion=11
+pkgrel=1
+pkgdesc="TweetDeck for GitHub - Filter Issues, Activities & Notifications - Web, Mobile & Desktop with 99% code sharing between them.Use system-wide electron."
+arch=('x86_64')
+url="https://devhubapp.com/"
+_ghurl="https://github.com/devhubapp/devhub"
+license=('AGPL-3.0-only')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}-bin"
+)
+makedepends=(
+ 'fuse2'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.AppImage"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('28620433cf9d36151e21786ed67ba8efc5c0f84517bcbad879a30793e558d2c6'
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ cp -r "${srcdir}/squashfs-root/resources/"{assets,build} "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/devhub.sh b/devhub.sh
new file mode 100644
index 000000000000..7ddcaab8d734
--- /dev/null
+++ b/devhub.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+set -e
+_APPDIR="/usr/lib/@appname@"
+_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+else
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file