summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEntityBlackHawk2024-01-24 11:08:48 -0300
committerEntityBlackHawk2024-01-24 11:08:48 -0300
commit9ea40961fa08e19bc6cd2f1ae68d7f400cc38e9e (patch)
tree11cc5f6c922ec70a93e8fd034dfe2eb05c92f837
downloadaur-devtunnel-cli-git.tar.gz
Fist commit (PKGBUILD .SRCINFO)
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--devtunnel-cli-git.install3
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9445c584f77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = devtunnel-cli-git
+ pkgdesc = Microsoft's Dev tunnel - CLI
+ pkgver = e5b20b7
+ pkgrel = 1
+ url = https://github.com/EnityBlackHawk/devtunnel-cli.git
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = libsecret
+ depends = glibc
+ depends = zlib
+ depends = gcc-libs
+ source = git+https://github.com/EnityBlackHawk/devtunnel-cli.git
+ md5sums = SKIP
+
+pkgname = devtunnel-cli-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c07ead8fbb6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: EnityBlackHawk <entityblackhawk@gmail.com>
+pkgname=devtunnel-cli-git
+pkgver=e5b20b7
+pkgrel=1
+epoch=
+pkgdesc="Microsoft's Dev tunnel - CLI"
+arch=('x86_64')
+url="https://github.com/EnityBlackHawk/devtunnel-cli.git"
+license=('MIT')
+depends=('libsecret' 'glibc' 'zlib' 'gcc-libs')
+makedepends=('git')
+source=('git+https://github.com/EnityBlackHawk/devtunnel-cli.git')
+md5sums=('SKIP')
+
+pkver(){
+ cd "devtunnel-cli"
+ git rev-parse --short HEAD
+}
+
+
+build() {
+ cd "devtunnel-cli"
+ ./devtunnel.sh
+}
+
+package() {
+ cd "devtunnel-cli"
+ sudo install ~/bin/devtunnel /usr/local/bin
+ rm ~/bin/devtunnel
+}
diff --git a/devtunnel-cli-git.install b/devtunnel-cli-git.install
new file mode 100644
index 000000000000..5cafc32588ba
--- /dev/null
+++ b/devtunnel-cli-git.install
@@ -0,0 +1,3 @@
+post_remove() {
+ sudo rm /usr/local/bin/devtunnel
+} \ No newline at end of file