summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-10-24 23:25:45 +0200
committerhaawda2022-10-24 23:25:45 +0200
commitd85026701d3b70bef18a537f17b89b3f183c1e1c (patch)
tree30230c9e8cb9f607af4d75d9d4a96304e76edbff
parent2a51fc6202d8b316381a62f41246a053676a235a (diff)
downloadaur-dex-git.tar.gz
adopted
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a33a76990dc9..288f5f69eff0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = dex-git
pkgdesc = Program to generate and execute DesktopEntry files of type Application
- pkgver = 83.864be05
+ pkgver = 0.8.0.r38.gd68c5d0
pkgrel = 1
+ epoch = 1
url = https://github.com/jceb/dex
arch = any
license = GPL2
@@ -14,4 +15,3 @@ pkgbase = dex-git
md5sums = SKIP
pkgname = dex-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e8b4506b6a62..94d4a2a504c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
-# Maintainer: Krystian Chachuła <krystiancha@gmail.com>
+# Contributor: Krystian Chachuła <krystiancha@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=dex-git
-pkgver=83.864be05
+pkgver=0.8.0.r38.gd68c5d0
pkgrel=1
-
+epoch=1
pkgdesc='Program to generate and execute DesktopEntry files of type Application'
url='https://github.com/jceb/dex'
arch=('any')
license=('GPL2')
-
depends=('python')
makedepends=('git' 'python-sphinx')
-
provides=('dex')
conflicts=('dex')
-
source=("git+https://github.com/jceb/dex.git")
-
md5sums=('SKIP')
pkgver() {
cd "$srcdir/dex"
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ echo $(git describe | cut -c2- | sed 's+-+.r+'| tr - .)
}
package() {
@@ -29,5 +26,3 @@ package() {
make install PREFIX=/usr MANPREFIX=/usr/share/man DESTDIR="$pkgdir"
rm "$pkgdir/usr/share/doc/dex/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: