summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-03-23 23:56:47 +0100
committerChristopher Arndt2018-03-23 23:56:47 +0100
commit3330ab4095dea8c661a76499b03ece4b37a547c3 (patch)
tree74ea45a4a1a491792cb24a12b0056d276ad72202
downloadaur-3330ab4095dea8c661a76499b03ece4b37a547c3.tar.gz
New package 'dexed-git' as replacement for 'dexed-vst-git'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore6
-rw-r--r--ChangeLog50
-rw-r--r--PKGBUILD57
-rw-r--r--dexed.desktop10
5 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c047a01634cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = dexed-git
+ pkgdesc = A software synth closely modelled on the Yamaha DX7 (git version)
+ pkgver = 0.9.4.r226.a08cc25
+ pkgrel = 2
+ url = http://asb2m10.github.io/dexed/
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ groups = vst-plugins
+ license = GPL3
+ makedepends = git
+ makedepends = juce
+ makedepends = steinberg-vst36
+ depends = alsa-lib
+ depends = curl
+ depends = hicolor-icon-theme
+ depends = freetype2
+ depends = libxinerama
+ provides = dexed
+ conflicts = dexed
+ conflicts = dexed-vst-git
+ source = dexed::git+https://github.com/asb2m10/dexed.git
+ source = dexed.desktop
+ md5sums = SKIP
+ md5sums = d888f8f2c1a44ed75c77d43faee73361
+
+pkgname = dexed-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fec96bca778a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+dexed/
+src/
+pkg/
+dexed-git-*.tar.xz
+dexed-git-*.src.tar.gz
+.AURINFO
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..404a1df59f8e
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,50 @@
+2018-03-23 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.9.4.r226.a08cc25-2
+ renamed package to 'dexed-git'
+
+2018-03-23 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.9.4.r226.a08cc25-1
+ enable JACK audio output for standalone version
+ added 'juce' to makedepends
+ added 'hicolor-icon-theme' to depends
+ added desktop file
+ install icon and desktop file
+
+2018-03-20 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ 0.9.4.r222.618b318-2
+ fixed missing new dependencies
+
+2018-03-20 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ 0.9.4.r222.618b318-1
+ install new standalone version of dexed
+
+2017-06-15 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.9.4.r175.d14ac25-1
+ removed gcc-libs-multilib dependency
+
+2016-11-28 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.9.2.r153.47b947d
+ fixed pkgver()
+
+2016-08-14 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.9.1.r127.3d95dff-2:
+ use steinberg-vst36 AUR package instead of including VST3 SDK in sources
+ Fix compilations error relating to lround function
+
+2016-02-29 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.9.1.r127.3d95dff-1:
+ new upstream version 0.9.1
+
+2015-07-12 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.9.0.r112.39d3c28-1:
+ add VST3 SDK to sources, since it can be downloaded from Steinberg's
+ website now without login
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f797baf5bb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=dexed
+pkgname="${_pkgname}-git"
+pkgver=0.9.4.r226.a08cc25
+pkgrel=2
+pkgdesc="A software synth closely modelled on the Yamaha DX7 (git version)"
+arch=('i686' 'x86_64')
+url="http://asb2m10.github.io/dexed/"
+license=("GPL3")
+groups=('vst-plugins')
+depends=('alsa-lib' 'curl' 'hicolor-icon-theme' 'freetype2' 'libxinerama')
+makedepends=('git' 'juce' 'steinberg-vst36')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}" "${_pkgname}-vst-git")
+source=("${_pkgname}::git+https://github.com/asb2m10/dexed.git"
+ 'dexed.desktop')
+md5sums=('SKIP'
+ 'd888f8f2c1a44ed75c77d43faee73361')
+changelog=ChangeLog
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ local ver=$(cpp -dM Source/Dexed.h | grep '^#define DEXED_ID' | cut -d '"' -f 2)
+ echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${_pkgname}"
+
+ msg2 "Enabling JACK audio in Dexed JUCE project file..."
+ sed -i -e 's|JUCE_JACK="0"|JUCE_JACK="1"|' Dexed.jucer
+ Projucer --resave Dexed.jucer
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}/Builds/Linux"
+
+ make CONFIG=Release
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ # install VST plugin
+ install -Dm755 Builds/Linux/build/Dexed.so "${pkgdir}/usr/lib/vst/Dexed.so"
+ # install standalone program
+ install -Dm755 Builds/Linux/build/Dexed "${pkgdir}/usr/bin/dexed"
+
+ # install icon and desktop file
+ install -Dm755 Resources/ui/dexedIcon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/dexed.png"
+ install -Dm755 "${srcdir}/dexed.desktop" "${pkgdir}/usr/share/applications/dexed.desktop"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dexed.desktop b/dexed.desktop
new file mode 100644
index 000000000000..cba4e43d9e35
--- /dev/null
+++ b/dexed.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=dexed
+Comment=A software synth closely modelled on the Yamaha DX7
+TryExec=dexed
+Exec=dexed %F
+Icon=dexed
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;Audio;Midi;Music