summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-10-20 14:48:16 +0200
committerChristopher Arndt2020-10-20 14:48:16 +0200
commit52d747941a53bc98d136174146d8081a862dea8b (patch)
treee72160afc9b8c54c3224b87ef51078ae3b868a39
parent4e6dc5db4295d39938e14ad381cae075cd7df926 (diff)
downloadaur-52d747941a53bc98d136174146d8081a862dea8b.tar.gz
Adapt to upstream changes (see ChangeLog for details)
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO9
-rw-r--r--ChangeLog8
-rw-r--r--PKGBUILD18
3 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 292529e61cf3..29b56df2128e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dexed-git
pkgdesc = A software synth closely modelled on the Yamaha DX7 (git version)
- pkgver = 0.9.4hf1.r57.g2ebdf1e
+ pkgver = 0.9.5.r3.gdb90ad7
pkgrel = 1
url = http://asb2m10.github.io/dexed/
changelog = ChangeLog
@@ -10,23 +10,20 @@ pkgbase = dexed-git
groups = vst-plugins
license = GPL3
makedepends = git
- makedepends = steinberg-vst36
depends = alsa-lib
- depends = curl
depends = hicolor-icon-theme
depends = freetype2
- depends = libxinerama
provides = dexed
conflicts = dexed
conflicts = dexed-vst-git
source = dexed::git+https://github.com/asb2m10/dexed.git
- source = https://d30pueezughrda.cloudfront.net/juce/juce-5.4.7-linux.zip
+ source = https://github.com/juce-framework/JUCE/releases/download/6.0.1/juce-6.0.1-linux.zip
source = git+https://github.com/steinbergmedia/vst3sdk.git
source = git+https://github.com/surge-synthesizer/tuning-library.git
source = git+https://github.com/surge-synthesizer/surgesynthteam_tuningui.git
source = dexed.desktop
sha256sums = SKIP
- sha256sums = 6f259573553a26951e896ed8d0737f78c3db7668894adc699a1e517aafe76e39
+ sha256sums = dcaac2c8a9f752ffd8d65325cea9224421f018786c229b46fdbc0cba180c5737
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/ChangeLog b/ChangeLog
index 4279d6391461..1bb625f3c245 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2020-10-20 Christopher Arndt <aur -at- chrisarndt -dot- de>
+ * 0.9.5.r3.gdb90ad7-1
+ * Update JUCE to 6.0.1
+ * VST2 no longer supported / built
+ * Provides VST3 plugin instead
+ * Consequently remove 'steinberg-vst36' make dependency
+ * Remove obsolete 'curl' and 'libxinerama' dependencies
+
2020-04-27 Christopher Arndt <aur -at- chrisarndt -dot- de>
* 0.9.4hf1.r57.g2ebdf1e-1
diff --git a/PKGBUILD b/PKGBUILD
index cbeebec58ac2..f1ba5eaec1f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=dexed
-_juce_version=5.4.7
+_juce_version=6.0.1
pkgname="${_pkgname}-git"
-pkgver=0.9.4hf1.r57.g2ebdf1e
+pkgver=0.9.5.r3.gdb90ad7
pkgrel=1
pkgdesc="A software synth closely modelled on the Yamaha DX7 (git version)"
arch=('i686' 'x86_64')
url="http://asb2m10.github.io/dexed/"
license=("GPL3")
groups=('pro-audio' 'vst-plugins')
-depends=('alsa-lib' 'curl' 'hicolor-icon-theme' 'freetype2' 'libxinerama')
-makedepends=('git' 'steinberg-vst36')
+depends=('alsa-lib' 'hicolor-icon-theme' 'freetype2')
+makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}" "${_pkgname}-vst-git")
source=("${_pkgname}::git+https://github.com/asb2m10/dexed.git"
- "https://d30pueezughrda.cloudfront.net/juce/juce-${_juce_version}-linux.zip"
+ "https://github.com/juce-framework/JUCE/releases/download/${_juce_version}/juce-${_juce_version}-linux.zip"
'git+https://github.com/steinbergmedia/vst3sdk.git'
'git+https://github.com/surge-synthesizer/tuning-library.git'
'git+https://github.com/surge-synthesizer/surgesynthteam_tuningui.git'
'dexed.desktop')
sha256sums=('SKIP'
- '6f259573553a26951e896ed8d0737f78c3db7668894adc699a1e517aafe76e39'
+ 'dcaac2c8a9f752ffd8d65325cea9224421f018786c229b46fdbc0cba180c5737'
'SKIP'
'SKIP'
'SKIP'
@@ -48,7 +48,7 @@ prepare() {
mkdir -p assets
ln -sf "${srcdir}/JUCE" assets
- VST2SDK_DIR="/usr/include/vst36" ./scripts/projuce-lin-vst2.sh
+ ./scripts/projuce-lin.sh
}
build() {
@@ -60,8 +60,8 @@ package() {
cd "${srcdir}/${_pkgname}"
# install VST plugin
- install -Dm755 Builds/Linux/build/Dexed.so \
- "${pkgdir}/usr/lib/vst/Dexed.so"
+ install -Dm755 Builds/Linux/build/Dexed.vst3/Contents/$(uname -m)-linux/Dexed.so \
+ -t "${pkgdir}/usr/lib/vst/Dexed.vst3/Contents/$(uname -m)-linux/"
# install standalone program
install -Dm755 Builds/Linux/build/Dexed \
"${pkgdir}/usr/bin/dexed"