summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-03-05 17:23:22 +0100
committerChristopher Arndt2021-03-05 17:23:22 +0100
commita01f98c2ec69e99a6e31543428b02abc7f8d4434 (patch)
treecf5c061c3a2f2d18355de29b1156bfb20d4a4a9c
parent7233f840a23ccdf0170b642291c471076982a236 (diff)
downloadaur-a01f98c2ec69e99a6e31543428b02abc7f8d4434.tar.gz
Updated PKGBUILD for build commands changes in 0.9.6
Also updated JUCE to 6.0.7 Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1657595ab71e..ea4b3dac8ff3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dexed-git
pkgdesc = A software synth closely modelled on the Yamaha DX7 (git version)
- pkgver = 0.9.5.r9.g7026151
+ pkgver = 0.9.6.r0.g11ae4d7
pkgrel = 1
url = http://asb2m10.github.io/dexed/
changelog = ChangeLog
@@ -25,13 +25,13 @@ pkgbase = dexed-git
conflicts = dexed
conflicts = dexed-vst-git
source = dexed::git+https://github.com/asb2m10/dexed.git
- source = https://github.com/juce-framework/JUCE/releases/download/6.0.1/juce-6.0.1-linux.zip
+ source = https://github.com/juce-framework/JUCE/releases/download/6.0.7/juce-6.0.7-linux.zip
source = git+https://github.com/steinbergmedia/vst3sdk.git
source = git+https://github.com/surge-synthesizer/tuning-library.git
source = git+https://github.com/surge-synthesizer/surgesynthteam_tuningui.git
source = dexed.desktop
sha256sums = SKIP
- sha256sums = dcaac2c8a9f752ffd8d65325cea9224421f018786c229b46fdbc0cba180c5737
+ sha256sums = 05f794e8cf94acb06a622484a3644743e27fdc4de590dff1c77f2f360dad2415
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d3101964a90e..88debec8886b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=dexed
-_juce_version=6.0.1
+_juce_version=6.0.7
pkgname="${_pkgname}-git"
-pkgver=0.9.5.r9.g7026151
+pkgver=0.9.6.r0.g11ae4d7
pkgrel=1
pkgdesc="A software synth closely modelled on the Yamaha DX7 (git version)"
arch=('i686' 'x86_64')
@@ -23,7 +23,7 @@ source=("${_pkgname}::git+https://github.com/asb2m10/dexed.git"
'git+https://github.com/surge-synthesizer/surgesynthteam_tuningui.git'
'dexed.desktop')
sha256sums=('SKIP'
- 'dcaac2c8a9f752ffd8d65325cea9224421f018786c229b46fdbc0cba180c5737'
+ '05f794e8cf94acb06a622484a3644743e27fdc4de590dff1c77f2f360dad2415'
'SKIP'
'SKIP'
'SKIP'
@@ -36,7 +36,7 @@ pkgver() {
#local ver=$(cpp -dM Source/Dexed.h | grep '^#define DEXED_ID' | cut -d '"' -f 2)
#echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
- echo $(git describe --tags | sed -E -e 's/-([0-9]+)-/-r\1-/' -e 's/^v//' -e 's/-/./g')
+ echo $(git describe --tags --long | sed -E -e 's/-([0-9]+)-/-r\1-/' -e 's/^v//' -e 's/-/./g')
}
prepare() {
@@ -50,7 +50,7 @@ prepare() {
mkdir -p assets
ln -sf "${srcdir}/JUCE" assets
- ./scripts/projuce-lin.sh
+ ./assets/JUCE/Projucer --resave Dexed.jucer
}
build() {