summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZiusudra2022-12-04 23:04:10 -0700
committerZiusudra2022-12-04 23:04:10 -0700
commitaae247126e1cd6b3c96dae5c078bca6103833dc8 (patch)
treecc828d93b7975650fa831141e184f65e93270949
parentbae742b2b4ba6470b0010cf4520b78f55907f7f7 (diff)
downloadaur-dfhack.tar.gz
dfhack-0.47.05-r8 +updated patches
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--Wno-array-bounds-gtest.patch12
-rw-r--r--Wno-restrict-modules.patch11
-rw-r--r--Wno-restrict-plugins.patch12
-rw-r--r--Wno-restrict.patch12
6 files changed, 56 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0e0eda58e38..2a7479086743 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dfhack
pkgdesc = memory hacking library for Dwarf Fortress and a set of tools that use it
pkgver = 0.47.05
- pkgrel = 10
+ pkgrel = 11
url = https://dfhack.readthedocs.io/en/stable/
arch = x86_64
arch = i686
@@ -24,13 +24,17 @@ pkgbase = dfhack
depends = libxcrypt-compat
conflicts = dfhack-bin
conflicts = dfhack-git
- source = dfhack::git+https://github.com/DFHack/dfhack#tag=0.47.05-r7
+ source = dfhack::git+https://github.com/DFHack/dfhack#tag=0.47.05-r8
source = dfhack.sh
source = dfhack-run.sh
- source = Wno-restrict.patch
+ source = Wno-array-bounds-gtest.patch
+ source = Wno-restrict-modules.patch
+ source = Wno-restrict-plugins.patch
md5sums = SKIP
md5sums = 45ab3b65cb5b01beff9fecccff777f85
md5sums = 37421a6cf2ca420bed4420ea8e402d40
- md5sums = 086fc32900f4c6589a06ac1c7acc6e98
+ md5sums = 833927da48cf98ae0a4f0e7133a64e8b
+ md5sums = 5d4089692561a2b7f62e35be4e78fca3
+ md5sums = f011e03da6118390ebebcd90763cde95
pkgname = dfhack
diff --git a/PKGBUILD b/PKGBUILD
index 6eacc28eb6dc..43bcd5aef7da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=dfhack
pkgver=0.47.05
-_pkgver=$pkgver-r7
-pkgrel=10
+_pkgver=$pkgver-r8
+pkgrel=11
pkgdesc="memory hacking library for Dwarf Fortress and a set of tools that use it"
arch=('x86_64' 'i686')
url="https://dfhack.readthedocs.io/en/stable/"
@@ -19,12 +19,16 @@ conflicts=('dfhack-bin' 'dfhack-git')
source=("$pkgname::git+https://github.com/DFHack/dfhack#tag=$_pkgver"
dfhack.sh
dfhack-run.sh
- Wno-restrict.patch)
+ Wno-array-bounds-gtest.patch
+ Wno-restrict-modules.patch
+ Wno-restrict-plugins.patch)
md5sums=('SKIP'
'45ab3b65cb5b01beff9fecccff777f85'
'37421a6cf2ca420bed4420ea8e402d40'
- '086fc32900f4c6589a06ac1c7acc6e98')
+ '833927da48cf98ae0a4f0e7133a64e8b'
+ '5d4089692561a2b7f62e35be4e78fca3'
+ 'ca1f96739f5013608852e340b41eda31')
prepare() {
# shellcheck disable=2154
@@ -34,9 +38,12 @@ prepare() {
git submodule sync
git submodule update --init
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname"
# gcc issue - https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105329
- patch --strip=1 --input="${srcdir}/Wno-restrict.patch"
+ patch --strip=1 --input="${srcdir}/Wno-restrict-modules.patch"
+ patch --strip=1 --input="${srcdir}/Wno-restrict-plugins.patch"
+ # looks like another gcc issue but I don't actually know
+ patch --strip=1 --input="${srcdir}/Wno-array-bounds-gtest.patch"
}
build() {
diff --git a/Wno-array-bounds-gtest.patch b/Wno-array-bounds-gtest.patch
new file mode 100644
index 000000000000..6baa61efa06a
--- /dev/null
+++ b/Wno-array-bounds-gtest.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text dfhack/depends/CMakeLists.txt dfhack.new/depends/CMakeLists.txt
+--- dfhack/depends/CMakeLists.txt 2022-12-02 22:34:28.530386074 -0700
++++ dfhack.new/depends/CMakeLists.txt 2022-12-03 21:32:03.853149929 -0700
+@@ -8,7 +8,7 @@
+ option(INSTALL_GTEST "Enable installation of googletest. (Projects embedding googletest may want to turn this OFF.)" OFF)
+ add_subdirectory(googletest)
+ if(UNIX)
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-Wno-maybe-uninitialized -Wno-sign-compare")
++ set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-Wno-maybe-uninitialized -Wno-sign-compare -Wno-array-bounds")
+ endif()
+ endif()
+
diff --git a/Wno-restrict-modules.patch b/Wno-restrict-modules.patch
new file mode 100644
index 000000000000..4e806e480737
--- /dev/null
+++ b/Wno-restrict-modules.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text dfhack/library/CMakeLists.txt dfhack.new/library/CMakeLists.txt
+--- dfhack/library/CMakeLists.txt 2022-12-04 00:58:10.697225422 -0700
++++ dfhack.new/library/CMakeLists.txt 2022-12-04 01:16:14.329282824 -0700
+@@ -208,6 +208,7 @@
+ list(APPEND PROJECT_SOURCES ${MAIN_SOURCES_DARWIN})
+ else()
+ list(APPEND PROJECT_SOURCES ${MAIN_SOURCES_LINUX})
++ set_source_files_properties(${MODULE_SOURCES} PROPERTIES COMPILE_FLAGS "-Wno-restrict")
+ endif()
+ elseif(WIN32)
+ list(APPEND PROJECT_SOURCES ${MAIN_SOURCES_WINDOWS})
diff --git a/Wno-restrict-plugins.patch b/Wno-restrict-plugins.patch
new file mode 100644
index 000000000000..79a8a5d28742
--- /dev/null
+++ b/Wno-restrict-plugins.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text dfhack/plugins/Plugins.cmake dfhack.new/plugins/Plugins.cmake
+--- dfhack/plugins/Plugins.cmake 2022-12-04 19:58:58.989881762 -0700
++++ dfhack.new/plugins/Plugins.cmake 2022-12-04 20:01:02.600600673 -0700
+@@ -140,7 +140,7 @@
+ else()
+ set(PLUGIN_COMPILE_FLAGS "${PLUGIN_COMPILE_FLAGS} ${PLUGIN_COMPILE_FLAGS_MSVC}")
+ endif()
+- set_target_properties(${PLUGIN_NAME} PROPERTIES COMPILE_FLAGS "${PLUGIN_COMPILE_FLAGS}")
++ set_target_properties(${PLUGIN_NAME} PROPERTIES COMPILE_FLAGS "${PLUGIN_COMPILE_FLAGS} -Wno-restrict")
+
+ if(APPLE)
+ set_target_properties(${PLUGIN_NAME} PROPERTIES SUFFIX .plug.dylib PREFIX "")
diff --git a/Wno-restrict.patch b/Wno-restrict.patch
deleted file mode 100644
index 8b43305f7d3e..000000000000
--- a/Wno-restrict.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --unified --recursive --text dfhack/CMakeLists.txt dfhack.new/CMakeLists.txt
---- dfhack/CMakeLists.txt 2022-07-29 03:02:00.924080839 -0600
-+++ dfhack.new/CMakeLists.txt 2022-07-29 03:43:33.584455373 -0600
-@@ -244,7 +244,7 @@
- # enable C++11 features
- add_definitions(-DLINUX_BUILD)
- add_definitions(-D_GLIBCXX_USE_C99)
-- set(GCC_COMMON_FLAGS "-fvisibility=hidden -mtune=generic -Wall -Werror")
-+ set(GCC_COMMON_FLAGS "-fvisibility=hidden -mtune=generic -Wall -Werror -Wno-restrict")
- set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -g")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${GCC_COMMON_FLAGS}")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${GCC_COMMON_FLAGS}")