summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2024-03-09 23:26:04 -0700
committerBrian Bidulock2024-03-09 23:26:04 -0700
commit87c77b6bcd5f666277a2c7e04c019b04a66ddb19 (patch)
treecad2db48ca41c7c24bd58adcf47084bd2b8a6d26
parent3743111a2f5519e85cf0d012440eca6046724133 (diff)
downloadaur-dhcpcd-ui.tar.gz
updates
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 896ca93141c0..5015c9d8d9d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = dhcpcd-ui
pkgdesc = dhcpcd Monitor in GTK+
pkgver = 0.7.9
- pkgrel = 1
+ pkgrel = 2
url = http://roy.marples.name/projects/dhcpcd-ui
arch = i686
arch = x86_64
- license = BSD
+ license = BSD-2-Clause
makedepends = python-cairosvg
makedepends = python-xcffib
depends = gtk2
depends = libnotify
- depends = dhcpcd-dbus>=0.6.0
depends = hicolor-icon-theme
source = https://github.com/NetworkConfiguration/dhcpcd-ui/releases/download/v0.7.9/dhcpcd-ui-0.7.9.tar.xz
md5sums = e3b0b1506688c71742a65a76c740a0e0
diff --git a/PKGBUILD b/PKGBUILD
index d9dbcf3d9d09..abb952011d58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: nizox <nizzox@gmail.com>
pkgname=dhcpcd-ui
pkgver=0.7.9
-pkgrel=1
+pkgrel=2
pkgdesc="dhcpcd Monitor in GTK+"
url="http://roy.marples.name/projects/dhcpcd-ui"
-license=("BSD")
-depends=("gtk2" "libnotify" "dhcpcd-dbus>=0.6.0" "hicolor-icon-theme")
+license=(BSD-2-Clause)
+depends=("gtk2" "libnotify" "hicolor-icon-theme")
makedepends=("python-cairosvg" "python-xcffib")
#source=(http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.xz)
source=("https://github.com/NetworkConfiguration/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
@@ -16,13 +16,13 @@ md5sums=('e3b0b1506688c71742a65a76c740a0e0')
build() {
cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --icondir=/usr/share/icons --without-qt
+ ./configure --prefix=/usr --sysconfdir=/etc --without-qt
make
}
package() {
cd $srcdir/$pkgname-$pkgver
- make DESTDIR="$pkgdir/" AUTOSTARTDIR=/etc/xdg/autostart install
+ make DESTDIR="$pkgdir/" AUTOSTARTDIR=/etc/xdg/autostart ICONDIR=/usr/share/icons install
install -d "$pkgdir/usr/share/licenses/$pkgname"
sed -n '1,/^$/p' src/dhcpcd-gtk/main.c \