summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-26 11:33:25 -0500
committerLuis Martinez2021-05-26 11:33:25 -0500
commite175943720ab06e73a13967ce10b81ef24ad9cd2 (patch)
tree8a712fb19baa8bdbe48e0b81d9ffa5586a22fef0
downloadaur-diary-bin.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..babfe7ed1427
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = diary-bin
+ pkgdesc = Encrypted memories -- a journal program with local encryption support (binary release)
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/actuday6418/diary
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ provides = diary
+ conflicts = diary
+ source = diary-bin-0.1.2::https://github.com/actuday6418/diary/releases/download/0.1.2/diary
+ source = README-0.1.2.md::https://raw.githubusercontent.com/actuday6418/diary/0.1.2/README.md
+ sha256sums = c5f95be4088e353b965268460fe46caabb2d2dd836fcd068d855d2be38889661
+ sha256sums = 4a7ab6592482adf9da57d64cab3fac2721768065cdf46e64172ced9db7c1d7e3
+
+pkgname = diary-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb66617743fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=diary-bin
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Encrypted memories -- a journal program with local encryption support (binary release)"
+arch=('x86_64')
+url="https://github.com/actuday6418/diary"
+license=('GPL3')
+depends=('gcc-libs')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("$pkgname-$pkgver::$url/releases/download/$pkgver/diary"
+ "README-$pkgver.md::https://raw.githubusercontent.com/actuday6418/diary/$pkgver/README.md")
+sha256sums=('c5f95be4088e353b965268460fe46caabb2d2dd836fcd068d855d2be38889661'
+ '4a7ab6592482adf9da57d64cab3fac2721768065cdf46e64172ced9db7c1d7e3')
+
+package() {
+ install -Dvm 755 "$pkgname-$pkgver" "$pkgdir/usr/bin/diary"
+ install -Dvm 644 "README-$pkgver.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+