summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-19 08:17:36 +0800
committerzxp198210052024-03-19 08:17:36 +0800
commit29d160f569f0ef1ab7e5539180d96e8242bd23e9 (patch)
treefe4c7be14f11f82c3f001ed1c4ac2c4d627e47b7
parent6d466bf19c9be769af8b85ef570810daf62d85b4 (diff)
downloadaur-dicionario.js-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--dicionario.js.sh5
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bb7a5b6ee1e..aaacf2ffaeaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dicionario.js-bin
pkgdesc = Simple dictionary in which you record your own words.
pkgver = 2.7.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ArthurLobopro/dicionario.js
arch = x86_64
license = MIT
@@ -12,6 +12,6 @@ pkgbase = dicionario.js-bin
source = dicionario.js-2.7.5.deb::https://github.com/ArthurLobopro/dicionario.js/releases/download/v2.7.5/dicionario.js_2.7.5_amd64.deb
source = dicionario.js.sh
sha256sums = 354d3d518cb64f07dbadb9989dfc43702f234c0fb2e330822b97fb36215b033a
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = dicionario.js-bin
diff --git a/PKGBUILD b/PKGBUILD
index c76bd9fc7354..4950cd9acdcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dicionario.js-bin
pkgver=2.7.5
_electronversion=28
-pkgrel=1
+pkgrel=2
pkgdesc="Simple dictionary in which you record your own words."
arch=('x86_64')
url="https://github.com/ArthurLobopro/dicionario.js"
@@ -18,11 +18,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('354d3d518cb64f07dbadb9989dfc43702f234c0fb2e330822b97fb36215b033a'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
}
diff --git a/dicionario.js.sh b/dicionario.js.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/dicionario.js.sh
+++ b/dicionario.js.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file