summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2023-03-13 12:04:29 +0100
committerTaijian2023-03-13 12:04:29 +0100
commit1d221e8f3692c6eb8b43d3b5e15e87c8b3c75de3 (patch)
tree62d964103ea9cb65eea3aa6cfbdaf2d814885c20
parent859ead965dae763e1b88e292f57cbfc7d7a2af88 (diff)
downloadaur-1d221e8f3692c6eb8b43d3b5e15e87c8b3c75de3.tar.gz
update to 7.10.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
-rw-r--r--f2f86c3c.patch61
3 files changed, 6 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 754f577fd95f..61bedd5830a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = digikam-without-akonadi-mediawiki-vkontakte
pkgdesc = An advanced digital photo management application
- pkgver = 7.9.0
+ pkgver = 7.10.0
pkgrel = 1
url = https://www.digikam.org/
arch = x86_64
@@ -32,14 +32,12 @@ pkgbase = digikam-without-akonadi-mediawiki-vkontakte
provides = digikam
conflicts = digikam
conflicts = digikam-git
- source = https://download.kde.org/stable/digikam/7.9.0/digiKam-7.9.0.tar.xz
- source = https://download.kde.org/stable/digikam/7.9.0/digiKam-7.9.0.tar.xz.sig
- source = f2f86c3c.patch
+ source = https://download.kde.org/stable/digikam/7.10.0/digiKam-7.10.0.tar.xz
+ source = https://download.kde.org/stable/digikam/7.10.0/digiKam-7.10.0.tar.xz.sig
source = ffmpeg5.patch
validpgpkeys = D1CF2444A7858C5F2FB095B74A77747BC2386E50
- sha256sums = c3b80abc090da3cbbc42e67a403080d7f5fe0a7c98698735bda556c60314bab4
+ sha256sums = a3f30f01b7d1b6d585822bcd5ebf8df69e0ff024563a72462ebf8069dbda22e1
sha256sums = SKIP
- sha256sums = 93e3bf4a6d8118db45171acbab51381ee0806a98f3dc5be7f32727445ea80ac1
sha256sums = ef2601f9b2e668116a3643b4bd7ddcfc233ccfc747d813955423ca17b6a23dee
pkgname = digikam-without-akonadi-mediawiki-vkontakte
diff --git a/PKGBUILD b/PKGBUILD
index e1c8c4da13eb..92569cf6551e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=digikam
pkgname=digikam-without-akonadi-mediawiki-vkontakte
-_pkgver=7.9.0
+_pkgver=7.10.0
pkgver=${_pkgver//-/_} # for beta versions
pkgrel=1
pkgdesc='An advanced digital photo management application'
@@ -23,17 +23,14 @@ optdepends=('hugin: panorama tool' 'qt5-imageformats: support for additional ima
'rawtherapee: RAW import' 'darktable: RAW import'
'perl: for digitaglinktree')
source=(https://download.kde.org/stable/$_pkgname/$pkgver/digiKam-$_pkgver.tar.xz{,.sig}
- f2f86c3c.patch
ffmpeg5.patch)
-sha256sums=('c3b80abc090da3cbbc42e67a403080d7f5fe0a7c98698735bda556c60314bab4'
+sha256sums=('a3f30f01b7d1b6d585822bcd5ebf8df69e0ff024563a72462ebf8069dbda22e1'
'SKIP'
- '93e3bf4a6d8118db45171acbab51381ee0806a98f3dc5be7f32727445ea80ac1'
'ef2601f9b2e668116a3643b4bd7ddcfc233ccfc747d813955423ca17b6a23dee')
validpgpkeys=(D1CF2444A7858C5F2FB095B74A77747BC2386E50) # digiKam.org (digiKam project) <digikamdeveloper@gmail.com>
prepare() {
patch -d $_pkgname-$_pkgver -p1 < ffmpeg5.patch # Fix build with FFmpeg 5
- patch -d $_pkgname-$_pkgver -p1 < f2f86c3c.patch # Fix crashes on face recognition
}
build() {
diff --git a/f2f86c3c.patch b/f2f86c3c.patch
deleted file mode 100644
index 2cc222987cc2..000000000000
--- a/f2f86c3c.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From f2f86c3c6719e4ea0bc7de95ce1ae33e8c45495e Mon Sep 17 00:00:00 2001
-From: Maik Qualmann <metzpinguin@gmail.com>
-Date: Sun, 29 Jan 2023 21:30:24 +0100
-Subject: [PATCH] fix crash with the release version of OpenCV-4.7.0 The
- problem is already fixed with the master version of OpenCV. BUGS: 464646
- BUGS: 464745 FIXED-IN: 7.10.0
-
-diff --git a/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectorssd.cpp b/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectorssd.cpp
-index e178ea435a..e0f9eda6c7 100644
---- a/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectorssd.cpp
-+++ b/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectorssd.cpp
-@@ -78,6 +78,12 @@ bool DNNFaceDetectorSSD::loadModels()
- net = cv::dnn::readNetFromCaffe(nnmodel.toStdString(),
- nndata.toStdString());
-
-+#endif
-+
-+#if (OPENCV_VERSION == QT_VERSION_CHECK(4, 7, 0))
-+
-+ net.enableWinograd(false);
-+
- #endif
-
- }
-diff --git a/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectoryolo.cpp b/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectoryolo.cpp
-index 3524d07071..0624a745f6 100644
---- a/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectoryolo.cpp
-+++ b/core/libs/facesengine/detection/opencv-dnn/dnnfacedetectoryolo.cpp
-@@ -89,6 +89,13 @@ bool DNNFaceDetectorYOLO::loadModels()
-
- net.setPreferableBackend(cv::dnn::DNN_BACKEND_DEFAULT);
- net.setPreferableTarget(cv::dnn::DNN_TARGET_CPU);
-+
-+#if (OPENCV_VERSION == QT_VERSION_CHECK(4, 7, 0))
-+
-+ net.enableWinograd(false);
-+
-+#endif
-+
- }
- catch (cv::Exception& e)
- {
-diff --git a/core/libs/facesengine/recognition/opencv-dnn/dnnfaceextractor.cpp b/core/libs/facesengine/recognition/opencv-dnn/dnnfaceextractor.cpp
-index e9a2fe9efb..7067af2590 100644
---- a/core/libs/facesengine/recognition/opencv-dnn/dnnfaceextractor.cpp
-+++ b/core/libs/facesengine/recognition/opencv-dnn/dnnfaceextractor.cpp
-@@ -149,6 +149,12 @@ bool DNNFaceExtractor::loadModels()
-
- d->net = cv::dnn::readNetFromTorch(nnmodel.toStdString());
-
-+#endif
-+
-+#if (OPENCV_VERSION == QT_VERSION_CHECK(4, 7, 0))
-+
-+ d->net.enableWinograd(false);
-+
- #endif
-
- }
---
-GitLab