summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblackhole2021-04-17 10:26:23 +0200
committerblackhole2021-04-17 10:26:23 +0200
commit7e68cfc8b13709d87f7f8bb2b87634da94e163b6 (patch)
tree714de0a2d05d86267e2bb95e887893a6d79eea65
parent8934d6d4359ebb0de3b1d1e6de10c54109ee95c3 (diff)
downloadaur-7e68cfc8b13709d87f7f8bb2b87634da94e163b6.tar.gz
Update to version 7.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64bdd1e8df8c..d2dd9f7f84f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = digikam-without-akonadi-mediawiki-vkontakte
pkgdesc = An advanced digital photo management application
- pkgver = 7.1.0
- pkgrel = 2
+ pkgver = 7.2.0
+ pkgrel = 1
url = https://www.digikam.org/
arch = x86_64
license = GPL
@@ -10,7 +10,6 @@ pkgbase = digikam-without-akonadi-mediawiki-vkontakte
makedepends = eigen
makedepends = boost
makedepends = kdoctools
- makedepends = jasper
depends = lensfun
depends = opencv
depends = knotifyconfig
@@ -31,13 +30,13 @@ pkgbase = digikam-without-akonadi-mediawiki-vkontakte
provides = digikam
conflicts = digikam
conflicts = digikam-git
- source = https://download.kde.org/stable/digikam/7.1.0/digikam-7.1.0.tar.xz
- source = https://download.kde.org/stable/digikam/7.1.0/digikam-7.1.0.tar.xz.sig
- source = showfoto-configure-crash.patch::https://invent.kde.org/graphics/digikam/-/commit/c79a1c6b.patch
+ source = https://download.kde.org/stable/digikam/7.2.0/digikam-7.2.0.tar.xz
+ source = https://download.kde.org/stable/digikam/7.2.0/digikam-7.2.0.tar.xz.sig
+ source = digikam-fix-build.patch::https://invent.kde.org/graphics/digikam/-/commit/b428a1fa.patch
validpgpkeys = D1CF2444A7858C5F2FB095B74A77747BC2386E50
- sha256sums = b103c8463adf04939583199e13f8e83015d8a4a9ad79ebfd502d2a50b5a5abbe
+ sha256sums = cd87ece143aefa02e692a4af5c3c3cc107b9a4d61804d79fa77dd2e344798a17
sha256sums = SKIP
- sha256sums = 86f775473462087f24fcf72257ba6f0b6001dca729fb7225ac38e88cd7a5f338
+ sha256sums = f2e951275896c9cb3195e5557482b675bdb5538a12caa6fdf57e309aa77596c1
pkgname = digikam-without-akonadi-mediawiki-vkontakte
diff --git a/PKGBUILD b/PKGBUILD
index 17959d4f5523..93a1160c340e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,30 +7,27 @@
_pkgname=digikam
pkgname=digikam-without-akonadi-mediawiki-vkontakte
-_pkgver=7.1.0
+_pkgver=7.2.0
pkgver=${_pkgver//-/_} # for beta versions
-pkgrel=2
+pkgrel=1
pkgdesc="An advanced digital photo management application"
arch=(x86_64)
license=(GPL)
url="https://www.digikam.org/"
-depends=(lensfun opencv knotifyconfig libksane kfilemetadata qtav marble-common threadweaver kcalendarcore
- qt5-xmlpatterns imagemagick glu)
-makedepends=(extra-cmake-modules doxygen eigen boost kdoctools jasper)
+depends=(lensfun opencv knotifyconfig libksane kfilemetadata qtav marble-common threadweaver kcalendarcore qt5-xmlpatterns imagemagick glu)
+makedepends=(extra-cmake-modules doxygen eigen boost kdoctools)
conflicts=('digikam' 'digikam-git')
provides=('digikam')
-optdepends=('hugin: panorama tool' 'qt5-imageformats: support for additional image formats (WEBP, TIFF)'
- 'rawtherapee: RAW import' 'darktable: RAW import'
- 'perl: for digitaglinktree')
-source=("https://download.kde.org/stable/$_pkgname/$pkgver/$_pkgname-$_pkgver.tar.xz"{,.sig}
-showfoto-configure-crash.patch::"https://invent.kde.org/graphics/digikam/-/commit/c79a1c6b.patch")
-sha256sums=('b103c8463adf04939583199e13f8e83015d8a4a9ad79ebfd502d2a50b5a5abbe'
+optdepends=('hugin: panorama tool' 'qt5-imageformats: support for additional image formats (WEBP, TIFF)' 'rawtherapee: RAW import' 'darktable: RAW import' 'perl: for digitaglinktree')
+source=(https://download.kde.org/stable/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.xz{,.sig}
+ digikam-fix-build.patch::https://invent.kde.org/graphics/digikam/-/commit/b428a1fa.patch)
+sha256sums=('cd87ece143aefa02e692a4af5c3c3cc107b9a4d61804d79fa77dd2e344798a17'
'SKIP'
- '86f775473462087f24fcf72257ba6f0b6001dca729fb7225ac38e88cd7a5f338')
+ 'f2e951275896c9cb3195e5557482b675bdb5538a12caa6fdf57e309aa77596c1')
validpgpkeys=(D1CF2444A7858C5F2FB095B74A77747BC2386E50) # digiKam.org (digiKam project) <digikamdeveloper@gmail.com>
prepare() {
- patch -d $srcdir/$_pkgname-$_pkgver -p1 -i ../showfoto-configure-crash.patch # Fix crash on showfoto configuration
+ patch -d $_pkgname-$_pkgver -p1 < digikam-fix-build.patch # Fix build with Qt post 5.15.2
}
build() {