summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayde Dixon2016-03-25 17:11:24 +1100
committerCayde Dixon2016-03-25 17:27:00 +1100
commitd28c41e1ce7065a0589ea67b383b64c0d0e66fcf (patch)
tree3e6908d202c9081f7bc54cf5a3c17d3f6b5ab206
downloadaur-d28c41e1ce7065a0589ea67b383b64c0d0e66fcf.tar.gz
Initial commit with DiscordCanary v0.0.0
-rw-r--r--.SRCINFO22
-rw-r--r--DiscordCanary.desktop9
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD42
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51271fe55601
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri Mar 25 06:26:40 UTC 2016
+pkgbase = discord-canary
+ pkgdesc = Discord Canary linux release
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://discordapp.com/
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ depends = gconf
+ optdepends = freetype2-infinality: If you have black screens with emojis install this.
+ provides = discord-canary
+ source = DiscordCanary.desktop
+ source = LICENSE
+ sha256sums = 851cf241f5f2418a4a5dc533e0060844ee5673f7cac563fd33e2584b09dbe2d0
+ sha256sums = 688f418cd32a682c6d331c211fedd48ff86ee8ba5a7640f589eadb32996af80f
+ source_x86_64 = https://storage.googleapis.com/discord-developer/test/discord-canary-0.0.0.tar.gz
+ sha256sums_x86_64 = 0edc1be19faf2e6401c408b1097901ce582222348f144e38c51749bd38ba3dd6
+
+pkgname = discord-canary
+
diff --git a/DiscordCanary.desktop b/DiscordCanary.desktop
new file mode 100644
index 000000000000..d9b4b9f1d6d8
--- /dev/null
+++ b/DiscordCanary.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Discord Canary
+Comment=All-in-one voice and text chat for gamers that's free, secure, and works on both your desktop and phone.
+GenericName=Internet Messenger
+Exec=/opt/discord-canary/
+Icon=/usr/share/pixmaps/discord-canary.png
+Type=Application
+StartupNotify=true
+Categories=Network;InstantMessaging;
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..afdc5112be2a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+Copyright (c) 2016 Hammer & Chisel
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60aeef3a301a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Cayde Dixon <me@cazzar.net>
+
+pkgname=discord-canary
+pkgver=0.0.0
+pkgrel=1
+pkgdesc='Discord Canary linux release'
+arch=('x86_64')
+url='https://discordapp.com/'
+provides=('discord-canary')
+license=('custom')
+depends=('gtk2' 'gconf')
+optdepends=('freetype2-infinality: If you have black screens with emojis install this.')
+
+source=(DiscordCanary.desktop LICENSE)
+source_x86_64=("https://storage.googleapis.com/discord-developer/test/discord-canary-${pkgver}.tar.gz")
+sha256sums=('851cf241f5f2418a4a5dc533e0060844ee5673f7cac563fd33e2584b09dbe2d0' '688f418cd32a682c6d331c211fedd48ff86ee8ba5a7640f589eadb32996af80f')
+sha256sums_x86_64=('0edc1be19faf2e6401c408b1097901ce582222348f144e38c51749bd38ba3dd6')
+
+package() {
+ # Install the main files.
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a "${srcdir}/DiscordCanary/." "${pkgdir}/opt/${pkgname}"
+
+ # Exec bit
+ chmod 755 "${pkgdir}/opt/${pkgname}/DiscordCanary"
+
+
+ # Desktop Entry
+ install -d "${pkgdir}/usr/share/applications"
+ install "${srcdir}/DiscordCanary.desktop" "${pkgdir}/usr/share/applications"
+
+ # Main binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/DiscordCanary" "${pkgdir}/usr/bin/DiscordCanary"
+
+ # Create symbolic link to the icon
+ install -d "${pkgdir}/usr/share/pixmaps"
+ ln -s "/opt/${pkgname}/discord.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}