summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2019-09-05 15:52:50 +0200
committerTim Schumacher2019-09-05 15:52:50 +0200
commite88e07c270f62fa168fe2ec37d98a5a16b6989d0 (patch)
treecba7a798ee236aa9c55a2bd8c571c4fc7be415b5
parent72302648da221739047feec44cf0b15d8d830ed6 (diff)
downloadaur-e88e07c270f62fa168fe2ec37d98a5a16b6989d0.tar.gz
Don't check Licenses sha512 and cut it down
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c90e5d362a1..724d5e75c83d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,10 +16,10 @@ pkgbase = discord-ptb
optdepends = xdg-utils: Open files
source = https://dl-ptb.discordapp.net/apps/linux/0.0.16/discord-ptb-0.0.16.tar.gz
source = LICENSE
- source = OSS-LICENSES.html::https://discordapp.com/licenses
+ source = OSS-LICENSES::https://discordapp.com/licenses
sha512sums = 654f2b600ebce5058dd74d5676a6d40e70a9eecf8351a61601206ccbcd88631fd25b42f0db532b5195285bb8e227d746d433d132b09fae4f77f5dfabc154f8c8
sha512sums = 2478ed8c0c3f086cfa9e6f8a7f8264a3a0f20364b940f888efe7a695f54f103523547e9b95db046776d7d9c820447436fbf65e557daf583947a6bbef5620971d
- sha512sums = 17ae8d140d1ec219b3328ef5d80cd53672ba31b5cc48194798379055eb9224f43c33dac806ce5648ac3ce7cdd2b691e0fcb0bb429601eb78c004f89e6b36f3bc
+ sha512sums = SKIP
pkgname = discord-ptb
diff --git a/PKGBUILD b/PKGBUILD
index d351de2b8750..a95e796d8371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,10 +15,10 @@ optdepends=('libpulse: Pulseaudio support'
'xdg-utils: Open files')
source=("https://dl-ptb.discordapp.net/apps/linux/$pkgver/$pkgname-$pkgver.tar.gz"
'LICENSE'
- 'OSS-LICENSES.html::https://discordapp.com/licenses')
+ 'OSS-LICENSES::https://discordapp.com/licenses')
sha512sums=('654f2b600ebce5058dd74d5676a6d40e70a9eecf8351a61601206ccbcd88631fd25b42f0db532b5195285bb8e227d746d433d132b09fae4f77f5dfabc154f8c8'
'2478ed8c0c3f086cfa9e6f8a7f8264a3a0f20364b940f888efe7a695f54f103523547e9b95db046776d7d9c820447436fbf65e557daf583947a6bbef5620971d'
- '17ae8d140d1ec219b3328ef5d80cd53672ba31b5cc48194798379055eb9224f43c33dac806ce5648ac3ce7cdd2b691e0fcb0bb429601eb78c004f89e6b36f3bc')
+ 'SKIP')
prepare() {
cd $_pkgname
@@ -50,6 +50,9 @@ package() {
# Licenses
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm 644 OSS-LICENSES.html "$pkgdir"/usr/share/licenses/$pkgname/OSS-LICENSES.html
+ install -Dm 644 OSS-LICENSES "$pkgdir"/usr/share/licenses/$pkgname/OSS-LICENSES
+
+ # Cut HTML from licenses file (remove lines 1-34 and everything from '">' to EOF)
+ sed -i '1,34d;/^">/,$d' "$pkgdir"/usr/share/licenses/$pkgname/OSS-LICENSES
}