summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Borgert2022-06-22 09:40:35 +0200
committerTobias Borgert2022-06-22 09:40:35 +0200
commit3ed17d6767a1b50767a15998b797c645a040b945 (patch)
tree55ed92f37c9a02fa8109b54da20315909630e59a
parentb0df0ea835d7ccfd5da7a2113dff92d9afdb25d3 (diff)
downloadaur-3ed17d6767a1b50767a15998b797c645a040b945.tar.gz
Update to v5.25.1. Added clean-up to autoup.bash.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rwxr-xr-xautoup.bash8
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fe838613ff3..8e8fa94bca8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = discover-snap
pkgdesc = KDE and Plasma resources management GUI with snap support
- pkgver = 5.25.0
+ pkgver = 5.25.1
pkgrel = 1
url = https://userbase.kde.org/Discover
arch = x86_64
@@ -28,13 +28,13 @@ pkgbase = discover-snap
optdepends = fwupd: firmware update support
provides = discover
conflicts = discover
- source = https://download.kde.org/stable/plasma/5.25.0/discover-5.25.0.tar.xz
- source = https://download.kde.org/stable/plasma/5.25.0/discover-5.25.0.tar.xz.sig
+ source = https://download.kde.org/stable/plasma/5.25.1/discover-5.25.1.tar.xz
+ source = https://download.kde.org/stable/plasma/5.25.1/discover-5.25.1.tar.xz.sig
validpgpkeys = E0A3EB202F8E57528E13E72FD7574483BB57B18D
validpgpkeys = 0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D
validpgpkeys = D07BD8662C56CB291B316EB2F5675605C74E02CF
validpgpkeys = 1FA881591C26B276D7A5518EEAAF29B42A678C20
- sha256sums = d1e2e9bd5df7d53e46d701408a3ce4bac93dce32657b4d8be775b865fb864073
+ sha256sums = 3a716ef8273a456fa1d38d7a17b64303204c89ec5356858bdcf9d2ee3089f5b2
sha256sums = SKIP
pkgname = discover-snap
diff --git a/PKGBUILD b/PKGBUILD
index a7892277d4c3..823bedc3cc2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=discover
pkgname=discover-snap
-pkgver=5.25.0
+pkgver=5.25.1
pkgrel=1
pkgdesc='KDE and Plasma resources management GUI with snap support'
arch=(x86_64)
@@ -20,7 +20,7 @@ optdepends=('packagekit-qt5: to manage packages from Arch Linux repositories' 'f
'fwupd: firmware update support')
groups=(plasma)
source=("https://download.kde.org/stable/plasma/${pkgver}/$_pkgname-$pkgver.tar.xz"{,.sig})
-sha256sums=('d1e2e9bd5df7d53e46d701408a3ce4bac93dce32657b4d8be775b865fb864073'
+sha256sums=('3a716ef8273a456fa1d38d7a17b64303204c89ec5356858bdcf9d2ee3089f5b2'
'SKIP')
validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D' # Jonathan Esk-Riddell <jr@jriddell.org>
'0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
diff --git a/autoup.bash b/autoup.bash
index 26f26f64c04a..c362c4b8de75 100755
--- a/autoup.bash
+++ b/autoup.bash
@@ -5,24 +5,32 @@ if [ -z "$1" ]; then
fi
echo "Trying to auto-update this package to version ${1} ..."
+
+# Clean up
+rm -rf pkg src discover-*
+
+# Update the version in the PKGBUILD
sed -ri 's/pkgver=([0-9]+\.[0-9]+\.[0-9]+\.{0,1}[0-9]*)/pkgver='"${1}"'/' PKGBUILD
if [ "$?" -ne 0 ]; then
echo "Setting the version number in PKGBUILD failed."
exit 1
fi
+# Update the package sums in the PKGBUILD
updpkgsums
if [ "$?" -ne 0 ]; then
echo "Updating the checksums failed."
exit 1
fi
+# Update .SRCINFO
makepkg --printsrcinfo > .SRCINFO
if [ "$?" -ne 0 ]; then
echo "Recreating .SRCINFO failed."
exit 1
fi
+# Build & install the package
makepkg -si --noconfirm
if [ "$?" -ne 0 ]; then
echo "Building and installing the package failed."