summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Borgert2021-11-09 22:42:33 +0100
committerTobias Borgert2021-11-09 22:42:33 +0100
commit8da10f9cf294f68dc8d2fd0acedb8e1930db2029 (patch)
tree3fe6a66b7c2f2c8026fa7d4e7e4d3621696118bd
parent461430a94a2b0074987b486bcd429c3a2d78779a (diff)
downloadaur-8da10f9cf294f68dc8d2fd0acedb8e1930db2029.tar.gz
Update to v5.23.3. Added autoup.bash.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rwxr-xr-xautoup.bash32
3 files changed, 38 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e9df41bead4..e7e46fff659a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = discover-snap
pkgdesc = KDE and Plasma resources management GUI with snap support
- pkgver = 5.23.2
+ pkgver = 5.23.3
pkgrel = 1
url = https://userbase.kde.org/Discover
arch = x86_64
@@ -28,13 +28,13 @@ pkgbase = discover-snap
optdepends = fwupd: firmware update support
provides = discover
conflicts = discover
- source = https://download.kde.org/stable/plasma/5.23.2/discover-5.23.2.tar.xz
- source = https://download.kde.org/stable/plasma/5.23.2/discover-5.23.2.tar.xz.sig
+ source = https://download.kde.org/stable/plasma/5.23.3/discover-5.23.3.tar.xz
+ source = https://download.kde.org/stable/plasma/5.23.3/discover-5.23.3.tar.xz.sig
validpgpkeys = E0A3EB202F8E57528E13E72FD7574483BB57B18D
validpgpkeys = 0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D
validpgpkeys = D07BD8662C56CB291B316EB2F5675605C74E02CF
validpgpkeys = 1FA881591C26B276D7A5518EEAAF29B42A678C20
- sha256sums = 44255c9b1a8df70a4c710396ccbdaf1725f93694a040d4197e4bf45285e6ee71
+ sha256sums = e09a1be1c41a80509835df44e340b5b8eb5b32725d046b99cf216442e666dc14
sha256sums = SKIP
pkgname = discover-snap
diff --git a/PKGBUILD b/PKGBUILD
index 521cd6e68d8b..5237f2b81335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=discover
pkgname=discover-snap
-pkgver=5.23.2
+pkgver=5.23.3
pkgrel=1
pkgdesc='KDE and Plasma resources management GUI with snap support'
arch=(x86_64)
@@ -19,7 +19,7 @@ optdepends=('packagekit-qt5: to manage packages from Arch Linux repositories' 'f
'fwupd: firmware update support')
groups=(plasma)
source=("https://download.kde.org/stable/plasma/${pkgver}/$_pkgname-$pkgver.tar.xz"{,.sig})
-sha256sums=('9e0de4a567d3f05cffa2ed7158eedf2729623d4e74772859120d1e6670c6c014'
+sha256sums=('e09a1be1c41a80509835df44e340b5b8eb5b32725d046b99cf216442e666dc14'
'SKIP')
validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D' # Jonathan Esk-Riddell <jr@jriddell.org>
'0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D' # Bhushan Shah <bshah@kde.org>
diff --git a/autoup.bash b/autoup.bash
new file mode 100755
index 000000000000..26f26f64c04a
--- /dev/null
+++ b/autoup.bash
@@ -0,0 +1,32 @@
+#!/bin/bash
+if [ -z "$1" ]; then
+ echo "You must specify the target version for the auto-update."
+ exit 1
+fi
+
+echo "Trying to auto-update this package to version ${1} ..."
+sed -ri 's/pkgver=([0-9]+\.[0-9]+\.[0-9]+\.{0,1}[0-9]*)/pkgver='"${1}"'/' PKGBUILD
+if [ "$?" -ne 0 ]; then
+ echo "Setting the version number in PKGBUILD failed."
+ exit 1
+fi
+
+updpkgsums
+if [ "$?" -ne 0 ]; then
+ echo "Updating the checksums failed."
+ exit 1
+fi
+
+makepkg --printsrcinfo > .SRCINFO
+if [ "$?" -ne 0 ]; then
+ echo "Recreating .SRCINFO failed."
+ exit 1
+fi
+
+makepkg -si --noconfirm
+if [ "$?" -ne 0 ]; then
+ echo "Building and installing the package failed."
+ exit 1
+fi
+
+echo "Autoupdate successful. Ready to add, commit and push the changes."