summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-08-19 14:50:33 +0200
committerKrzysztof (3ED) AS2015-08-19 14:50:33 +0200
commit319e2a227c9a683441e608f49bdd4589d37433fc (patch)
tree273d85c2d473e1952b1abddbd5485b08ebdeeef9
parentb35895e4efe22682f9d41260bca17b052fbcaca0 (diff)
downloadaur-disksearch.tar.gz
Add desktop file and previous contributors...
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
-rw-r--r--disksearch.desktop9
3 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e13aa6f11b4e..f5d05db75520 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = disksearch
pkgdesc = is a tool for searching for files on removable media disks (e.g. for songs on your MP3-CD's)
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 5
url = http://www.saring.de/disksearch/
arch = any
license = GPL
- depends = python2
depends = pygtk
source = http://downloads.sourceforge.net/disksearch/disksearch-1.2.1.tar.gz
source = 10-Makefile_small_tweakfix.patch
source = 11-disksearch_bin_script_paths_fix.patch
+ source = disksearch.desktop
sha256sums = 58711b617382582ad59d9d3ccf95d9a6eb9b620237455b4e586a6efa387258d7
sha256sums = 3d698b3eb7c18af4f9f045fb23246569608bcab8d2567c87629f693120a9e71b
sha256sums = c611e37f5804f35cc26f2a14ec34fe630c0e26d6735e649ac57e54bb45fb76cb
+ sha256sums = 8a8cdabb4d20da1610ca7b762b99883ff4f17a6e9ffd1498859ff25d708915ae
pkgname = disksearch
diff --git a/PKGBUILD b/PKGBUILD
index 67f7e733f4a0..d517e36b21b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: 3ED_0 <krzysztof1987 @ gmail.com>
+# Contributor: TDY <tdy@archlinux.info>
+# Contributor: Dmitry N. Shilov <stormblast@land.ru>
pkgname=disksearch
pkgver=1.2.1
-pkgrel=1
+pkgrel=5
pkgdesc="is a tool for searching for files on removable media disks (e.g. for songs on your MP3-CD's)"
arch=('any')
url="http://www.saring.de/disksearch/"
license=('GPL')
-depends=('python2' 'pygtk')
+depends=('pygtk')
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
"10-Makefile_small_tweakfix.patch"
- "11-disksearch_bin_script_paths_fix.patch")
+ "11-disksearch_bin_script_paths_fix.patch"
+ "disksearch.desktop")
noextract=()
sha256sums=('58711b617382582ad59d9d3ccf95d9a6eb9b620237455b4e586a6efa387258d7'
'3d698b3eb7c18af4f9f045fb23246569608bcab8d2567c87629f693120a9e71b'
- 'c611e37f5804f35cc26f2a14ec34fe630c0e26d6735e649ac57e54bb45fb76cb')
+ 'c611e37f5804f35cc26f2a14ec34fe630c0e26d6735e649ac57e54bb45fb76cb'
+ '8a8cdabb4d20da1610ca7b762b99883ff4f17a6e9ffd1498859ff25d708915ae')
prepare() {
cd "$pkgname-$pkgver"
patch -Np0 -i "$srcdir/10-Makefile_small_tweakfix.patch"
@@ -29,4 +33,13 @@ build() {
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
+
+ # icon
+ install -Dm644 \
+ "resource/$pkgname.png" \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ # desktop file
+ install -Dm644 \
+ "$srcdir/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
}
diff --git a/disksearch.desktop b/disksearch.desktop
new file mode 100644
index 000000000000..e458e6e47bc6
--- /dev/null
+++ b/disksearch.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=DiskSearch
+Comment=A database tool for searching removable media
+TryExec=/usr/bin/disksearch
+Exec=disksearch
+Icon=disksearch
+Categories=Office;Database;