summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:55:15 +0200
committerLubosz Sarnecki2015-06-22 22:55:15 +0200
commit60d3bc9b80a84e8483a1ee291fa98b0933aab66d (patch)
tree851806087668ea98647dfaac0cd78249846ad831
downloadaur-django-threaded-multihost-hg.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7fa3363a229
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = django-threaded-multihost-hg
+ pkgdesc = Provides multi-host utilities to Django projects by using threadlocals, middleware and simple utilities. Using the middleware provided, you can easily provide multi-site awareness to any project.
+ pkgver = 20101010
+ pkgrel = 1
+ url = http://bitbucket.org/bkroeze/django-threaded-multihost
+ arch = any
+ license = GPL
+ depends = python
+ depends = django
+ provides = django-threaded-multihost
+ conflicts = django-threaded-multihost
+
+pkgname = django-threaded-multihost-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0602fce321e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lubosz Sarnecki <lubosz at gmail com>
+
+pkgname=django-threaded-multihost-hg
+pkgver=20101010
+pkgrel=1
+pkgdesc="Provides multi-host utilities to Django projects by using threadlocals, middleware and simple utilities. Using the middleware provided, you can easily provide multi-site awareness to any project."
+arch=(any)
+url="http://bitbucket.org/bkroeze/django-threaded-multihost"
+license=('GPL')
+depends=('python' 'django')
+conflicts=('django-threaded-multihost')
+provides=('django-threaded-multihost')
+source=()
+md5sums=()
+
+_hgbranch=http://bitbucket.org/bkroeze/django-threaded-multihost
+_hgrepo=django-threaded-multihost
+
+build() {
+ cd ${srcdir}
+
+ if [ -d ${_hgrepo} ]; then
+ (cd ${_hgrepo} && hg pull -u) || return 1
+ else
+ hg clone ${_hgbranch} || return 1
+ fi
+
+ msg "Mercurial clone done or server timeout"
+
+ cd ${_hgrepo}
+
+ python2 setup.py build || return 1
+ python2 setup.py install --root=$pkgdir --optimize=1 || return 1
+}