summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShizcow2020-06-26 23:01:02 -0600
committerShizcow2020-06-26 23:01:02 -0600
commit1e07870e3088561c7ae36754c54481d5479e5b90 (patch)
tree4f2f60c33d45b2f2dcfeb4807bccfee279a13f7b
parentd60c4d5af4901cc87ba7b8b8ddde9c070ba4ea7f (diff)
downloadaur-1e07870e3088561c7ae36754c54481d5479e5b90.tar.gz
upstream update, added plugin support
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c17295659c7..080316114c37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dmenu-rs
pkgdesc = A 1:1 port of dmenu, rewritten in Rust
- pkgver = 5.1.0.0.g906941c
+ pkgver = 5.2.0.0.g38a8ad8
pkgrel = 1
url = https://github.com/Shizcow/dmenu-rs
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 7c64e48cbd5e..477f8812a393 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,16 @@
# Maintainer: Devin Pohl <pohl.devin@gmail.com>
+# -------------------------------------------------------
+# PLUGINS
+# -------------------------------------------------------
+# If you'd like to compile in plugins, add the names here
+# For a list of available plugins, see the git repo
+# or run `make plugins` in the cloned repo
+PLUGINS=""
+
_pkgname=dmenu
pkgname=$_pkgname-rs
-pkgver=5.1.0.0.g906941c
+pkgver=5.2.0.0.g38a8ad8
pkgrel=1
pkgdesc="A 1:1 port of dmenu, rewritten in Rust"
arch=('i686' 'x86_64')
@@ -22,11 +30,11 @@ pkgver() {
build() (
cd dmenu-rs
- make
+ make PLUGINS="$PLUGINS"
)
package() (
cd $pkgname
- make PREFIX=/usr DESTDIR="$pkgdir" install
+ make PREFIX=/usr DESTDIR="$pkgdir" PLUGINS="$PLUGINS" install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
) \ No newline at end of file