summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Wright2021-01-18 22:38:06 -0500
committerJosh Wright2021-01-18 22:38:06 -0500
commit157ec81791c529a3edfa75220ff2dcf63b18ec94 (patch)
tree49dd12f61c9c5f12ae5c396364a6eb5b94bc20f9
downloadaur-dndtools.tar.gz
initial package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9fd991b8461
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dndtools
+ pkgdesc = Various CLI tools and Rust library for D&D 5e
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/wrightjjw/dndtools
+ arch = x86_64
+ license = GPL3
+ checkdepends = cargo
+ makedepends = cargo
+ provides = stats
+ provides = roll
+ source = https://github.com/wrightjjw/dndtools/archive/v0.1.0.tar.gz
+ sha256sums = 303c0239f4790cfbea1526189e05cfc7bca0938db560e8922460c74217e97d1a
+
+pkgname = dndtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..021d0d479a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Josh Wright <wright.jjw@gmail.com>
+pkgname=dndtools
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="Various CLI tools and Rust library for D&D 5e"
+arch=('x86_64')
+url="https://github.com/wrightjjw/dndtools"
+license=('GPL3')
+depends=()
+makedepends=('cargo')
+checkdepends=('cargo')
+optdepends=()
+provides=('stats'
+ 'roll')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=("303c0239f4790cfbea1526189e05cfc7bca0938db560e8922460c74217e97d1a")
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/stats $pkgdir/usr/bin/stats
+ install -Dm755 target/release/roll $pkgdir/usr/bin/roll
+}