summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2018-03-18 18:17:46 +0100
committerOleksandr Natalenko2018-03-18 18:18:12 +0100
commit4e53b0f35718726a981bd1d5399115525fba5659 (patch)
tree6d9f6fef9956abc92a4961ee9f430ad33647eb35
parentdf4a12bfc54eb93a55300c3d412bea2271e0a220 (diff)
downloadaur-dnsbalancer.tar.gz
update to v0.2.0
Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
-rw-r--r--dnsbalancer.service13
4 files changed, 38 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5be945384255..f127b6bb53ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,18 @@
-# Generated by mksrcinfo v8
-# Mon Jul 4 11:19:58 UTC 2016
pkgbase = dnsbalancer
pkgdesc = Daemon to balance UDP DNS requests over DNS servers
- pkgver = 0.0.1
- pkgrel = 3
- url = https://github.com/LanetNetwork/dnsbalancer
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/pfactum/dnsbalancer
arch = x86_64
license = GPL
makedepends = git
makedepends = gcc
makedepends = cmake
- makedepends = make
- depends = libmicrohttpd
- depends = libbsd
- depends = ldns
- depends = openssl
- depends = libunwind
- optdepends = gperftools: faster memory allocation with tcmalloc
- source = dnsbalancer-git::git+https://github.com/LanetNetwork/dnsbalancer.git
+ makedepends = ninja
+ source = dnsbalancer-git::git+https://github.com/pfactum/dnsbalancer.git
+ source = dnsbalancer.service
sha256sums = SKIP
+ sha256sums = 02011cfedb857d958aa3cfd5f3cd6c1e621b138f869d362f548ae49f93c52403
pkgname = dnsbalancer
diff --git a/.gitignore b/.gitignore
index 23a220a2c294..b9c440cb296b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
dnsbalancer-git/
+pkg/
+src/
*.tar.xz
-pkg
-src
+
diff --git a/PKGBUILD b/PKGBUILD
index 7a645c3713e9..113ebd8b356d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Oleksandr Natalenko <oleksandr@natalenko.name>
pkgname=dnsbalancer
-pkgver=0.0.1
-pkgrel=3
+pkgver=0.2.0
+pkgrel=1
pkgdesc="Daemon to balance UDP DNS requests over DNS servers"
arch=('x86_64')
-url="https://github.com/LanetNetwork/${pkgname}"
+url="https://github.com/pfactum/${pkgname}"
license=('GPL')
-depends=('libmicrohttpd' 'libbsd' 'ldns' 'openssl' 'libunwind')
-optdepends=('gperftools: faster memory allocation with tcmalloc')
-makedepends=('git' 'gcc' 'cmake' 'make')
+makedepends=('git' 'gcc' 'cmake' 'ninja')
-source=("${pkgname}-git::git+https://github.com/LanetNetwork/${pkgname}.git")
+source=(
+ "${pkgname}-git::git+https://github.com/pfactum/${pkgname}.git"
+ "dnsbalancer.service"
+ )
-sha256sums=("SKIP")
+sha256sums=('SKIP'
+ '02011cfedb857d958aa3cfd5f3cd6c1e621b138f869d362f548ae49f93c52403')
build() {
cd "${srcdir}/${pkgname}-git"
@@ -20,16 +22,16 @@ build() {
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
- make -j$(nproc)
+ CC=gcc cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" ..
+ cmake --build .
}
package() {
cd "${srcdir}/${pkgname}-git/build"
- make install
+ cmake --build . --target install
- install -Dm0644 ../configs/${pkgname}.conf.sample ${pkgdir}/etc/${pkgname}/${pkgname}.conf.sample
- install -Dm0644 ../configs/${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
+ install -Dm0644 ../${pkgname}.conf.sample ${pkgdir}/etc/${pkgname}/${pkgname}.conf.sample
+ install -Dm0644 ../../${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
}
diff --git a/dnsbalancer.service b/dnsbalancer.service
new file mode 100644
index 000000000000..b6adee0976dd
--- /dev/null
+++ b/dnsbalancer.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=UDP DNS balancer
+After=network.target
+
+[Service]
+Type=forking
+PrivateTmp=true
+ExecStart=/usr/bin/dnsbalancer --config=/etc/dnsbalancer/dnsbalancer.conf --daemonize --syslog
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
+