summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFixed Torres2018-01-11 20:02:21 -0500
committerFixed Torres2018-01-11 20:02:21 -0500
commit1850a5da34f97448eb49d90a0c1ff16ce6f6880e (patch)
treea3f99380aec0ef607a287c46ac9fefc360a42543
parent3bdeb06a80f9adf43395e85e1a0affa3cefcfe6d (diff)
downloadaur-1850a5da34f97448eb49d90a0c1ff16ce6f6880e.tar.gz
New repository https://github.com/dyne/dnscrypt-proxy perhaps temporary
-rw-r--r--.SRCINFO11
-rwxr-xr-xPKGBUILD16
-rwxr-xr-xdnscrypt-proxy-git.install2
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0da0f163b25..a8d24eef45ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Aug 31 00:01:08 UTC 2017
+# Fri Jan 12 00:59:25 UTC 2018
pkgbase = dnscrypt-proxy-git
pkgdesc = Is a protocol for securing communications between a client and a DNS resolver
- pkgver = 1.9.5.2492.e916ef6
+ pkgver = 2018.01.07.2504.f71ca69
pkgrel = 1
- url = http://dnscrypt.org/
+ url = https://github.com/DNSCrypt/dnscrypt-proxy
install = dnscrypt-proxy-git.install
arch = i686
arch = x86_64
@@ -17,8 +17,9 @@ pkgbase = dnscrypt-proxy-git
conflicts = dnscrypt-proxy
options = libtool
backup = etc/dnscrypt-proxy.conf
- source = dnscrypt-proxy::git+https://github.com/jedisct1/dnscrypt-proxy.git
- md5sums = SKIP
+ backup = dnscrypt-proxy.service
+ source = dnscrypt-proxy::git+https://github.com/dyne/dnscrypt-proxy.git
+ sha512sums = SKIP
pkgname = dnscrypt-proxy-git
diff --git a/PKGBUILD b/PKGBUILD
index a0a1ed7ff2f9..8624e42735c6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
pkgname=dnscrypt-proxy-git
_pkgname=dnscrypt-proxy
-pkgver=1.9.5.2492.e916ef6
+pkgver=2018.01.07.2504.f71ca69
pkgrel=1
pkgdesc="Is a protocol for securing communications between a client and a DNS resolver"
arch=('i686' 'x86_64')
-url="http://dnscrypt.org/"
+url="https://github.com/DNSCrypt/dnscrypt-proxy"
license=('custom:ISC')
depends=('libsodium' 'systemd' 'libtool' 'ldns' 'git')
options=(libtool)
conflicts=('dnscrypt-proxy')
-backup=('etc/dnscrypt-proxy.conf')
+backup=('etc/dnscrypt-proxy.conf' 'dnscrypt-proxy.service')
install=dnscrypt-proxy-git.install
-source=("${_pkgname}::git+https://github.com/jedisct1/dnscrypt-proxy.git")
+source=("${_pkgname}::git+https://github.com/dyne/dnscrypt-proxy.git")
pkgver() {
cd ${_pkgname}
- echo "$(git describe --tags --abbrev=0).$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ echo "2018.01.07$(git describe --tags --abbrev=0).$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
@@ -32,8 +32,8 @@ prepare() {
build() {
cd ${srcdir}/${_pkgname}
- ./autogen.sh --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --with-included-ltdl--with-systemd
- ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --with-included-ltdl --with-systemd
+ ./autogen.sh --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --with-systemd
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --with-systemd
make -j2
}
@@ -68,4 +68,4 @@ EOF
chmod 755 "${pkgdir}/usr/bin/dnscrypt-update-resolvers"
chmod 755 "${pkgdir}/usr/bin/dnscrypt-domains-blacklist"
}
-md5sums=('SKIP')
+sha512sums=('SKIP')
diff --git a/dnscrypt-proxy-git.install b/dnscrypt-proxy-git.install
index 9e359e90b86a..400ae3f11651 100755
--- a/dnscrypt-proxy-git.install
+++ b/dnscrypt-proxy-git.install
@@ -4,6 +4,6 @@ post_upgrade() {
echo "Since 1.8.1-1 there is a new configuration file at /etc/dnscrypt-proxy.conf."
echo "The systemd unit has been configured to use it, so please adjust your settings there."
- echo "For more information, see: https://github.com/jedisct1/dnscrypt-proxy/wiki"
+ echo "For more information, see: https://github.com/FixedTorres/dnscrypt-proxy-git"
fi
}