summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFixed Torres2017-01-16 16:50:27 -0500
committerFixed Torres2017-01-16 16:50:27 -0500
commitfe8c847ab4b6479bd33df697850607ed26c557f4 (patch)
tree8b8cb0217fc12288adb6426c89a83530ef701b19
downloadaur-fe8c847ab4b6479bd33df697850607ed26c557f4.tar.gz
Git version configured with support for plugins and domains blacklist
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD63
-rw-r--r--dnscrypt-proxy-git.install9
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..182dd1accd2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Jan 16 21:50:11 UTC 2017
+pkgbase = dnscrypt-proxy-git
+ pkgdesc = Is a protocol for securing communications between a client and a DNS resolver
+ pkgver = 1.9.2.2281.48b8a90
+ pkgrel = 1
+ url = http://dnscrypt.org/
+ install = dnscrypt-proxy-git.install
+ arch = i686
+ arch = x86_64
+ license = custom:ISC
+ depends = libsodium
+ depends = systemd
+ depends = libtool
+ depends = ldns
+ conflicts = dnscrypt-proxy
+ options = libtool
+ backup = etc/dnscrypt-proxy.conf
+ source = dnscrypt-proxy::git+https://github.com/jedisct1/dnscrypt-proxy.git
+ sha512sums = SKIP
+
+pkgname = dnscrypt-proxy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11b774b62bdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Fixed Torres <aur_linuxero@outlook.com>
+# Contributor: Fixed Torres <aur_linuxero@outlook.com>
+
+pkgname=dnscrypt-proxy-git
+_pkgname=dnscrypt-proxy
+pkgver=1.9.2.2281.48b8a90
+pkgrel=1
+pkgdesc="Is a protocol for securing communications between a client and a DNS resolver"
+arch=('i686' 'x86_64')
+url="http://dnscrypt.org/"
+license=('custom:ISC')
+depends=('libsodium' 'systemd' 'libtool' 'ldns')
+options=(libtool)
+conflicts=('dnscrypt-proxy')
+backup=('etc/dnscrypt-proxy.conf')
+install=dnscrypt-proxy-git.install
+source=("${_pkgname}::git+https://github.com/jedisct1/dnscrypt-proxy.git")
+
+pkgver() {
+ cd ${_pkgname}
+ echo "$(git describe --tags --abbrev=0).$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${srcdir}/${_pkgname}
+
+ sed -e 's|^ExecStart=.*|ExecStart=/usr/bin/dnscrypt-proxy /etc/dnscrypt-proxy.conf|' \
+ -i dnscrypt-proxy.service
+
+ sed -e 's|python|python2|' -i contrib/generate-domains-blacklist.py
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}
+ ./autogen.sh --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --with-systemd
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --with-systemd
+ make -j2
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+ make DESTDIR="$pkgdir" install
+
+ install -dm755 "$pkgdir"/{usr/share/{licenses,doc}/$_pkgname,usr/lib/systemd/system,usr/lib/${_pkgname}}
+ install -dm755 "$pkgdir/usr/share/${_pkgname}/script"
+ install -m 644 COPYING "$pkgdir"/usr/share/licenses/${_pkgname}
+ install -m 644 AUTHORS NEWS README README.markdown "$pkgdir"/usr/share/doc/${_pkgname}
+ install -m 644 dnscrypt-proxy.service "$pkgdir"/usr/lib/systemd/system
+ install -m 644 dnscrypt-proxy.socket "$pkgdir"/usr/lib/systemd/system
+
+## Installing script to generate domains blacklist
+ cd ${srcdir}/${_pkgname}/contrib/
+ install -m 644 generate-domains-blacklist.py "$pkgdir/usr/share/${_pkgname}/script"
+ install -m 644 domains-blacklist.conf "$pkgdir/usr/share/${_pkgname}/script"
+ install -m 644 *.txt "$pkgdir/usr/share/${_pkgname}/script"
+
+cat > "$pkgdir/usr/bin/generate-domains-blacklist" << EOF
+#!/bin/bash
+cd /usr/share/dnscrypt-proxy/script && python2 generate-domains-blacklist.py "\$@"
+EOF
+ chmod 755 "${pkgdir}/usr/bin/generate-domains-blacklist"
+}
+sha512sums=('SKIP')
diff --git a/dnscrypt-proxy-git.install b/dnscrypt-proxy-git.install
new file mode 100644
index 000000000000..4b97ce616d24
--- /dev/null
+++ b/dnscrypt-proxy-git.install
@@ -0,0 +1,9 @@
+post_upgrade() {
+ if [ "$(vercmp $2 1.8.1-1)" -lt 0 ]
+ then
+ echo "Since 1.8.1-1 there is a new configuration file at /etc/dnscrypt-proxy.conf."
+ echo "The systemd unit has been configured to use it, so please adjust your settings there."
+
+ echo "For more information, see: https://github.com/jedisct1/dnscrypt-proxy/wiki"
+ fi
+}