summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLenni vH2020-08-18 19:26:27 +0200
committerLenni vH2020-08-18 19:26:27 +0200
commitc5140aa64aa7aa234c13a817239543583531f6d7 (patch)
treee771699604d1b4a92e6cd29868ac0da06d983479
parent4b78582491c876b6bd31c2055396644564f056c5 (diff)
downloadaur-c5140aa64aa7aa234c13a817239543583531f6d7.tar.gz
fixes to PKGBUILD, added changelog and configuration instructions
-rw-r--r--PKGBUILD16
-rw-r--r--doas.changelog29
-rw-r--r--doas.install4
3 files changed, 45 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3df94bcf2ab7..beb7974da741 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: lennivh24@gmail.com
+# Maintainer: Leonard von Hagen <lennivh24@gmail.com>
+# Contributor: Stephen Gregoratto <dev@sgregoratto.me>
pkgname=doas
pkgver=6.3p2
pkgrel=1
@@ -6,11 +7,13 @@ pkgdesc="A port of OpenBSD's doas(1), an alternative to sudo(1)"
license=('BSD')
url="https://github.com/slicer69/doas"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-depends=('pam' 'bison')
+makedepends=('bison')
+optdepends=('vi: default editor for vidoas')
backup=('etc/doas.conf'
'etc/pam.d/doas')
-provides=('doas')
-replaces=('opendoas' 'opendoas-git')
+install="doas.install"
+changelog="doas.changelog"
+conflicts=('opendoas' 'opendoas-git')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'00-Makefile.patch'
'doas-pam'
@@ -37,3 +40,8 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+post_install() {
+ echo "Edit the configuration in /etc/doas.conf"
+ echo "by adding your username or other values"
+}
diff --git a/doas.changelog b/doas.changelog
new file mode 100644
index 000000000000..e615ddce5b3a
--- /dev/null
+++ b/doas.changelog
@@ -0,0 +1,29 @@
+2020-08-07 Jesse Smith <jsmith@resonatingmedia.com>
+ * Added tool to edit and check doas.conf
+
+2020-08-06 Jesse Smith <jsmith@resonatingmedia.com>
+ * Double-dash no longer needed on Linux
+
+2020-06-22 Jesse Smith <jsmith@resonatingmedia.com>
+ * Added interactive login shell option
+
+2020-04-21 Jesse Smith <jsmith@resonatingmedia.com>
+ * Added example PAM configuration file for FreeBSD
+
+2019-12-28 Jesse Smith <jsmith@resonatingmedia.com>
+ * doas 6.2p4 Keeping environment variables with keepenv
+
+2019-12-28 Jesse Smith <jsmith@resonatingmedia.com>
+ * doas 6.2p3 Made sure parse.o is cleaned up
+
+2019-10-12 Jesse Smith <jsmith@resonatingmedia.com>
+ * doas 6.2p2 Introducing macOS support
+
+2019-09-10 Jesse Smith <jsmith@resonatingmedia.com>
+ * doas 6.2p1 Code reorganization, fix Linux crash, remove numeric UID matches
+
+2019-09-03 Jesse Smith <jsmith@resonatingmedia.com>
+ * doas 6.2 Linux group permissions, bug fix and optimizations
+
+2019-09-02 Jesse Smith <jsmith@resonatingmedia.com>
+ * doas 6.1p1 ported to illumos
diff --git a/doas.install b/doas.install
new file mode 100644
index 000000000000..755d4780292f
--- /dev/null
+++ b/doas.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo " >> Edit the configuration in /etc/doas.conf"
+ echo " >> by adding your username or other values"
+}