summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Javorski2017-06-28 12:14:24 -0700
committerMike Javorski2017-06-28 12:14:24 -0700
commit1676163de69f0fc84ee4e53826decb394db9fd32 (patch)
tree21776771e40d63c200c10605b8c453e41dacaee6
parente3d7e4d8d26777db2d65dc186b86e50cc135a5fc (diff)
downloadaur-1676163de69f0fc84ee4e53826decb394db9fd32.tar.gz
Moby -> Docker name changes and update for 17.06.0 release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD52
2 files changed, 30 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31ac666a9924..7484e73cbd0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docker-bin
pkgdesc = Pack, ship and run any application as a lightweight container, using official binaries
- pkgver = 17.05.0
+ pkgver = 17.06.0
pkgrel = 1
url = https://www.docker.com/
arch = x86_64
@@ -22,13 +22,13 @@ pkgbase = docker-bin
conflicts = docker-ce
conflicts = docker-git
options = !strip
- source = https://get.docker.com/builds/Linux/x86_64/docker-17.05.0-ce.tgz
- source = https://github.com/moby/moby/archive/v17.05.0-ce.tar.gz
+ source = https://download.docker.com/linux/static/stable/x86_64/docker-17.06.0-ce.tgz
+ source = https://github.com/docker/docker-ce/archive/v17.06.0-ce.tar.gz
source = git+https://github.com/spf13/cobra.git
source = git+https://github.com/cpuguy83/go-md2man.git
source = docker.sysusers
- md5sums = 1058a7eb3f05833475fcc29fc4b11011
- md5sums = 98db409f71d8b1531f94a1cf95f676e0
+ md5sums = ecc2f2d99b64b35d8ad478eafcc6f502
+ md5sums = 1eb7761b77dc328e6b0a9c481bcd7514
md5sums = SKIP
md5sums = SKIP
md5sums = 9a8b2744db23b14ca3cd350fdf73c179
diff --git a/PKGBUILD b/PKGBUILD
index b9ffcbc0e8b5..bbde4b846c7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sébastien "Seblu" Luttringer
pkgname=docker-bin
-pkgver=17.05.0
+pkgver=17.06.0
pkgrel=1
pkgdesc='Pack, ship and run any application as a lightweight container, using official binaries'
arch=('x86_64')
@@ -11,22 +11,19 @@ license=('Apache')
provides=('docker' 'docker-ce')
conflicts=('docker' 'docker-ce' 'docker-git')
depends=('bridge-utils' 'iproute2' 'device-mapper' 'sqlite' 'systemd' 'libseccomp')
-makedepends=('git' 'go' 'go-md2man')
+#makedepends=('git' 'go' 'go-md2man')
+makedepends=('make' 'git' 'go')
optdepends=('btrfs-progs: btrfs backend support'
'lxc: lxc backend support')
# don't strip binaries! A sha1 is used to check binary consistency.
options=('!strip')
source=(
- "https://get.docker.com/builds/Linux/x86_64/docker-${pkgver}-ce.tgz"
- "https://github.com/moby/moby/archive/v${pkgver}-ce.tar.gz"
- "git+https://github.com/spf13/cobra.git"
- "git+https://github.com/cpuguy83/go-md2man.git"
+ "https://download.docker.com/linux/static/stable/x86_64/docker-${pkgver}-ce.tgz"
+ "https://github.com/docker/docker-ce/archive/v${pkgver}-ce.tar.gz"
"docker.sysusers"
)
-md5sums=('1058a7eb3f05833475fcc29fc4b11011'
- '98db409f71d8b1531f94a1cf95f676e0'
- 'SKIP'
- 'SKIP'
+md5sums=('ecc2f2d99b64b35d8ad478eafcc6f502'
+ '1eb7761b77dc328e6b0a9c481bcd7514'
'9a8b2744db23b14ca3cd350fdf73c179')
build() {
@@ -36,15 +33,11 @@ build() {
# mock go packages so we can generate the man pages
mkdir -p src/github.com/docker
- ln -rsfT moby-$pkgver-ce src/github.com/docker/docker
- mkdir -p src/github.com/cpuguy83
- ln -rsf go-md2man src/github.com/cpuguy83
- mkdir -p src/github.com/spf13
- ln -rsf cobra src/github.com/spf13
+ ln -rsfT docker-ce-$pkgver-ce/components/cli src/github.com/docker/cli
msg2 'Building man pages'
- pushd src/github.com/docker/docker >/dev/null
- man/generate.sh 2>/dev/null
+ pushd src/github.com/docker/cli >/dev/null
+ make manpages 2>/dev/null
popd >/dev/null
}
@@ -63,23 +56,28 @@ package() {
# docker binary
install -Dm755 'docker' "$pkgdir/usr/bin/docker"
install -Dm755 'dockerd' "$pkgdir/usr/bin/dockerd"
+
+ cd $srcdir/docker-ce-$pkgver-ce/components/cli
# completion
- install -Dm644 'completion/bash/docker' "$pkgdir/usr/share/bash-completion/completions/docker"
- install -Dm644 'completion/zsh/_docker' "$pkgdir/usr/share/zsh/site-functions/_docker"
- install -Dm644 'completion/fish/docker.fish' "$pkgdir/usr/share/fish/vendor_completions.d/docker.fish"
+ install -Dm644 'contrib/completion/bash/docker' "$pkgdir/usr/share/bash-completion/completions/docker"
+ install -Dm644 'contrib/completion/zsh/_docker' "$pkgdir/usr/share/zsh/site-functions/_docker"
+ install -Dm644 'contrib/completion/fish/docker.fish' "$pkgdir/usr/share/fish/vendor_completions.d/docker.fish"
+
+ # man
+ install -dm755 "$pkgdir/usr/share/man"
+ cp -r man/man* "$pkgdir/usr/share/man"
- cd ../moby-$pkgver-ce
+ cd $srcdir/docker-ce-$pkgver-ce/components/packaging
# systemd
- install -Dm644 'contrib/init/systemd/docker.service' "$pkgdir/usr/lib/systemd/system/docker.service"
- install -Dm644 'contrib/init/systemd/docker.socket' "$pkgdir/usr/lib/systemd/system/docker.socket"
- install -Dm644 'contrib/udev/80-docker.rules' "$pkgdir/usr/lib/udev/rules.d/80-docker.rules"
+ install -Dm644 'deb/systemd/docker.service' "$pkgdir/usr/lib/systemd/system/docker.service"
+ install -Dm644 'deb/systemd/docker.socket' "$pkgdir/usr/lib/systemd/system/docker.socket"
install -Dm644 "$srcdir/docker.sysusers" "$pkgdir/usr/lib/sysusers.d/docker.conf"
+
+ cd $srcdir/docker-ce-$pkgver-ce/components/engine
+ install -Dm644 'contrib/udev/80-docker.rules' "$pkgdir/usr/lib/udev/rules.d/80-docker.rules"
# vim syntax
install -Dm644 'contrib/syntax/vim/syntax/dockerfile.vim' "$pkgdir/usr/share/vim/vimfiles/syntax/dockerfile.vim"
install -Dm644 'contrib/syntax/vim/ftdetect/dockerfile.vim' "$pkgdir/usr/share/vim/vimfiles/ftdetect/dockerfile.vim"
- # man
- install -dm755 "$pkgdir/usr/share/man"
- cp -r man/man* "$pkgdir/usr/share/man"
}
# vim:set ts=2 sw=2 et: