aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Plangg2016-06-29 18:18:36 +0200
committerMarkus Plangg2016-06-29 18:18:36 +0200
commit162cbe2beeac82d9583100302307a3bc6920242b (patch)
tree4af6752086a6973ae3fe071e1e597e79341db0c3
parent4384acff6e57d1fa1c0dd89d5c1c2f7672b052ae (diff)
downloadaur-docker-gc-git.tar.gz
Change package to docker-gc-git
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--README.md21
3 files changed, 31 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4f7bc56c21b..3440c034c961 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Jun 24 18:50:52 UTC 2016
-pkgbase = docker-gc
+# Wed Jun 29 16:15:03 UTC 2016
+pkgbase = docker-gc-git
pkgdesc = A simple Docker container and image garbage collection script
- pkgver = 0.1.1.r131.5005527
+ pkgver = r135.ff0b648
pkgrel = 1
url = https://github.com/spotify/docker-gc
arch = any
license = Apache
+ makedepends = git
depends = bash
provides = docker-gc
conflicts = docker-gc
- source = https://raw.githubusercontent.com/spotify/docker-gc/420558e74413b63aa479a31a44d6039d6b255d66/docker-gc
- md5sums = f12f02b1cd2a7ff6fda5e784797435c6
- sha256sums = 6168362cb3dcad79df6f80fad2adbf6224053dca51a862dd654c2f64a71efc59
+ source = git+https://github.com/spotify/docker-gc.git
+ md5sums = SKIP
-pkgname = docker-gc
+pkgname = docker-gc-git
diff --git a/PKGBUILD b/PKGBUILD
index ccaf150373a2..cb4112de4cc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
# Maintainer: Markus Plangg <mksplg at gmail.com>
-pkgname=docker-gc
-pkgver=0.1.1.r131.5005527
+pkgname=docker-gc-git
+pkgver=r135.ff0b648
pkgrel=1
-pkgdesc="A simple Docker container and image garbage collection script"
+pkgdesc='A simple Docker container and image garbage collection script'
arch=('any')
-url="https://github.com/spotify/docker-gc"
+url='https://github.com/spotify/docker-gc'
license=('Apache')
-provides=('docker-gc')
-conflicts=('docker-gc')
-source=("https://raw.githubusercontent.com/spotify/docker-gc/420558e74413b63aa479a31a44d6039d6b255d66/docker-gc")
-md5sums=('f12f02b1cd2a7ff6fda5e784797435c6')
-sha256sums=('6168362cb3dcad79df6f80fad2adbf6224053dca51a862dd654c2f64a71efc59')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/spotify/docker-gc.git')
+md5sums=('SKIP')
depends=('bash')
+makedepends=('git')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- install -D -m755 "$srcdir"/docker-gc "$pkgdir/usr/bin/docker-gc"
+ install -D -m755 "${pkgname%-git}"/docker-gc "$pkgdir/usr/bin/docker-gc"
install -d -m755 "$pkgdir"/var/lib/docker-gc
}
diff --git a/README.md b/README.md
index f92390d72623..f4570f0692e3 100644
--- a/README.md
+++ b/README.md
@@ -1,4 +1,4 @@
-# Arch package docker-gc
+# Arch package docker-gc-git
[docker-gc](https://github.com/spotify/docker-gc) is a simple Docker container and image garbage collection script.
@@ -7,29 +7,26 @@
[AUR Helpers](https://wiki.archlinux.org/index.php/AUR_helpers) provide a simpler interface to the Arch User Repository. There are serveral tools that allow to build an install an AUR package using a single command.
-* `yaourt docker-gc`
-* `aura -A docker-gc`
-* `pacaur -y docker-gc`
+* `yaourt docker-gc-git`
+* `aura -A docker-gc-git`
+* `pacaur -y docker-gc-git`
## Build and install the package
[Installing packages from AUR](https://wiki.archlinux.org/index.php/AUR_User_Guidelines#Installing_packages) can be done manually:
-* Clone the [docker-gc AUR repository](https://aur.archlinux.org/docker-gc.git)
- `git clone https://aur.archlinux.org/docker-gc.git`
+* Clone the [docker-gc-git AUR repository](https://aur.archlinux.org/docker-gc-git.git)
+ `git clone https://aur.archlinux.org/docker-gc-git.git`
* Change into the cloned repository
- `cd docker-gc`
+ `cd docker-gc-git`
* Inspect the package
`vi PKGBUILD`
* Build and install the package
`makepkg -srci`
-## Update the PKGBUILD
+## Update PKGBUILD
* Update PKGBUILD
- [Package version for git repositories](https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git) should be in the form `[VERSION].r[REVISION].[HASH]`. Since the docker-gc repository does not tag releases check `version.txt` for the current version and append the appropriate revision and hash manually or by running `printf "%s.r%s.%s" "$(cat version.txt)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"` in the repository root.
-* Update source file hashes
- `updpkgsums`
* Update the .SRCINFO
`mksrcinfo`
* Build the package
@@ -39,5 +36,5 @@
* Test-install package
`pacman -U docker-gc-*.pkg.tar.xz`
* Remove tmp files
- `rm docker-gc`
+ `rm -r docker-gc`
`rm docker-gc-*.pkg.tar.xz`