summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-09-11 17:59:24 +0200
committerhaawda2021-09-11 17:59:24 +0200
commit8d026e7e4899df5ccaa858a8500b805c67e44bc8 (patch)
tree4c309e951b3d5dcf37726eef6c8c565fc22f20c7
downloadaur-docma-git.tar.gz
initial upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60588d19dbb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = docma-git
+ pkgdesc = A command-line document manager with keyword search
+ pkgver = r19.b956694
+ pkgrel = 1
+ url = https://github.com/patrickschulz/docma
+ arch = any
+ license = custom:unknown
+ makedepends = git
+ depends = lua-penlight
+ depends = lua
+ provides = docma
+ conflicts = docma
+ source = git+https://github.com/patrickschulz/docma
+ sha256sums = SKIP
+
+pkgname = docma-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f344105416e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Patrick Kurth <p.kurth@posteo.de>
+
+pkgname=docma-git
+pkgver=r19.b956694
+pkgrel=1
+pkgdesc="A command-line document manager with keyword search"
+arch=('any')
+url="https://github.com/patrickschulz/docma"
+source=("git+https://github.com/patrickschulz/docma")
+sha256sums=('SKIP')
+depends=('lua-penlight' 'lua')
+makedepends=('git')
+conflicts=('docma')
+provides=('docma')
+license=('custom:unknown')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname%-git}
+ install -d "$pkgdir"/usr/share/lua/5.4
+ cp --recursive docmalib "${pkgdir}/usr/share/lua/5.4"
+ install -Dm755 ${pkgname%-git} "$pkgdir"/usr/bin/${pkgname%-git}
+ touch L
+ install -Dm644 L "$pkgdir"/usr/share/licenses/$pkgname/unknown-license
+}