summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Actions2023-10-29 17:12:19 +0000
committerGitHub Actions2023-10-29 17:12:19 +0000
commit5ea568cdf48ba16345e6f4f3becf2408de6b7d1c (patch)
tree3344b07f7ac560c7de78a1cda90b4f7d9850a9a0
parentaf25a30ffa6a606bf7c28d59dac26786bfb65501 (diff)
downloadaur-docoseco.tar.gz
Automatic update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD41
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d6f41a90d65..1db282ec3f6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,12 @@ pkgbase = docoseco
url = https://github.com/Zebradil/docoseco
arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-dephell
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python3
depends = python-ruamel-yaml
provides = docoseco
source = https://files.pythonhosted.org/packages/source/d/docoseco/docoseco-1.0.0.tar.gz
- sha512sums = 30c7652873e296237bc0eda6226a581f7ad618f473790cb843de041afd324c37255ed88acd97783c5f1533dd4ca7c3974f0f3d87c42c2849426fe15ed5803199
pkgname = docoseco
diff --git a/PKGBUILD b/PKGBUILD
index 674bdb8eb9f7..41b6b613523b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
-#Maintainer: German Lashevich <german.lashevich@gmail.com>
-
+# Maintainer: German Lashevich <german.lashevich@gmail.com>
+#
+# Source: https://github.com/zebradil/aur
pkgname=docoseco
pkgver=1.0.0
pkgrel=1
pkgdesc="Automatize management of docker confgs and secrets"
+url="https://github.com/Zebradil/docoseco"
arch=(any)
license=(MIT)
-url="https://github.com/Zebradil/docoseco"
+groups=()
+backup=()
depends=(python3 python-ruamel-yaml)
-makedepends=(python-setuptools python-dephell)
+makedepends=(python-build python-installer python-wheel)
+checkdepends=()
+optdepends=()
+conflicts=()
provides=(docoseco)
-source=(
- https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz
-)
-sha512sums=('30c7652873e296237bc0eda6226a581f7ad618f473790cb843de041afd324c37255ed88acd97783c5f1533dd4ca7c3974f0f3d87c42c2849426fe15ed5803199')
-
-prepare() {
- cd "$pkgname-$pkgver"
- dephell deps convert --from pyproject.toml --to setup.py
- python3 setup.py build
+replaces=()
+source=(https://files.pythonhosted.org/packages/source/d/docoseco/docoseco-1.0.0.tar.gz)
+sha256sums=()
+build ()
+{
+ cd "$pkgname-$pkgver" || exit 1;
+ python -m build --wheel --no-isolation
}
-
-package() {
- cd "$pkgname-$pkgver"
- python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+package ()
+{
+ cd "$pkgname-$pkgver" || exit 1;
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-
-
-# vim: set ts=2 sw=2 et: