summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2015-11-10 20:33:23 -0500
committeracerix2015-11-10 20:33:23 -0500
commit3d89050fe103db09f7a946fe482e658e14c4594b (patch)
tree5d6aa5aa905503d4f5ca4c659e9af1efed3a2adc
parent8d5749ab7d843578a5b96eb8086f8aaecaf2242c (diff)
downloadaur-3d89050fe103db09f7a946fe482e658e14c4594b.tar.gz
update to 1.10
-rw-r--r--PKGBUILD59
-rw-r--r--dogecoin-daemon.install10
2 files changed, 42 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05fc6f025fd1..3acd285a89ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,46 @@
pkg_base=dogecoin
pkgname=('dogecoin-daemon')
-pkgver=1.8.3
-_git_branch=1.8-maint
-pkgrel=3
+pkgver=1.10
+_git_branch=master
+pkgrel=1
arch=('i686' 'x86_64')
-url="http://dogecoin.com/"
+url='http://dogecoin.com/'
makedepends=('boost' 'automoc4' 'protobuf')
+conflicts=('dogecoin-qt') # why can't weeee be friends... (/usr/bin/dogecoind exists in filesystem)
license=('MIT')
-source=(https://github.com/dogecoin/dogecoin/archive/$_git_branch.tar.gz
- https://raw.github.com/dogecoin/dogecoin/$_git_branch/contrib/debian/examples/bitcoin.conf
- https://raw.github.com/dogecoin/dogecoin/$_git_branch/contrib/debian/manpages/bitcoind.1
- https://raw.github.com/dogecoin/dogecoin/$_git_branch/contrib/debian/manpages/bitcoin.conf.5)
-sha256sums=('d86ce7d48452d1a3524217961cbb53859c8c48cd4d7f528b33bd38d331afd9a0'
- 'ad93d42db719310b71129ada2e69c5dce438cbaa900c90c2d8ee062a014cbb88'
- '33deda1a0d805a10cae0f16100f32367d4d109b9deac55a67ecd7e2ec49f80e6'
- '20ce26d2953f34a541f8a0b08b7e6093aa729d11044a60bf0ff4574f97dd36af')
-
+_git_base_url=github.com/$pkg_base/$pkg_base/
+_git_raw_base_url=github.com/$pkg_base/$pkg_base/
+source=(
+ https://$_git_base_url/archive/$_git_branch.tar.gz
+ https://raw.$_git_base_url$_git_branch/contrib/debian/examples/$pkg_base.conf
+ https://raw.$_git_base_url$_git_branch/contrib/debian/manpages/$pkg_base'd.1'
+ https://raw.$_git_base_url$_git_branch/contrib/debian/manpages/$pkg_base.conf.5
+ $pkgname.install
+)
+sha256sums=(
+ '8dc2125a5e36fd20b471ab63a8db837566528b3a23079fdc24da8573d7d98d1a'
+ '1daa77c34dc9b849da6582212e700c8c7ff32a1825cb03ab24fa4df0e2921609'
+ 'e1ff69595c1eb43e801fae557fd395b65bb806dbc2dc0fe16807ab0344e8a866'
+ '34afb1af9e1e628dc32b7a320e23b66b3f384a64cb7cfca500332489a9ca6cd5'
+ '87b5a5c7cbfa9ebb959453858068fca4289bf465b42c8bc12944ab184639e224'
+)
+
build() {
- cd "$srcdir/$pkg_base-$_git_branch"
+ cd $srcdir/$pkg_base-$_git_branch
./autogen.sh
- CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1"
- ./configure --prefix=/usr --with-gui=no --disable-tests --without-miniupnpc --with-incompatible-bdb
+ #CXXFLAGS='$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1'
+ ./configure --enable-cxx --prefix=/usr --with-gui=no --disable-tests --without-miniupnpc --with-incompatible-bdb
make
}
package_dogecoin-daemon() {
- pkgdesc="Dogecoin is a peer-to-peer network based digital currency - daemon"
+ pkgdesc='Dogecoin is a peer-to-peer network based digital currency - daemon'
depends=(boost-libs openssl)
- cd "$srcdir/$pkg_base-$_git_branch"
- install -Dm755 src/dogecoind "$pkgdir"/usr/bin/dogecoind
- install -Dm644 "$srcdir"/bitcoin.conf \
- "$pkgdir/usr/share/doc/$pkgname/examples/dogecoin.conf"
- install -Dm644 "$srcdir"/bitcoind.1 \
- "$pkgdir"/usr/share/man/man1/dogecoind.1
- install -Dm644 "$srcdir"/bitcoin.conf.5 \
- "$pkgdir"/usr/share/man/man5/dogecoin.conf.5
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ cd $srcdir/$pkg_base-$_git_branch
+ install -Dm755 src/$pkg_base'd' $pkgdir/usr/bin/$pkg_base'd'
+ install -Dm644 $srcdir/$pkg_base.conf $pkgdir/usr/share/doc/$pkgname/examples/$pkg_base.conf
+ install -Dm644 $srcdir/$pkg_base'd.1' $pkgdir/usr/share/man/man1/$pkg_base'd.1'
+ install -Dm644 $srcdir/$pkg_base.conf.5 $pkgdir/usr/share/man/man5/$pkg_base.conf.5
+ install -Dm644 COPYING '$pkgdir/usr/share/licenses/$pkgname/COPYING'
}
-
diff --git a/dogecoin-daemon.install b/dogecoin-daemon.install
new file mode 100644
index 000000000000..f622d898bd50
--- /dev/null
+++ b/dogecoin-daemon.install
@@ -0,0 +1,10 @@
+
+post_upgrade(){
+
+ if [[ "$(vercmp $2 1.10)" -lt 0 ]]; then
+ echo ":: Major version update, -reindex required."
+ echo " https://github.com/dogecoin/dogecoin/releases/tag/v1.10.0"
+ fi
+
+}
+