summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2021-01-03 15:22:24 -0500
committeracerix2021-01-03 15:22:24 -0500
commit6aa864638730b8cb7d48bbfd79d99034908ea074 (patch)
tree2a0c2f414ace15bc01ccfc9c1f651a993be23f39
parentc82882b6e015a9d940ddc9a76d7086daef20a37f (diff)
downloadaur-6aa864638730b8cb7d48bbfd79d99034908ea074.tar.gz
Fix missing headers
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--boost.patch81
-rw-r--r--deque.patch11
-rw-r--r--qpainterpath.patch11
5 files changed, 126 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9cab4b54ce0..deac534abde9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dogecoin-daemon
pkgver = 1.14.2
- pkgrel = 1
+ pkgrel = 2
url = https://dogecoin.com/
arch = x86_64
license = MIT
@@ -10,14 +10,21 @@ pkgbase = dogecoin-daemon
source = dogecoin-daemon-1.14.2.tar.gz::https://github.com/dogecoin/dogecoin/archive/v1.14.2.tar.gz
source = dogecoin.sysusers
source = dogecoin.tmpfiles
+ source = boost.patch
+ source = deque.patch
+ source = qpainterpath.patch
validpgpkeys = 1DDC450B45DB5ADCCF5DDA7F8E4217C6D47D946D
sha256sums = 416581d0af2df05ededb400b9434765eeaeb1396c9f3ef80a7b59a88c74a90cc
sha256sums = eae13ea082a6431bb9552b5bddd8d1a5100ba883540c1e520685272d4307ca7f
sha256sums = eaf022a60cb3297a31148b047bd473eef5bb08ec011f6ed29869061a03342d94
+ sha256sums = 7a9129b8a99ed6c93d409188a9111aeaa5ef556aabc194b10a0f0516693a6074
+ sha256sums = f5464a8082741adb0f72767a701ac6c43972f1d47da0c96ad20e268a4899baa7
+ sha256sums = 80dfca2c5b354423aab4e88677d8b97a21bd9f2089d96a39fb3962944fb81b78
pkgname = dogecoin-daemon
pkgdesc = Dogecoin is a peer-to-peer network based digital currency - daemon
depends = boost-libs
depends = libevent
depends = zeromq
+ conflicts = dogecoin-qt
diff --git a/PKGBUILD b/PKGBUILD
index c244bc147d82..1bc465dbf61e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,33 @@
_pkgbase=dogecoin
pkgname=('dogecoin-daemon') # 'dogecoin-cli' 'dogecoin-tx')
pkgver=1.14.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://dogecoin.com/'
makedepends=('boost' 'libevent' 'zeromq')
license=('MIT')
source=("$pkgname-$pkgver.tar.gz::https://github.com/$_pkgbase/$_pkgbase/archive/v$pkgver.tar.gz"
"dogecoin.sysusers"
- "dogecoin.tmpfiles")
+ "dogecoin.tmpfiles"
+ "boost.patch"
+ "deque.patch"
+ "qpainterpath.patch")
sha256sums=('416581d0af2df05ededb400b9434765eeaeb1396c9f3ef80a7b59a88c74a90cc'
'eae13ea082a6431bb9552b5bddd8d1a5100ba883540c1e520685272d4307ca7f'
- 'eaf022a60cb3297a31148b047bd473eef5bb08ec011f6ed29869061a03342d94')
+ 'eaf022a60cb3297a31148b047bd473eef5bb08ec011f6ed29869061a03342d94'
+ '7a9129b8a99ed6c93d409188a9111aeaa5ef556aabc194b10a0f0516693a6074'
+ 'f5464a8082741adb0f72767a701ac6c43972f1d47da0c96ad20e268a4899baa7'
+ '80dfca2c5b354423aab4e88677d8b97a21bd9f2089d96a39fb3962944fb81b78')
+
validpgpkeys=('1DDC450B45DB5ADCCF5DDA7F8E4217C6D47D946D')
prepare() {
cd "$_pkgbase-$pkgver"
autoreconf -fi
+
+ patch -p2 <$srcdir/deque.patch
+ patch -p1 <$srcdir/qpainterpath.patch
+ patch -p2 <$srcdir/boost.patch
}
build() {
@@ -30,6 +41,7 @@ build() {
package_dogecoin-daemon() {
pkgdesc="Dogecoin is a peer-to-peer network based digital currency - daemon"
depends=(boost-libs libevent zeromq)
+ conflicts=(dogecoin-qt)
cd $_pkgbase-$pkgver
install -Dm755 src/dogecoind "$pkgdir"/usr/bin/dogecoind
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 000000000000..2780315d50b6
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,81 @@
+diff -ur src2/dogecoin-1.14.2/src/validation.cpp src/dogecoin-1.14.2/src/validation.cpp
+--- src2/dogecoin-1.14.2/src/validation.cpp 2019-04-08 14:28:20.000000000 +0700
++++ src/dogecoin-1.14.2/src/validation.cpp 2020-02-03 18:31:55.196768990 +0700
+@@ -44,6 +44,7 @@
+
+ #include <boost/algorithm/string/replace.hpp>
+ #include <boost/algorithm/string/join.hpp>
++#include <boost/bind.hpp>
+ #include <boost/filesystem.hpp>
+ #include <boost/filesystem/fstream.hpp>
+ #include <boost/math/distributions/poisson.hpp>
+
+--- src2/dogecoin-1.14.2/src/validationinterface.cpp 2020-12-22 05:09:29.305584746 -0800
++++ src/dogecoin-1.14.2/src/validationinterface.cpp 2020-12-22 04:55:54.489730962 -0800
+@@ -5,6 +5,8 @@
+
+ #include "validationinterface.h"
+
++#include <boost/bind.hpp>
++
+ static CMainSignals g_signals;
+
+ CMainSignals& GetMainSignals()
+
+--- src2/dogecoin-1.14.2/src/qt/bitcoingui.cpp 2020-12-22 05:14:22.863474268 -0800
++++ src2/dogecoin-1.14.2/src/qt/bitcoingui.cpp 2020-12-22 05:05:15.267433930 -0800
+@@ -38,6 +38,8 @@
+
+ #include <iostream>
+
++#include <boost/bind.hpp>
++
+ #include <QAction>
+ #include <QApplication>
+ #include <QDateTime>
+
+--- src2/dogecoin-1.14.2/src/qt/clientmodel.cpp 2020-12-22 05:14:33.973393228 -0800
++++ src2/dogecoin-1.14.2/src/qt/clientmodel.cpp 2020-12-22 05:05:34.335287787 -0800
+@@ -21,6 +21,8 @@
+
+ #include <stdint.h>
+
++#include <boost/bind.hpp>
++
+ #include <QDebug>
+ #include <QTimer>
+
+--- src2/dogecoin-1.14.2/src/qt/splashscreen.cpp 2020-12-22 05:14:44.537316110 -0800
++++ src2/dogecoin-1.14.2/src/qt/splashscreen.cpp 2020-12-22 05:05:50.163166476 -0800
+@@ -20,6 +20,8 @@
+ #include "wallet/wallet.h"
+ #endif
+
++#include <boost/bind.hpp>
++
+ #include <QApplication>
+ #include <QCloseEvent>
+ #include <QDesktopWidget>
+
+--- src2/dogecoin-1.14.2/src/qt/transactiontablemodel.cpp 2020-12-22 05:14:54.453243665 -0800
++++ src2/dogecoin-1.14.2/src/qt/transactiontablemodel.cpp 2020-12-22 05:06:09.833015722 -0800
+@@ -26,6 +26,7 @@
+ #include <QIcon>
+ #include <QList>
+
++#include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+
+ // Amount column is right-aligned it contains numbers
+
+--- src2/dogecoin-1.14.2/src/qt/walletmodel.cpp 2020-12-22 05:15:01.839189671 -0800
++++ src2/dogecoin-1.14.2/src/qt/walletmodel.cpp 2020-12-22 05:06:28.748870741 -0800
+@@ -28,6 +28,7 @@
+ #include <QSet>
+ #include <QTimer>
+
++#include <boost/bind.hpp>
+ #include <boost/foreach.hpp>
+
+ WalletModel::WalletModel(const PlatformStyle *platformStyle, CWallet *_wallet, OptionsModel *_optionsModel, QObject *parent) :
+
diff --git a/deque.patch b/deque.patch
new file mode 100644
index 000000000000..bcac3a6b7274
--- /dev/null
+++ b/deque.patch
@@ -0,0 +1,11 @@
+diff -ur src2/dogecoin-1.14.2/src/httpserver.cpp src/dogecoin-1.14.2/src/httpserver.cpp
+--- src2/dogecoin-1.14.2/src/httpserver.cpp 2019-04-08 14:28:20.000000000 +0700
++++ src/dogecoin-1.14.2/src/httpserver.cpp 2020-02-03 18:31:55.196768990 +0700
+@@ -19,6 +19,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <deque>
+ #include <future>
+
+ #include <event2/event.h>
diff --git a/qpainterpath.patch b/qpainterpath.patch
new file mode 100644
index 000000000000..d2e9f0d23dff
--- /dev/null
+++ b/qpainterpath.patch
@@ -0,0 +1,11 @@
+diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
+--- a/src/qt/trafficgraphwidget.cpp
++++ b/src/qt/trafficgraphwidget.cpp
+@@ -6,6 +6,7 @@
+ #include "clientmodel.h"
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QColor>
+ #include <QTimer
+