summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsigvaldm2018-02-20 11:52:51 +0100
committersigvaldm2018-02-20 11:52:51 +0100
commit39c5632445ca6c66c5eb26d2cb1d97557fb2eee2 (patch)
treed69805162507ea6ffddbc18a8a556793b45f3340
parent02422c2789552feb5d6182b1b4b70cfd16a968bd (diff)
downloadaur-39c5632445ca6c66c5eb26d2cb1d97557fb2eee2.tar.gz
Bumped to version 2017.2.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD39
-rw-r--r--parse_doxygen.patch11
-rw-r--r--src.patch45
4 files changed, 48 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eeada9938b0..bc5bbe764510 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,32 @@
pkgbase = dolfin
pkgdesc = the C++ and Python interfaces of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations (stable).
- pkgver = 20170509
+ pkgver = 2017.2.0
pkgrel = 1
url = https://bitbucket.org/fenics-project/dolfin
arch = i686
arch = x86_64
groups = fenics
license = GPL3
- makedepends = git
+ depends = python-instant
+ depends = python-pkgconfig
+ depends = python-ply
+ depends = swig
depends = cppunit
depends = eigen
depends = gl2ps
depends = hdf5
depends = python-ffc
- depends = slepc
+ depends = petsc
depends = suitesparse
optdepends = scotch: libraries for graph, mesh and hypergraph partitioning
+ optdepends = python-mpi4py: MPI library for python
+ optdepends = slepc: eigenvalue problem solvers
+ optdepends = petsc4py: interface with PETSc from python
+ optdepends = slepc4py: interface with SLEPc from python
+ optdepends = python-matplotlib: plotting support
conflicts = dolfin-git
options = !emptydirs
- source = dolfin::git+https://bitbucket.org/fenics-project/dolfin.git#tag=2017.1.0
+ source = dolfin::git+https://bitbucket.org/fenics-project/dolfin.git#tag=2017.2.0
md5sums = SKIP
pkgname = dolfin
diff --git a/PKGBUILD b/PKGBUILD
index ee58a68606fd..3311d4ebc843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,38 @@
# Based on dolfin-git, maintained by Lucas H. Gabrielli <heitzmann@gmail.com> and submitted by myles
_base=dolfin
-_fragment="#tag=2017.1.0"
pkgname=${_base}
pkgdesc="the C++ and Python interfaces of FEniCS, providing a consistent PSE (Problem Solving Environment) for ordinary and partial differential equations (stable)."
-pkgver=20170509
+pkgver=2017.2.0
pkgrel=1
arch=('i686' 'x86_64')
url="https://bitbucket.org/fenics-project/${_base}"
license=('GPL3')
groups=('fenics')
conflicts=('dolfin-git')
-depends=('cppunit' 'eigen' 'gl2ps' 'hdf5' 'python-ffc' 'slepc' 'suitesparse')
-optdepends=('scotch: libraries for graph, mesh and hypergraph partitioning')
-makedepends=('git')
+depends=('python-instant'
+ 'python-pkgconfig'
+ 'python-ply'
+ 'swig'
+ 'cppunit'
+ 'eigen'
+ 'gl2ps'
+ 'hdf5'
+ 'python-ffc'
+ 'petsc'
+ 'suitesparse')
+optdepends=('scotch: libraries for graph, mesh and hypergraph partitioning'
+ 'python-mpi4py: MPI library for python'
+ 'slepc: eigenvalue problem solvers'
+ 'petsc4py: interface with PETSc from python'
+ 'slepc4py: interface with SLEPc from python'
+ 'python-matplotlib: plotting support')
options=(!emptydirs)
-source=("${_base}::git+https://bitbucket.org/fenics-project/${_base}.git${_fragment}")
+source=("${_base}::git+https://bitbucket.org/fenics-project/${_base}.git#tag=${pkgver}")
md5sums=('SKIP')
export MAKEFLAGS="-j1"
-pkgver() {
- cd ${_base}
- git log --format="%cd" --date=short -1 | sed 's/-//g'
-}
-
build() {
cd ${_base}
[ -d build ] && rm -rf build
@@ -34,16 +42,19 @@ build() {
local py_interp=`python -c "import os,sys; print(os.path.realpath(sys.executable))"`
- [ -z "$PETSC_DIR" ] && source /etc/profile.d/petsc.sh
- [ -z "$SLEPC_DIR" ] && source /etc/profile.d/slepc.sh
+ [ -n "$PETSC_DIR" ] && source /etc/profile.d/petsc.sh
+ [ -n "$SLEPC_DIR" ] && source /etc/profile.d/slepc.sh
+
+ echo $(pwd)
+ patch ../doc/parse_doxygen.py < ../../../parse_doxygen.patch
cmake ..\
-DCMAKE_INSTALL_PREFIX="${pkg}"/usr \
-DPYTHON_EXECUTABLE="${py_interp}" \
- -DDOLFIN_ENABLE_DOCS=FALSE \
-DCMAKE_SKIP_BUILD_RPATH=TRUE \
-DCMAKE_SKIP_RPATH=TRUE \
-DCMAKE_BUILD_TYPE="Release"
+ # -DDOLFIN_ENABLE_DOCS=FALSE \
make
}
diff --git a/parse_doxygen.patch b/parse_doxygen.patch
new file mode 100644
index 000000000000..951eeebd1fb3
--- /dev/null
+++ b/parse_doxygen.patch
@@ -0,0 +1,11 @@
+--- parse_doxygen.py 2018-02-20 10:09:01.595734780 +0100
++++ parse_doxygen.py.new 2018-02-20 10:09:35.768496224 +0100
+@@ -634,6 +634,8 @@
+ def add_text(text):
+ if text is not None and text.strip():
+ tl = text.split('\n')
++ if isinstance(lines[-1], bytes):
++ lines[-1] = lines[-1].decode('utf-8')
+ lines[-1] += tl[0]
+ lines.extend([indent + line for line in tl[1:]])
+ if text.endswith('\n'):
diff --git a/src.patch b/src.patch
deleted file mode 100644
index 036fe68d6fc1..000000000000
--- a/src.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/src/dolfin/CMakeLists.txt b/src/dolfin/CMakeLists.txt
-index afb33ce..96a5460 100644
---- a/src/dolfin/CMakeLists.txt
-+++ b/src/dolfin/CMakeLists.txt
-@@ -61,7 +61,7 @@ endif()
-
- # Set location of our FindFoo.cmake modules
- set(DOLFIN_CMAKE_DIR "${DOLFIN_SOURCE_DIR}/cmake" CACHE INTERNAL "")
--set(CMAKE_MODULE_PATH "${DOLFIN_CMAKE_DIR}/modules")
-+set(CMAKE_MODULE_PATH "${CMAKE_MODULE_PATH}" "${DOLFIN_CMAKE_DIR}/modules")
-
- # Make sure CMake uses the correct DOLFINConfig.cmake for tests and demos
- set(CMAKE_PREFIX_PATH ${CMAKE_PREFIX_PATH} ${CMAKE_CURRENT_BINARY_DIR}/dolfin)
-diff --git a/src/dolfin/cmake/modules/FindPaStiX.cmake b/src/dolfin/cmake/modules/FindPaStiX.cmake
-index be2f60a..6b2566a 100644
---- a/src/dolfin/cmake/modules/FindPaStiX.cmake
-+++ b/src/dolfin/cmake/modules/FindPaStiX.cmake
-@@ -123,6 +123,8 @@ elseif (PASTIX_INCLUDE_DIRS AND PASTIX_LIBRARIES)
- set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} ${MPI_C_COMPILE_FLAGS}")
- endif()
-
-+ set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} "-lpastix -llapack -lbz2 -lptscotch -lscotcherr")
-+
- # Build and run test program
- include(CheckCSourceRuns)
- check_c_source_runs("
-diff --git a/src/dolfin/cmake/modules/FindSCOTCH.cmake b/src/dolfin/cmake/modules/FindSCOTCH.cmake
-index 58b96b4..97d7264 100644
---- a/src/dolfin/cmake/modules/FindSCOTCH.cmake
-+++ b/src/dolfin/cmake/modules/FindSCOTCH.cmake
-@@ -159,6 +159,14 @@ elseif (SCOTCH_INCLUDE_DIRS AND SCOTCH_LIBRARIES)
- set(CMAKE_REQUIRED_INCLUDES ${SCOTCH_INCLUDE_DIRS})
- set(CMAKE_REQUIRED_LIBRARIES ${SCOTCH_LIBRARIES})
- #set(CMAKE_REQUIRED_LIBRARIES ${SCOTCH_LIBRARY} ${SCOTCHERR_LIBRARY})
-+ # TODO: see if scotch was built against bzip2 before finding
-+ # nm --dynamic /usr/lib/libscotch.so | grep -w BZ2_bzRead
-+ if (NOT BZIP2_FOUND)
-+ find_package(BZip2)
-+ endif()
-+ if (BZIP2_FOUND)
-+ set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ${BZIP2_LIBRARIES})
-+ endif()
-
- # Add MPI variables if MPI has been found
- if (MPI_CXX_FOUND)