summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-11-05 20:41:46 -0800
committerxiota2023-11-05 20:41:46 -0800
commit9880bec52dbbb45bd87c048241a85f46e74d1e94 (patch)
tree4e1eb5df518d704dd20f8cd1fa519d5ba4896d3c
parent3b32705e7ffb5dae143277981940617dccd6a347 (diff)
downloadaur-dolphin-hau-git.tar.gz
metapackage
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD60
3 files changed, 16 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7d2aaa044b1..a9ba121da438 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,8 @@
pkgbase = dolphin-hau-git
- pkgdesc = A Wii/GameCube Emulator (Melee/Project M)
- pkgver = 5.0_hau.1
+ pkgdesc = metapackage - migrate to dolphin-emu
+ pkgver = 5.0.a
pkgrel = 1
- url = http://github.com/HannesMann/dolphin-hau
- arch = x86_64
- license = GPL
- makedepends = cmake
- makedepends = git
- depends = bluez-libs
- depends = enet
- depends = ffmpeg
- depends = libao
- depends = libevdev
- depends = mbedtls
- depends = miniupnpc
- depends = openal
- depends = portaudio
- depends = soundtouch
- depends = xdg-utils
- depends = wxgtk
- optdepends = pulseaudio: PulseAudio backend
- options = !emptydirs
- source = dolphin-hau::git+https://github.com/HannesMann/dolphin-hau.git
- sha256sums = SKIP
+ arch = any
pkgname = dolphin-hau-git
- provides = dolphin-hau
- conflicts = dolphin-hau
-
-pkgname = dolphin-hau-cli-git
- depends = dolphin-hau-git
-
+ depends = dolphin-emu
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 4c5847be272f..96cf3d001f92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,12 @@
-# Maintainer: Hannes Mann <hannesmann2000@gmail.com>
-# Based on: https://aur.archlinux.org/dolphin-emu-git.git
+# Maintainer:
-pkgbase=dolphin-hau-git
-pkgname=('dolphin-hau-git' 'dolphin-hau-cli-git')
-pkgver=5.0_hau.1
+_newpkg='dolphin-emu'
+pkgname='dolphin-hau-git'
+pkgver=5.0.a
pkgrel=1
-pkgdesc='A Wii/GameCube Emulator (Melee/Project M)'
-arch=('x86_64')
-url='http://github.com/HannesMann/dolphin-hau'
-license=('GPL')
-depends=('bluez-libs' 'enet' 'ffmpeg' 'libao' 'libevdev' 'mbedtls' 'miniupnpc'
- 'openal' 'portaudio' 'soundtouch' 'xdg-utils' 'wxgtk')
-makedepends=('cmake' 'git')
-optdepends=('pulseaudio: PulseAudio backend')
-options=('!emptydirs')
-source=('dolphin-hau::git+https://github.com/HannesMann/dolphin-hau.git')
-sha256sums=('SKIP')
+pkgdesc="metapackage - migrate to $_newpkg"
+arch=('any')
-prepare() {
- cd dolphin-hau
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
-}
-
-build() {
- cd dolphin-hau/build
-
- cmake .. \
- -DCMAKE_INSTALL_PREFIX='/usr'
- make
-}
-
-package_dolphin-hau-git() {
- provides=('dolphin-hau')
- conflicts=('dolphin-hau')
-
- cd dolphin-hau/build
-
- make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}"/usr/bin/dolphin-hau-{nogui}
-
- install -Dm 644 ../Data/51-usb-device.rules -t "${pkgdir}"/usr/lib/udev/rules.d/
-}
-
-package_dolphin-hau-cli-git() {
- depends=('dolphin-hau-git')
-
- cd dolphin-hau/build
-
- install -dm 755 "${pkgdir}"/usr/bin
- install -m 755 Binaries/dolphin-hau-nogui "${pkgdir}"/usr/bin/dolphin-hau-cli
+package() {
+ depends=("$_newpkg")
}