summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2020-06-12 02:59:19 -0400
committerAndy Kluger2020-06-12 02:59:19 -0400
commit3072e7d7ce9e31244f867fbb4d4e39bf4cfc1104 (patch)
tree418d5b71ad1df0779ae209f5399ffa941a489b32
parent369bad4462a3fb60614e3604e9c72c0f5a446b01 (diff)
downloadaur-3072e7d7ce9e31244f867fbb4d4e39bf4cfc1104.tar.gz
version bump; merge updates from Arch dolphin PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d081168eb71..c1acd06eb78d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = dolphin-meld
pkgdesc = KDE File Manager, using Meld rather than Kompare
- pkgver = 20.04.1
+ pkgver = 20.04.2
pkgrel = 1
url = https://kde.org/applications/system/dolphin/
arch = x86_64
groups = kde-applications
- groups = kdebase
+ groups = kde-system
license = LGPL
makedepends = extra-cmake-modules
makedepends = kdoctools
@@ -15,21 +15,20 @@ pkgbase = dolphin-meld
depends = kcmutils
depends = kparts
depends = kinit
- depends = phonon-qt5
optdepends = kde-cli-tools: for editing file type options
optdepends = ffmpegthumbs: video thumbnails
optdepends = kdegraphics-thumbnailers: PDF and PS thumbnails
optdepends = meld: file comparisons
optdepends = konsole: terminal panel
optdepends = purpose: share context menu
- provides = dolphin=20.04.1
- conflicts = dolphin=20.04.1
- source = https://download.kde.org/stable/release-service/20.04.1/src/dolphin-20.04.1.tar.xz
- source = https://download.kde.org/stable/release-service/20.04.1/src/dolphin-20.04.1.tar.xz.sig
+ provides = dolphin=20.04.2
+ conflicts = dolphin=20.04.2
+ source = https://download.kde.org/stable/release-service/20.04.2/src/dolphin-20.04.2.tar.xz
+ source = https://download.kde.org/stable/release-service/20.04.2/src/dolphin-20.04.2.tar.xz.sig
source = dolphin-meld.patch
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
- sha256sums = ba5db89b338d29c5fa492fc7ce08304427d8db51775fe5a4d34b444034d02577
+ sha256sums = 37e4c1510227112365418cacccabc6d535fb0880e182a2341bfe00d585d14fb2
sha256sums = SKIP
sha256sums = 13107b72348bd7eea5665196dc4a37c21bff131bbc8457efe77ef8c3e9450c7b
diff --git a/PKGBUILD b/PKGBUILD
index cdc355ce8cc3..106aab1b099e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=dolphin-meld
_pkgname=dolphin
-pkgver=20.04.1
+pkgver=20.04.2
pkgrel=1
pkgdesc="KDE File Manager, using Meld rather than Kompare"
arch=(x86_64)
@@ -15,15 +15,15 @@ url="https://kde.org/applications/system/dolphin/"
license=(LGPL)
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname=$pkgver")
-depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kinit phonon-qt5)
+depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kinit)
makedepends=(extra-cmake-modules kdoctools)
optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video thumbnails' 'kdegraphics-thumbnailers: PDF and PS thumbnails'
'meld: file comparisons'
'konsole: terminal panel' 'purpose: share context menu')
-groups=(kde-applications kdebase)
+groups=(kde-applications kde-system)
source=("https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz"{,.sig}
"dolphin-meld.patch")
-sha256sums=('ba5db89b338d29c5fa492fc7ce08304427d8db51775fe5a4d34b444034d02577'
+sha256sums=('37e4c1510227112365418cacccabc6d535fb0880e182a2341bfe00d585d14fb2'
'SKIP'
'13107b72348bd7eea5665196dc4a37c21bff131bbc8457efe77ef8c3e9450c7b')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
@@ -36,13 +36,11 @@ prepare() {
}
build() {
- cd build
- cmake ../$_pkgname-$pkgver \
+ cmake -B build -S $_pkgname-$pkgver \
-DBUILD_TESTING=OFF
- make
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}