aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDian Fay2016-10-18 23:51:53 -0400
committerDian Fay2016-10-18 23:51:53 -0400
commit6c6111c94a0b182a2d7d2ef4990cb874212f7620 (patch)
tree0c55710c96f08d76360294dd72001c7958642e23
parentfde739df32c2e190dc7deebf7c793bdd75778e4d (diff)
downloadaur-6c6111c94a0b182a2d7d2ef4990cb874212f7620.tar.gz
small improvements/cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xdom435
-rw-r--r--dom4-server.install2
4 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfac2e258f95..f49bfce107d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,7 @@ pkgbase = dom4-server
md5sums = d7467fb7a599236f71d428a85cf05014
md5sums = e9772a237cc540558e74235b98df8a7f
md5sums = 338b8462868ecf6cc56c4a520cea6bac
- md5sums = d25b42aae80b30633920605faa36ed35
+ md5sums = 7abd186618d24111ec3cf7c24332a7e0
pkgname = dom4-server
diff --git a/PKGBUILD b/PKGBUILD
index ae7469d1450d..8be0b6284a5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,4 +30,4 @@ md5sums=('03931b9317799ef4ae7fded185cd1c69'
'd7467fb7a599236f71d428a85cf05014'
'e9772a237cc540558e74235b98df8a7f'
'338b8462868ecf6cc56c4a520cea6bac'
- 'd25b42aae80b30633920605faa36ed35')
+ '7abd186618d24111ec3cf7c24332a7e0')
diff --git a/dom4 b/dom4
index a2ffb654ecd2..558672ef8acc 100755
--- a/dom4
+++ b/dom4
@@ -60,19 +60,28 @@ EOF
echo
else
cat << EOF | sudo -u dom4 tee /usr/share/dom4/config/$1.properties > /dev/null
-###### SERVER INFO ######
-# Set the map file. Any image file must have the same name but a different extension.
-mapfile my_pretty_world.map
-# Allow host to set dropped-out players to computer control
-masterpass supersecure
-# Will default to localhost
-ipadr 127.0.0.1
-# Must be between 1024 and 65535, and forwarded in your router config
+# See http://www.illwinter.com/dom4/startoptions.pdf for a full reference.
+# Sections 3-5, 3-6, and 3-7 are especially relevant. Switches should be
+# reproduced as given in the documentation, without any leading dashes (so to
+# pass the '--era 1' setting to the server, include the line 'era 1' in this
+# file).
+
+# SERVER INFO
+
+# Port number must be between 1024 and 65535, and forwarded in your router
+# config. Master password is not required but useful if you want to be able to
+# set dropped-out players to computer control.
+
port 6666
-# Time between turn rollover
-hours 26
+masterpass supersecure
+
+# GAME SETTINGS
+
+# The mapfile is required. Any .rgb or image files must have the same filename
+# and differ only in extension since the map data is automatically copied over.
-###### GAME SETTINGS ######
+mapfile my_pretty_world.map
+hours 26
era 1
renaming
storyevents
@@ -84,11 +93,9 @@ EOF
sudo -u dom4 $EDITOR /usr/share/dom4/config/$1.properties
- mapfile=$(grep -oP "mapfile\s+\K.+" /usr/share/dom4/config/$1.properties)
+ mapfile=$(grep -oP "^mapfile\s+\K.+" /usr/share/dom4/config/$1.properties)
mapname=$(basename $mapfile .map)
- sudo -u dom4 mkdir -p /usr/share/dom4/maps
-
if [[ -s "$mapname.map" ]]; then
echo "Copying $mapname map files..."
diff --git a/dom4-server.install b/dom4-server.install
index 2c445fdfe4cf..1b841d227dd8 100644
--- a/dom4-server.install
+++ b/dom4-server.install
@@ -14,6 +14,8 @@ post_upgrade() {
fi
mkdir -p /opt/dom4
+ mkdir -p /usr/share/dom4/config
+ mkdir -p /usr/share/dom4/maps
chown dom4:dom4 /usr/bin/dom4-server
chown -R dom4:dom4 /usr/share/dom4