summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvid Norlander2022-10-18 10:17:55 +0200
committerArvid Norlander2022-10-18 10:17:55 +0200
commit1c5b01ec7626461744134359472135e7aae1b613 (patch)
treecd80644cb2d58df5bf475095ce09ba13f9fccf25
parent33e06a4f927c1d4bc795a0fb0abc08866a7b91b0 (diff)
downloadaur-1c5b01ec7626461744134359472135e7aae1b613.tar.gz
Update to 2022.1.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--01-luajit-gcc12.patch15
-rw-r--r--PKGBUILD34
-rw-r--r--python3.9.patch44
5 files changed, 45 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa950394dd2a..f2bf8b7dae50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = domoticz
pkgdesc = Web based home automation
- pkgver = 2020.2
- pkgrel = 5
+ pkgver = 2022.1
+ pkgrel = 1
url = https://www.domoticz.com
install = domoticz.install
arch = i686
@@ -9,11 +9,10 @@ pkgbase = domoticz
arch = arm
arch = armv6h
arch = armv7h
- license = GPL-3.0
+ license = GPL3
makedepends = git
makedepends = cmake
makedepends = boost
- makedepends = python
depends = libusb-compat
depends = curl
depends = sqlite
@@ -24,12 +23,11 @@ pkgbase = domoticz
depends = mosquitto
depends = jsoncpp
depends = python
- source = https://github.com/domoticz/domoticz/archive/2020.2.tar.gz
+ source = domoticz-2022.1.tar.gz::https://github.com/domoticz/domoticz/archive/2022.1.tar.gz
source = domoticz.service
- source = python3.9.patch
- md5sums = fd383a13d13d0976c72f332d6db1d24e
+ source = 01-luajit-gcc12.patch
+ md5sums = 03ebcd9af34fbd2737725303a50ad9fd
md5sums = c13a3f5d04142587d159820156a6223f
- md5sums = 39b1a4aa57dff4d7083f67870bc1fa1b
+ md5sums = 84070f8332c86524a088cee1d829b5b7
pkgname = domoticz
-
diff --git a/.gitignore b/.gitignore
index 58c0555641dc..d506f8e1b90f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,8 @@
+*.log
*.tar.gz
*.tar.xz
+*.tar.zst
*.tgz
*.txt
-src/
pkg/
+src/
diff --git a/01-luajit-gcc12.patch b/01-luajit-gcc12.patch
new file mode 100644
index 000000000000..87abaca552aa
--- /dev/null
+++ b/01-luajit-gcc12.patch
@@ -0,0 +1,15 @@
+diff --git a/main/LuaTable.cpp b/main/LuaTable.cpp
+index 6475fac6bd..eca7489a42 100644
+--- a/main/LuaTable.cpp
++++ b/main/LuaTable.cpp
+@@ -6,9 +6,9 @@ extern "C" {
+ #include <lua.h>
+ #include <lualib.h>
+ #include <lauxlib.h>
++}
+
+ #include <utility>
+-}
+
+ CLuaTable::CLuaTable(lua_State *lua_state, const std::string &Name)
+ {
diff --git a/PKGBUILD b/PKGBUILD
index 53302c802040..e5993a52b97d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer : Martin Dratva <raquacontact+aur at gmail dot com>
+# Maintainer : Arvid Norlander <VorpalBlade (at) users DOT noreply DOT github DOT com>
+# Contributor : Martin Dratva <raquacontact+aur at gmail dot com>
# Contributor : Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor : Jaron Viƫtor <thulinma@thulinma.com>
# Contributor : Jameson Pugh <imntreal@gmail.com>
pkgname=domoticz
-pkgver=2020.2
-pkgrel=5
+pkgver=2022.1
+pkgrel=1
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url='https://www.domoticz.com'
-license=('GPL-3.0')
+license=('GPL3')
depends=('libusb-compat'
'curl'
'sqlite'
@@ -22,22 +23,29 @@ depends=('libusb-compat'
'python')
makedepends=('git'
'cmake'
- 'boost'
- 'python')
+ 'boost')
install='domoticz.install'
-source=("https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
'domoticz.service'
- 'python3.9.patch')
-md5sums=('fd383a13d13d0976c72f332d6db1d24e'
+ '01-luajit-gcc12.patch')
+md5sums=('03ebcd9af34fbd2737725303a50ad9fd'
'c13a3f5d04142587d159820156a6223f'
- '39b1a4aa57dff4d7083f67870bc1fa1b')
+ '84070f8332c86524a088cee1d829b5b7')
prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ local p
+ for p in "${srcdir}"/*.patch; do
+ patch --forward --strip=1 --input="${p}"
+ done
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
- patch --forward --strip=1 --input="${srcdir}/python3.9.patch"
+}
+build() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
+
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/opt/domoticz \
-DUSE_STATIC_OPENZWAVE=NO \
@@ -50,15 +58,13 @@ prepare() {
-DUSE_OPENSSL_STATIC=NO \
-DUSE_PYTHON=YES \
..
-}
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}/build"
make
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}/build
+
make DESTDIR=${pkgdir} install
chmod o+r "${pkgdir}/opt/domoticz/updatedomo"
mkdir -p "${pkgdir}/usr/lib/systemd/system"
diff --git a/python3.9.patch b/python3.9.patch
deleted file mode 100644
index 266fc190b7ef..000000000000
--- a/python3.9.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -u --unified --recursive --text /home/raqua/domoticz/src/domoticz-2020.2/hardware/plugins/DelayedLink.h /home/raqua/domoticz2/src/domoticz-2020.2/hardware/plugins/DelayedLink.h
---- ./domoticz-2020.2/hardware/plugins/DelayedLink.h 2020-04-26 15:49:25.000000000 +0200
-+++ ./domoticz-2020.2/hardware/plugins/DelayedLink.h 2020-12-05 14:22:49.533604214 +0100
-@@ -14,6 +14,17 @@
- #include <frameobject.h>
- #include "../../main/Helper.h"
-
-+#ifndef _Py_DEC_REFTOTAL
-+ /* _Py_DEC_REFTOTAL macro has been removed from Python 3.9 by:
-+ https://github.com/python/cpython/commit/49932fec62c616ec88da52642339d83ae719e924 */
-+# ifdef Py_REF_DEBUG
-+# define _Py_DEC_REFTOTAL _Py_RefTotal--
-+# else
-+# define _Py_DEC_REFTOTAL
-+# define _Py_Dealloc
-+# endif
-+#endif
-+
- #if PY_VERSION_HEX >= 0x030800f0
- static inline void
- py3__Py_DECREF(const char *filename, int lineno, PyObject *op)
-@@ -182,12 +193,14 @@
- if (!shared_lib_) {
- #ifdef WIN32
- # ifdef _DEBUG
-+ if (!shared_lib_) shared_lib_ = LoadLibrary("python39_d.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python38_d.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python37_d.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python36_d.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python35_d.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python34_d.dll");
- # else
-+ if (!shared_lib_) shared_lib_ = LoadLibrary("python39.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python38.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python37.dll");
- if (!shared_lib_) shared_lib_ = LoadLibrary("python36.dll");
-@@ -195,6 +208,7 @@
- if (!shared_lib_) shared_lib_ = LoadLibrary("python34.dll");
- # endif
- #else
-+ if (!shared_lib_) FindLibrary("python3.9", true);
- if (!shared_lib_) FindLibrary("python3.8", true);
- if (!shared_lib_) FindLibrary("python3.7", true);
- if (!shared_lib_) FindLibrary("python3.6", true);