summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvid Norlander2023-01-22 11:14:26 +0100
committerArvid Norlander2023-01-22 11:14:26 +0100
commit69b2db11424c2f96a6f278148aba969ae3badce1 (patch)
treed1f2a0a632c1fc804f53d3862141954f132591b6
parent1c5b01ec7626461744134359472135e7aae1b613 (diff)
downloadaur-69b2db11424c2f96a6f278148aba969ae3badce1.tar.gz
Update to version 2022.2
-rw-r--r--.SRCINFO10
-rw-r--r--01-luajit-gcc12.patch15
-rw-r--r--PKGBUILD18
-rw-r--r--domoticz.install2
-rw-r--r--domoticz.service6
5 files changed, 16 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2bf8b7dae50..ae85167c380e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = domoticz
pkgdesc = Web based home automation
- pkgver = 2022.1
+ pkgver = 2022.2
pkgrel = 1
url = https://www.domoticz.com
install = domoticz.install
@@ -23,11 +23,9 @@ pkgbase = domoticz
depends = mosquitto
depends = jsoncpp
depends = python
- source = domoticz-2022.1.tar.gz::https://github.com/domoticz/domoticz/archive/2022.1.tar.gz
+ source = domoticz-2022.2.tar.gz::https://github.com/domoticz/domoticz/archive/2022.2.tar.gz
source = domoticz.service
- source = 01-luajit-gcc12.patch
- md5sums = 03ebcd9af34fbd2737725303a50ad9fd
- md5sums = c13a3f5d04142587d159820156a6223f
- md5sums = 84070f8332c86524a088cee1d829b5b7
+ md5sums = f9ac0ba4828dc40a19c1f24f8b2d9614
+ md5sums = b1c9ad64a372714ffceeb3d3adf7412b
pkgname = domoticz
diff --git a/01-luajit-gcc12.patch b/01-luajit-gcc12.patch
deleted file mode 100644
index 87abaca552aa..000000000000
--- a/01-luajit-gcc12.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/main/LuaTable.cpp b/main/LuaTable.cpp
-index 6475fac6bd..eca7489a42 100644
---- a/main/LuaTable.cpp
-+++ b/main/LuaTable.cpp
-@@ -6,9 +6,9 @@ extern "C" {
- #include <lua.h>
- #include <lualib.h>
- #include <lauxlib.h>
-+}
-
- #include <utility>
--}
-
- CLuaTable::CLuaTable(lua_State *lua_state, const std::string &Name)
- {
diff --git a/PKGBUILD b/PKGBUILD
index e5993a52b97d..5dc9a84f7cb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor : Jameson Pugh <imntreal@gmail.com>
pkgname=domoticz
-pkgver=2022.1
+pkgver=2022.2
pkgrel=1
pkgdesc="Web based home automation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
@@ -26,19 +26,17 @@ makedepends=('git'
'boost')
install='domoticz.install'
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/domoticz/domoticz/archive/${pkgver}.tar.gz"
- 'domoticz.service'
- '01-luajit-gcc12.patch')
-md5sums=('03ebcd9af34fbd2737725303a50ad9fd'
- 'c13a3f5d04142587d159820156a6223f'
- '84070f8332c86524a088cee1d829b5b7')
+ 'domoticz.service')
+md5sums=('f9ac0ba4828dc40a19c1f24f8b2d9614'
+ 'b1c9ad64a372714ffceeb3d3adf7412b')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- local p
- for p in "${srcdir}"/*.patch; do
- patch --forward --strip=1 --input="${p}"
- done
+ #local p
+ #for p in "${srcdir}"/*.patch; do
+ # patch --forward --strip=1 --input="${p}"
+ #done
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
}
diff --git a/domoticz.install b/domoticz.install
index 2e16f59b7750..58a50acb3adf 100644
--- a/domoticz.install
+++ b/domoticz.install
@@ -1,5 +1,5 @@
post_install() {
- printf "post_instal...\n"
+ printf "post_install...\n"
gpasswd -a http uucp
chown -R http:http "${pkgdir}/opt/domoticz"
}
diff --git a/domoticz.service b/domoticz.service
index ea71ce28eaea..691dee388817 100644
--- a/domoticz.service
+++ b/domoticz.service
@@ -6,9 +6,9 @@ After=network.target
User=http
Group=http
PermissionsStartOnly=true
-ExecStartPre=/usr/bin/install -d -m 0700 -o http -g http /var/run/domoticz
-ExecStart=/opt/domoticz/domoticz -www 8080 -pidfile /var/run/domoticz/domoticz.pid
-PIDFile=/var/run/domoticz/domoticz.pid
+ExecStartPre=/usr/bin/install -d -m 0700 -o http -g http /run/domoticz
+ExecStart=/opt/domoticz/domoticz -www 8080 -pidfile /run/domoticz/domoticz.pid
+PIDFile=/run/domoticz/domoticz.pid
WorkingDirectory=/opt/domoticz
RestartSec=5
Restart=on-failure