summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-17 20:02:58 -0400
committerSlashbunny2009-08-17 20:02:58 -0400
commit3c69e601007539671c553e4002eb061cd5425e77 (patch)
treecd4bcd387f36d2b40211b38c6ef58ee5a309dcc5
downloadaur-3c69e601007539671c553e4002eb061cd5425e77.tar.gz
Adopted doom3
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD49
-rw-r--r--doom3-dedicated.sh4
-rwxr-xr-xdoom3-dedicated_64.sh4
-rw-r--r--doom3.desktop7
-rwxr-xr-xdoom3.install48
-rw-r--r--doom3.pngbin0 -> 6502 bytes
-rw-r--r--doom3.sh4
-rwxr-xr-xdoom3_64.sh4
10 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31ce674b82df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = doom3
+ pkgdesc = Doom 3 Engine. You need the retail .pk4 files to play.
+ pkgver = 1.3.1.1304
+ pkgrel = 2
+ url = http://www.doom3.com/
+ install = doom3.install
+ arch = i686
+ arch = x86_64
+ license = custom:"DOOM 3"
+ license = custom:"PunkBuster"
+ source = http://www.1337-server.net/doom3/doom3-linux-1.3.1.1304.x86.run
+ source = doom3.sh
+ source = doom3-dedicated.sh
+ source = doom3_64.sh
+ source = doom3-dedicated_64.sh
+ source = doom3.png
+ source = doom3.desktop
+ md5sums = 6325f0936f59420d33668754032141cb
+ md5sums = 18c6802eee15ad499e2fd3ae03d641a6
+ md5sums = da4e827e7ddec2209bf832db5cd3ab74
+ md5sums = b8e0aa217e4df414f009fe99448b49bb
+ md5sums = f7c57e01b2c97b6e808add668c68ef36
+ md5sums = f99eb141eecc4b9dd188d6819d741546
+ md5sums = a8a6c7b7befff52cbb6c766466ee4ce9
+
+pkgname = doom3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..0c94edaac7b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+# Contributor: teddy_beer_maniac <teddy_beer_maniac@wp.pl>
+
+pkgname=doom3
+pkgver=1.3.1.1304
+pkgrel=2
+pkgdesc="Doom 3 Engine. You need the retail .pk4 files to play."
+url="http://www.doom3.com/"
+license=('custom:"DOOM 3"' \
+ 'custom:"PunkBuster"')
+[ "$CARCH" = "i686" ] && depends=('libxext' 'libgl' 'alsa-lib>=1.0.6')
+[ "$CARCH" = "x86_64" ] && depends=('lib32-libxext' 'lib32-libgl' 'lib32-alsa-lib>=1.0.6')
+arch=('i686' 'x86_64')
+install="doom3.install"
+source=(http://www.1337-server.net/doom3/$pkgname-linux-$pkgver.x86.run \
+ $pkgname.sh $pkgname-dedicated.sh $pkgname"_64.sh" $pkgname-dedicated_64.sh
+ doom3.png doom3.desktop)
+md5sums=('6325f0936f59420d33668754032141cb'
+ '18c6802eee15ad499e2fd3ae03d641a6'
+ 'da4e827e7ddec2209bf832db5cd3ab74'
+ 'b8e0aa217e4df414f009fe99448b49bb'
+ 'f7c57e01b2c97b6e808add668c68ef36'
+ 'f99eb141eecc4b9dd188d6819d741546'
+ 'a8a6c7b7befff52cbb6c766466ee4ce9')
+
+build() {
+ cd $startdir/src
+ chmod +x $pkgname-linux-$pkgver.x86.run
+ mkdir -p $startdir/pkg/opt/$pkgname $startdir/pkg/usr/bin $startdir/pkg/usr/share/licenses/$pkgname
+ ./$pkgname-linux-$pkgver.x86.run -- -i $startdir/pkg/opt/$pkgname -b $startdir/pkg/usr/bin
+ # ncurses & gtk installers don't return 1 when canceled, so check that files are installed
+ ls $startdir/pkg/opt/$pkgname/base || return 1
+ if [ "$CARCH" == "i686" ]; then
+ install -m755 -D $pkgname.sh $startdir/pkg/opt/$pkgname/$pkgname
+ install -m755 -D $pkgname-dedicated.sh $startdir/pkg/opt/$pkgname/$pkgname-dedicated
+ else
+ install -m755 -D $pkgname"_64.sh" $startdir/pkg/opt/$pkgname/$pkgname
+ install -m755 -D $pkgname-dedicated_64.sh $startdir/pkg/opt/$pkgname/$pkgname-dedicated
+ fi
+
+ ln -sf /opt/$pkgname/$pkgname $startdir/pkg/usr/bin/$pkgname
+ ln -sf /opt/$pkgname/$pkgname-dedicated $startdir/pkg/usr/bin/$pkgname-dedicated
+ ln -sf /opt/$pkgname/License.txt $startdir/pkg/usr/share/licenses/$pkgname/License.txt
+ ln -sf /opt/$pkgname/pb/PB_EULA.txt $startdir/pkg/usr/share/licenses/$pkgname/PB_EULA.txt
+
+ mkdir -p $startdir/pkg/usr/share/pixmaps $startdir/pkg/usr/share/applications
+ install -m644 -D doom3.png $startdir/pkg/usr/share/pixmaps
+ install -m644 -D doom3.desktop $startdir/pkg/usr/share/applications
+}
diff --git a/doom3-dedicated.sh b/doom3-dedicated.sh
new file mode 100644
index 000000000000..2e9ff476fa9c
--- /dev/null
+++ b/doom3-dedicated.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /opt/doom3
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
+exec ./doomded.x86 $*
diff --git a/doom3-dedicated_64.sh b/doom3-dedicated_64.sh
new file mode 100755
index 000000000000..5e6c1fcad3eb
--- /dev/null
+++ b/doom3-dedicated_64.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /opt/doom3
+export LD_LIBRARY_PATH="/opt/lib32/usr/lib/:/opt/lib32/lib/:$LD_LIBRARY_PATH:."
+linux32 ./doomded.x86 $*
diff --git a/doom3.desktop b/doom3.desktop
new file mode 100644
index 000000000000..29463fe9e2d8
--- /dev/null
+++ b/doom3.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=DOOM III
+Exec=/usr/bin/doom3
+Categories=Game;ArcadeGame;
+Icon=doom3
diff --git a/doom3.install b/doom3.install
new file mode 100755
index 000000000000..6bc2d04e42c4
--- /dev/null
+++ b/doom3.install
@@ -0,0 +1,48 @@
+post_install() {
+cat << EOF
+IMPORTANT
+==> In order to use the software, you have to agree to ID Software's license
+==> located in /opt/doom3/License.txt and Punkbuster's license located in
+==> /opt/doom3/pb/PB_EULA.txt
+==> If you don't, please remove this package (pacman -R doom3)
+IMPORTANT2
+==> If You have x86_64 system and nvidia graphics card, You need to install lib32-nvidia-utils package too.
+==> Thanks jarrebylove.
+
+EOF
+
+cat <<-00installInstructions00
+The following files need to be copied from the win32 install CDs
+to your base/ directory ( md5 sums provided below as reference )
+by default, /opt/doom3/base
+
+71b8d37b2444d3d86a36fd61783844fe base/pak000.pk4
+4bc4f3ba04ec2b4f4837be40e840a3c1 base/pak001.pk4
+fa84069e9642ad9aa4b49624150cc345 base/pak002.pk4
+f22d8464997924e4913e467e7d62d5fe base/pak003.pk4
+38561a3c73f93f2e6fd31abf1d4e9102 base/pak004.pk4
+
+If you are also installing the Resurrection of Evil Expansion Pack,
+you need to copy the following file to your d3xp/ directory
+by default, /opt/doom3/d3xp
+
+a883fef0fd10aadeb73d34c462ff865d d3xp/pak000.pk4
+
+Localization is not supported on Linux ( only english ), you should not copy over any of the zpak files.
+
+Start the game with the command: doom3
+Start the dedicated server with the command: doom3-dedicated
+
+If installed, you can start the Expansion Pack directly from the command line with the command: doom3 +set fs_game d3xp
+Or you can select it in the mods menu of the base game.
+
+For troubleshooting and help, see:
+http://zerowing.idsoftware.com/linux/
+00installInstructions00
+ /bin/true
+}
+
+
+op=$1
+shift
+$op $*
diff --git a/doom3.png b/doom3.png
new file mode 100644
index 000000000000..769e9fa9a50a
--- /dev/null
+++ b/doom3.png
Binary files differ
diff --git a/doom3.sh b/doom3.sh
new file mode 100644
index 000000000000..eb0802a37da3
--- /dev/null
+++ b/doom3.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /opt/doom3
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
+exec ./doom.x86 $*
diff --git a/doom3_64.sh b/doom3_64.sh
new file mode 100755
index 000000000000..03617a2048d6
--- /dev/null
+++ b/doom3_64.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /opt/doom3
+export LD_LIBRARY_PATH="/opt/lib32/usr/lib/:/opt/lib32/lib/:$LD_LIBRARY_PATH:."
+linux32 ./doom.x86 $*