summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruser10951082023-09-23 11:18:36 +0200
committeruser10951082023-09-23 11:18:36 +0200
commita2fb37828992d4ad90828bf72787c42a1a831c4c (patch)
tree71786e915c878c5f222ebf2efa5e7161d8f650a2
parent90e9f654313b6e2ef92b5ee11cbfa2ac606d1d32 (diff)
downloadaur-dosbox-gcc.tar.gz
some fixes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--gcc-djgpp.diff23
3 files changed, 9 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c67f5ba684b..2eaa67ccfdda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dosbox-gcc
pkgdesc = djgpp cross-compiler for the dosbox environment
- pkgver = 13.1.0
- pkgrel = 8
+ pkgver = 13.2.0
+ pkgrel = 1
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -19,13 +19,13 @@ pkgbase = dosbox-gcc
depends = libmpc
depends = dosbox-binutils
optdepends = dosbox-djcrx: headers and utilities
- noextract = gcc-13.1.0.tar.xz
+ noextract = gcc-13.2.0.tar.xz
noextract = djcrx205.zip
noextract = v0.8.1.zip
options = !strip
options = staticlibs
options = !emptydirs
- source = https://ftp.gnu.org/gnu/gcc/gcc-13.1.0/gcc-13.1.0.tar.xz
+ source = https://ftp.gnu.org/gnu/gcc/gcc-13.2.0/gcc-13.2.0.tar.xz
source = ftp://www.delorie.com/pub/djgpp/current/v2/djcrx205.zip
source = https://github.com/JuliaMath/openlibm/archive/refs/tags/v0.8.1.zip
source = gcc-djgpp.diff
diff --git a/PKGBUILD b/PKGBUILD
index 7bfab0c07510..8a32c99250d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: janezz55
pkgname=dosbox-gcc
-pkgver=13.1.0
+pkgver=13.2.0
libmver=0.8.1
_target="i586-pc-msdosdjgpp"
_djver=2.05
-pkgrel=8
+pkgrel=1
pkgdesc="djgpp cross-compiler for the dosbox environment"
arch=('i686' 'x86_64')
url="http://gcc.gnu.org"
diff --git a/gcc-djgpp.diff b/gcc-djgpp.diff
index bfe723bd81df..939b281cb59e 100644
--- a/gcc-djgpp.diff
+++ b/gcc-djgpp.diff
@@ -79,10 +79,10 @@ index d1f009cab64..ce1e29da817 100644
#define MAPPED_READING 1
#else
diff --git a/gcc/ada/adaint.c b/gcc/ada/adaint.c
-index 8522094164e..d850d27a3dc 100644
+index 2a193efc002..0930c9671f8 100644
--- a/gcc/ada/adaint.c
+++ b/gcc/ada/adaint.c
-@@ -295,6 +295,12 @@ char __gnat_dir_separator = DIR_SEPARATOR;
+@@ -298,6 +298,12 @@ char __gnat_dir_separator = DIR_SEPARATOR;
char __gnat_path_separator = PATH_SEPARATOR;
@@ -95,7 +95,7 @@ index 8522094164e..d850d27a3dc 100644
/* The GNAT_LIBRARY_TEMPLATE contains a list of expressions that define
the base filenames that libraries specified with -lsomelib options
may have. This is used by GNATMAKE to check whether an executable
-@@ -589,7 +595,11 @@ __gnat_try_lock (char *dir, char *file)
+@@ -592,7 +598,11 @@ __gnat_try_lock (char *dir, char *file)
int
__gnat_get_maximum_file_name_length (void)
{
@@ -939,23 +939,6 @@ index e0e47188bb9..488c3043815 100644
return has_root_name() && has_root_directory();
#else
return has_root_directory();
-diff --git a/libstdc++-v3/src/c++11/shared_ptr.cc b/libstdc++-v3/src/c++11/shared_ptr.cc
-index 74e879e5828..a4785c71eaa 100644
---- a/libstdc++-v3/src/c++11/shared_ptr.cc
-+++ b/libstdc++-v3/src/c++11/shared_ptr.cc
-@@ -35,7 +35,12 @@ namespace __gnu_internal _GLIBCXX_VISIBILITY(hidden)
- get_mutex(unsigned char i)
- {
- // increase alignment to put each lock on a separate cache line
-+ // increase alignment to put each lock on a separate cache line
-+#ifdef __DJGPP__
-+ struct alignas(16) M : __gnu_cxx::__mutex { };
-+#else
- struct alignas(64) M : __gnu_cxx::__mutex { };
-+#endif
- // Use a static buffer, so that the mutexes are not destructed
- // before potential users (or at all)
- static __attribute__ ((aligned(__alignof__(M))))
diff --git a/libstdc++-v3/src/filesystem/path.cc b/libstdc++-v3/src/filesystem/path.cc
index 4c218bdae49..6c345d2e51b 100644
--- a/libstdc++-v3/src/filesystem/path.cc