summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Reese2015-06-09 15:22:11 -0700
committerJohn Reese2015-06-09 15:22:11 -0700
commitfa9d03c4278caf32c08bed6d84233057552b714b (patch)
tree5de5723abdc561b4c618969f6e62b3ee414d863e
downloadaur-dotlink.tar.gz
Initial import from AUR3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7392b098371f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dotlink
+ pkgdesc = Automated deployment of dotfiles to local or remote locations
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/jreese/dotlink
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-setuptools
+ source = https://pypi.python.org/packages/source/D/Dotlink/Dotlink-0.6.0.tar.gz
+ md5sums = f3034e0113089178352511b2f3590ff0
+
+pkgname = dotlink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2f80d16d627
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: John Reese <john@noswap.com>
+# Upstream URL: https://github.com/jreese/dotlink
+#
+# For improvements/fixes to this package, please send a pull request:
+# https://github.com/jreese/arch
+
+
+pkgname=dotlink
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Automated deployment of dotfiles to local or remote locations"
+arch=('any')
+url="https://github.com/jreese/dotlink"
+license=('MIT')
+depends=('python-setuptools')
+makedepends=('git')
+
+source=("https://pypi.python.org/packages/source/D/Dotlink/Dotlink-${pkgver}.tar.gz")
+md5sums=('f3034e0113089178352511b2f3590ff0')
+
+package() {
+ cd "$srcdir/Dotlink-$pkgver"
+ python setup.py install --root="$pkgdir/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: