summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2020-04-16 21:46:00 +0100
committerGr3q2020-04-16 21:46:00 +0100
commit3f3a9c7cd992b1deb5591fd021846595fcb611e4 (patch)
tree931a190aab8e073ef01f8f5c7da27bf20e229316
parent3dbe7de51482e51bed8f7c3d8cbf443859a1646f (diff)
downloadaur-3f3a9c7cd992b1deb5591fd021846595fcb611e4.tar.gz
Remove makedepends, add itself as conflicts
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9b424e4f6c1..f01d430d62e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,18 +6,6 @@ pkgbase = dotnet-core-bin
arch = armv7h
arch = aarch64
license = MIT
- makedepends = clang
- makedepends = cmake
- makedepends = curl
- makedepends = git
- makedepends = icu
- makedepends = krb5
- makedepends = libunwind
- makedepends = lldb
- makedepends = llvm
- makedepends = lttng-ust
- makedepends = openssl
- makedepends = zlib
options = staticlibs
source = dotnet.sh
sha512sums = 448e2ad41a1ac5b7adf4a17ef27d01d1f20c6d355fdb1e10b0ceb4bd6edd8b3a24874aa8c42cfcf56267a6a85c5896b5f69764e5e59526f6938ec7c9d1ec7383
@@ -39,6 +27,7 @@ pkgname = aspnet-runtime-bin
provides = aspnet-runtime-3.1
provides = aspnet-runtime=3.1.3.sdk201
conflicts = aspnet-runtime-3.1
+ conflicts = aspnet-runtime=3.1.3.sdk201
pkgname = dotnet-runtime-bin
pkgdesc = The .NET Core runtime (binary)
@@ -53,11 +42,14 @@ pkgname = dotnet-runtime-bin
provides = dotnet-runtime-3.1
provides = dotnet-runtime=3.1.3.sdk201
conflicts = dotnet-runtime-3.1
+ conflicts = dotnet-runtime=3.1.3.sdk201
pkgname = dotnet-sdk-bin
pkgdesc = The .NET Core SDK (binary)
depends = dotnet-runtime-3.1
+ depends = glibc
provides = dotnet-sdk-3.1
provides = dotnet-sdk=3.1.3.sdk201
conflicts = dotnet-sdk-3.1
+ conflicts = dotnet-sdk=3.1.3.sdk201
diff --git a/PKGBUILD b/PKGBUILD
index 8f8dd701a550..87d59b805bb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,6 @@ pkgrel=1
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
-makedepends=(
- 'clang' 'cmake' 'curl' 'git' 'icu' 'krb5' 'libunwind' 'lldb' 'llvm'
- 'lttng-ust' 'openssl' 'zlib'
-)
options=('staticlibs')
source=('dotnet.sh')
sha512sums=('448e2ad41a1ac5b7adf4a17ef27d01d1f20c6d355fdb1e10b0ceb4bd6edd8b3a24874aa8c42cfcf56267a6a85c5896b5f69764e5e59526f6938ec7c9d1ec7383')
@@ -42,7 +38,7 @@ package_dotnet-runtime-bin() {
'libcurl.so')
optdepends=('lttng-ust: CoreCLR tracing')
provides=("dotnet-runtime-3.1" "dotnet-runtime=${pkgver}")
- conflicts=("dotnet-runtime-3.1")
+ conflicts=("dotnet-runtime-3.1" "dotnet-runtime=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -53,7 +49,7 @@ package_aspnet-runtime-bin() {
pkgdesc='The ASP.NET Core runtime (binary)'
depends=('dotnet-runtime-3.1')
provides=("aspnet-runtime-3.1" "aspnet-runtime=${pkgver}")
- conflicts=("aspnet-runtime-3.1")
+ conflicts=("aspnet-runtime-3.1" "aspnet-runtime=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -62,9 +58,9 @@ package_aspnet-runtime-bin() {
package_dotnet-sdk-bin() {
pkgdesc='The .NET Core SDK (binary)'
- depends=('dotnet-runtime-3.1')
+ depends=('dotnet-runtime-3.1' 'glibc')
provides=("dotnet-sdk-3.1" "dotnet-sdk=${pkgver}")
- conflicts=("dotnet-sdk-3.1")
+ conflicts=("dotnet-sdk-3.1" "dotnet-sdk=${pkgver}")
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
cp -dr --no-preserve='ownership' packs sdk templates "${pkgdir}"/usr/share/dotnet/
ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-sdk