summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttila Greguss2019-10-05 19:32:57 +0100
committerAttila Greguss2019-10-05 19:32:57 +0100
commit4e9a879f792941704459dbf9541e26754f675c15 (patch)
treec147e22c07088d650098879a64485a66cb87d876
parentb34453d865b208f83143c106a6bf4cd178df5a32 (diff)
downloadaur-4e9a879f792941704459dbf9541e26754f675c15.tar.gz
Reenable Aspnet Runtime
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59d932782e83..a2cc7f9ccf9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,6 +33,11 @@ pkgname = dotnet-host-bin
provides = dotnet-host=3.0.100
conflicts = dotnet-host
+pkgname = aspnet-runtime-bin
+ pkgdesc = The ASP.NET Core runtime (binary)
+ depends = dotnet-runtime=3.0.100
+ provides = aspnet-runtime=3.0.100
+
pkgname = dotnet-runtime-bin
pkgdesc = The .NET Core runtime (binary)
depends = dotnet-host>=3.0.100
diff --git a/PKGBUILD b/PKGBUILD
index 1c1a22e7b9d6..9f3b972857cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
pkgbase=dotnet-core-bin
-pkgname=('dotnet-host-bin' 'dotnet-runtime-bin' 'dotnet-sdk-bin')
+pkgname=('dotnet-host-bin' 'aspnet-runtime-bin' 'dotnet-runtime-bin' 'dotnet-sdk-bin')
pkgver=3.0.100
pkgrel=4
arch=('x86_64' 'armv7h' 'aarch64')
@@ -44,16 +44,15 @@ package_dotnet-runtime-bin() {
ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-runtime-bin
}
-#package_aspnet-runtime-bin() {
-# arch=('x86_64' 'armv7h')
-# pkgdesc='The ASP.NET Core runtime (binary)'
-# depends=('dotnet-runtime=3.0.100')
-# provides=("aspnet-runtime=${pkgver%+*}")
+package_aspnet-runtime-bin() {
+ pkgdesc='The ASP.NET Core runtime (binary)'
+ depends=('dotnet-runtime=3.0.100')
+ provides=("aspnet-runtime=${pkgver%+*}")
-# install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
-# cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
-# ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/aspnet-runtime-bin
-#}
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/aspnet-runtime-bin
+}
package_dotnet-sdk-bin() {
pkgdesc='The .NET Core SDK (binary)'