summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttila Greguss2021-11-08 22:02:44 +0000
committerAttila Greguss2021-11-08 22:02:44 +0000
commit8a70ea4c4c095bf5f6c5cfb6ccdc88ea85db50aa (patch)
treeea78adc78dc858651b6719f579a8bf22db9372b4
parent2b820c21d0786ea6091e9e6a98c1689e9e1a228c (diff)
downloadaur-8a70ea4c4c095bf5f6c5cfb6ccdc88ea85db50aa.tar.gz
Update Incorrect conflicts
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09df3f6f67e8..ecf37a22cdab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-core-bin
pkgver = 6.0.0.sdk100
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsoft.com/net/core
arch = x86_64
arch = armv7h
@@ -24,9 +24,9 @@ pkgname = aspnet-runtime-bin
pkgdesc = The ASP.NET Core runtime (binary)
depends = dotnet-runtime-bin
provides = aspnet-runtime=6.0.0
- provides = aspnet-runtime-5.0
+ provides = aspnet-runtime-6.0
conflicts = aspnet-runtime=6.0.0
- conflicts = aspnet-runtime-5.0
+ conflicts = aspnet-runtime-6.0
pkgname = dotnet-runtime-bin
pkgdesc = The .NET Core runtime (binary)
@@ -40,9 +40,9 @@ pkgname = dotnet-runtime-bin
depends = zlib
optdepends = lttng-ust: CoreCLR tracing
provides = dotnet-runtime=6.0.0
- provides = dotnet-runtime-5.0
+ provides = dotnet-runtime-6.0
conflicts = dotnet-runtime=6.0.0
- conflicts = dotnet-runtime-5.0
+ conflicts = dotnet-runtime-6.0
pkgname = dotnet-sdk-bin
pkgdesc = The .NET Core SDK (binary)
@@ -53,10 +53,10 @@ pkgname = dotnet-sdk-bin
optdepends = aspnet-targeting-pack-bin: Build ASP.NET Core applications
provides = dotnet-sdk-bin
provides = dotnet-sdk=6.0.0.sdk100
- provides = dotnet-sdk-5.0
+ provides = dotnet-sdk-6.0
conflicts = dotnet-sdk-bin
conflicts = dotnet-sdk=6.0.0.sdk100
- conflicts = dotnet-sdk-5.0
+ conflicts = dotnet-sdk-6.0
pkgname = netstandard-targeting-pack-bin
pkgdesc = The .NET Standard targeting pack (binary)
@@ -69,14 +69,14 @@ pkgname = dotnet-targeting-pack-bin
pkgdesc = The .NET Core targeting pack (binary)
depends = netstandard-targeting-pack-bin
provides = dotnet-targeting-pack=6.0.0
- provides = dotnet-targeting-pack-5.0
+ provides = dotnet-targeting-pack-6.0
conflicts = dotnet-targeting-pack=6.0.0
- conflicts = dotnet-targeting-pack-5.0
+ conflicts = dotnet-targeting-pack-6.0
pkgname = aspnet-targeting-pack-bin
pkgdesc = The ASP.NET Core targeting pack (binary)
depends = dotnet-targeting-pack-bin
provides = aspnet-targeting-pack=6.0.0
- provides = aspnet-targeting-pack-5.0
+ provides = aspnet-targeting-pack-6.0
conflicts = aspnet-targeting-pack=6.0.0
- conflicts = aspnet-targeting-pack-5.0
+ conflicts = aspnet-targeting-pack-6.0
diff --git a/PKGBUILD b/PKGBUILD
index 42bc156ffb0a..665e9f950079 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ pkgname=(
pkgver=6.0.0.sdk100
_runtimever=6.0.0
_sdkver=6.0.100
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
@@ -49,8 +49,8 @@ package_dotnet-runtime-bin() {
'zlib'
)
optdepends=('lttng-ust: CoreCLR tracing')
- provides=("dotnet-runtime=${_runtimever}" "dotnet-runtime-5.0")
- conflicts=("dotnet-runtime=${_runtimever}" "dotnet-runtime-5.0")
+ provides=("dotnet-runtime=${_runtimever}" "dotnet-runtime-6.0")
+ conflicts=("dotnet-runtime=${_runtimever}" "dotnet-runtime-6.0")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -60,8 +60,8 @@ package_dotnet-runtime-bin() {
package_aspnet-runtime-bin() {
pkgdesc='The ASP.NET Core runtime (binary)'
depends=('dotnet-runtime-bin')
- provides=("aspnet-runtime=${_runtimever}" "aspnet-runtime-5.0")
- conflicts=("aspnet-runtime=${_runtimever}" "aspnet-runtime-5.0")
+ provides=("aspnet-runtime=${_runtimever}" "aspnet-runtime-6.0")
+ conflicts=("aspnet-runtime=${_runtimever}" "aspnet-runtime-6.0")
install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
@@ -76,8 +76,8 @@ package_dotnet-sdk-bin() {
'dotnet-targeting-pack-bin'
'netstandard-targeting-pack-bin')
optdepends=('aspnet-targeting-pack-bin: Build ASP.NET Core applications')
- provides=("dotnet-sdk-bin" "dotnet-sdk=${pkgver}" "dotnet-sdk-5.0")
- conflicts=("dotnet-sdk-bin" "dotnet-sdk=${pkgver}" "dotnet-sdk-5.0")
+ provides=("dotnet-sdk-bin" "dotnet-sdk=${pkgver}" "dotnet-sdk-6.0")
+ conflicts=("dotnet-sdk-bin" "dotnet-sdk=${pkgver}" "dotnet-sdk-6.0")
install -dm 755 "${pkgdir}"/usr/share/{dotnet,licenses}
cp -dr --no-preserve='ownership' sdk templates "${pkgdir}"/usr/share/dotnet/
@@ -97,8 +97,8 @@ package_netstandard-targeting-pack-bin() {
package_dotnet-targeting-pack-bin() {
pkgdesc='The .NET Core targeting pack (binary)'
depends=(netstandard-targeting-pack-bin)
- provides=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-5.0)
- conflicts=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-5.0)
+ provides=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-6.0)
+ conflicts=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-6.0)
if [ $CARCH = 'x86_64' ]; then msarch=x64;
elif [ $CARCH = 'armv7h' ]; then msarch=arm;
@@ -112,8 +112,8 @@ package_dotnet-targeting-pack-bin() {
package_aspnet-targeting-pack-bin() {
pkgdesc='The ASP.NET Core targeting pack (binary)'
depends=(dotnet-targeting-pack-bin)
- provides=(aspnet-targeting-pack=${_runtimever} aspnet-targeting-pack-5.0)
- conflicts=(aspnet-targeting-pack=${_runtimever} aspnet-targeting-pack-5.0)
+ provides=(aspnet-targeting-pack=${_runtimever} aspnet-targeting-pack-6.0)
+ conflicts=(aspnet-targeting-pack=${_runtimever} aspnet-targeting-pack-6.0)
install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
cp -dr --no-preserve='ownership' packs/Microsoft.AspNetCore.App.Ref "${pkgdir}"/usr/share/dotnet/packs/