summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2019-10-02 19:05:43 +0100
committerGr3q2019-10-02 19:05:43 +0100
commitb9c6a4a9d39cd7a5b217129794d2dca3ac040ae3 (patch)
treeb409527bb47b300c73ce72e15051c8451567278a
downloadaur-b9c6a4a9d39cd7a5b217129794d2dca3ac040ae3.tar.gz
Initial commit
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD81
-rwxr-xr-xdotnet.sh4
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eefe32f44809
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,57 @@
+pkgbase = dotnet-core-bin
+ pkgver = 3.0.100
+ pkgrel = 1
+ url = https://www.microsoft.com/net/core
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = clang
+ makedepends = cmake
+ makedepends = curl
+ makedepends = git
+ makedepends = icu
+ makedepends = krb5
+ makedepends = libunwind
+ makedepends = lldb
+ makedepends = llvm
+ makedepends = lttng-ust
+ makedepends = openssl
+ makedepends = zlib
+ options = staticlibs
+ source_x86_64 = https://download.visualstudio.microsoft.com/download/pr/886b4a4c-30af-454b-8bec-81c72b7b4e1f/d1a0c8de9abb36d8535363ede4a15de6/dotnet-sdk-3.0.100-linux-x64.tar.gz
+ source_x86_64 = dotnet.sh
+ sha512sums_x86_64 = 766da31f9a0bcfbf0f12c91ea68354eb509ac2111879d55b656f19299c6ea1c005d31460dac7c2a4ef82b3edfea30232c82ba301fb52c0ff268d3e3a1b73d8f7
+ sha512sums_x86_64 = 0a9b174c8ae01009c7054cdd1463ded77bd85e5840cdcf15adc872db1ac5ca4d25a4b383d75ba7819ea9d89926c90edfe85f13144610b3e4a44b0b48f8efc17c
+ source_armv7h = https://download.visualstudio.microsoft.com/download/pr/8ddb8193-f88c-4c4b-82a3-39fcced27e91/b8e0b9bf4cf77dff09ff86cc1a73960b/dotnet-sdk-3.0.100-linux-arm.tar.gz
+ source_armv7h = dotnet.sh
+ sha512sums_armv7h = c81dddb0b2db8e29762f222f8dc15b8f3fdf939226c4015d2d919b8faaece503c7bbe0ceeec3e8dc27ad9ca29d027bb1164ac9901f7bbf9c5e4a793e4111d45d
+ sha512sums_armv7h = 0a9b174c8ae01009c7054cdd1463ded77bd85e5840cdcf15adc872db1ac5ca4d25a4b383d75ba7819ea9d89926c90edfe85f13144610b3e4a44b0b48f8efc17c
+
+pkgname = dotnet-host-bin
+ pkgdesc = A generic driver for the .NET Core Command Line Interface (binary)
+ provides = dotnet-host=3.0.100
+ conflicts = dotnet-host
+
+pkgname = dotnet-runtime-bin
+ pkgdesc = The .NET Core runtime (binary)
+ depends = dotnet-host-preview
+ depends = icu
+ depends = krb5
+ depends = libunwind
+ depends = openssl
+ depends = zlib
+ depends = libcurl.so
+ optdepends = lttng-ust: CoreCLR tracing
+ provides = dotnet-runtime=3.0.100
+
+pkgname = aspnet-runtime-bin
+ pkgdesc = The ASP.NET Core runtime (binary)
+ depends = dotnet-runtime-bin
+ provides = aspnet-runtime=3.0.100
+
+pkgname = dotnet-sdk-bin
+ pkgdesc = The .NET Core SDK (binary)
+ depends = dotnet-runtime-bin
+ provides = dotnet-sdk=3.0.100
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2d4ee124f90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Attila Greguss <floyd0122[at]gmail[dot]com>
+
+pkgbase=dotnet-core-bin
+pkgname=('dotnet-host-bin' 'dotnet-runtime-bin' 'aspnet-runtime-bin' 'dotnet-sdk-bin')
+pkgver=3.0.100
+pkgrel=1
+arch=('x86_64' 'armv7h' 'aarch64')
+url='https://www.microsoft.com/net/core'
+license=('MIT')
+makedepends=(
+ 'clang' 'cmake' 'curl' 'git' 'icu' 'krb5' 'libunwind' 'lldb' 'llvm'
+ 'lttng-ust' 'openssl' 'zlib'
+)
+options=('staticlibs')
+source_armv7h=(
+ 'https://download.visualstudio.microsoft.com/download/pr/8ddb8193-f88c-4c4b-82a3-39fcced27e91/b8e0b9bf4cf77dff09ff86cc1a73960b/dotnet-sdk-3.0.100-linux-arm.tar.gz'
+ 'dotnet.sh'
+)
+source_aarm64=(
+ 'https://download.visualstudio.microsoft.com/download/pr/cbc83a0e-895c-4959-99d9-21cd11596e64/b0e59c2ba2bd3ef0f592acbeae7ab27d/dotnet-sdk-3.0.100-linux-arm64.tar.gz'
+ 'dotnet.sh'
+)
+source_x86_64=(
+ 'https://download.visualstudio.microsoft.com/download/pr/886b4a4c-30af-454b-8bec-81c72b7b4e1f/d1a0c8de9abb36d8535363ede4a15de6/dotnet-sdk-3.0.100-linux-x64.tar.gz'
+ 'dotnet.sh'
+)
+sha512sums_armv7h=(
+ 'c81dddb0b2db8e29762f222f8dc15b8f3fdf939226c4015d2d919b8faaece503c7bbe0ceeec3e8dc27ad9ca29d027bb1164ac9901f7bbf9c5e4a793e4111d45d'
+ '0a9b174c8ae01009c7054cdd1463ded77bd85e5840cdcf15adc872db1ac5ca4d25a4b383d75ba7819ea9d89926c90edfe85f13144610b3e4a44b0b48f8efc17c'
+)
+sha512sums_aarm64=(
+ '18c3bc07c4486381f54d4b40eb8401bf56c14fef5febc4639e3134d74ce66172d1e66c2dea9684ad727f08e9dd7e89d74535a8642fb2a2203445483293f3b3c3'
+ '0a9b174c8ae01009c7054cdd1463ded77bd85e5840cdcf15adc872db1ac5ca4d25a4b383d75ba7819ea9d89926c90edfe85f13144610b3e4a44b0b48f8efc17c'
+)
+sha512sums_x86_64=(
+ '766da31f9a0bcfbf0f12c91ea68354eb509ac2111879d55b656f19299c6ea1c005d31460dac7c2a4ef82b3edfea30232c82ba301fb52c0ff268d3e3a1b73d8f7'
+ '0a9b174c8ae01009c7054cdd1463ded77bd85e5840cdcf15adc872db1ac5ca4d25a4b383d75ba7819ea9d89926c90edfe85f13144610b3e4a44b0b48f8efc17c'
+)
+
+package_dotnet-host-bin() {
+ pkgdesc='A generic driver for the .NET Core Command Line Interface (binary)'
+ provides=("dotnet-host=${pkgver%+*}")
+ conflicts=('dotnet-host')
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses/dotnet-host}
+ cp -dr --no-preserve='ownership' dotnet host "${pkgdir}"/opt/dotnet/
+ cp -dr --no-preserve='ownership' LICENSE.txt ThirdPartyNotices.txt "${pkgdir}"/usr/share/licenses/dotnet-host
+ install -Dm 755 "${srcdir}"/dotnet.sh "${pkgdir}"/usr/bin/dotnet
+}
+
+package_dotnet-runtime-bin() {
+ pkgdesc='The .NET Core runtime (binary)'
+ depends=('dotnet-host-preview' 'icu' 'krb5' 'libunwind' 'openssl' 'zlib'
+ 'libcurl.so')
+ optdepends=('lttng-ust: CoreCLR tracing')
+ provides=("dotnet-runtime=${pkgver%+*}")
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-runtime
+}
+
+package_aspnet-runtime-bin() {
+ pkgdesc='The ASP.NET Core runtime (binary)'
+ depends=('dotnet-runtime-bin')
+ provides=("aspnet-runtime=${pkgver%+*}")
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet/shared,usr/share/licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/opt/dotnet/shared/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/aspnet-runtime
+}
+
+package_dotnet-sdk-bin() {
+ pkgdesc='The .NET Core SDK (binary)'
+ depends=('dotnet-runtime-bin')
+ provides=("dotnet-sdk=${pkgver%+*}")
+
+ install -dm 755 "${pkgdir}"/{opt/dotnet,usr/share/licenses}
+ cp -dr --no-preserve='ownership' packs sdk templates "${pkgdir}"/opt/dotnet/
+ ln -s dotnet-host "${pkgdir}"/usr/share/licenses/dotnet-sdk
+}
diff --git a/dotnet.sh b/dotnet.sh
new file mode 100755
index 000000000000..fda6aa61100f
--- /dev/null
+++ b/dotnet.sh
@@ -0,0 +1,4 @@
+#/bin/bash
+
+export DOTNET_ROOT=/opt/dotnet
+exec /opt/dotnet/dotnet "$@" \ No newline at end of file