summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrandon Milton2017-02-18 18:08:14 -0800
committerBrandon Milton2017-02-18 18:08:14 -0800
commit9db67f87bc8f65df46257b7a90aec09e4fe3e8fa (patch)
tree5f4f411e8f5ab37f97b071a2cda91520722ea037
parentb57b6c873b64b360f13c53908ffe08f8247bd967 (diff)
downloadaur-9db67f87bc8f65df46257b7a90aec09e4fe3e8fa.tar.gz
Update to 1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19119f6a2ad7..46bc05484d49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = download-sweeper
pkgdesc = A stale file archive and removal tool
- pkgver = 1.0
- pkgrel = 6
+ pkgver = 1.1
+ pkgrel = 0
url = https://github.com/brandonio21/download-sweeper
arch = any
license = GPL
- makedepends = python-pip
depends = python>=3
- depends = systemd
- depends = python-virtualenv
- source = https://github.com/brandonio21/download-sweeper/archive/v1.0.tar.gz
- md5sums = e54f13dc3d220295b1cd6ff17834dcfc
+ depends = python-yaml
+ source = https://github.com/brandonio21/download-sweeper/archive/v1.1.tar.gz
+ sha256sums = 87b93555a6f6b2bdf62c611c9336466bb3da134f8d95f9fb60048121d52fa4dc
pkgname = download-sweeper
diff --git a/PKGBUILD b/PKGBUILD
index 2ffb16f99c96..c3b810e38dc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,16 @@
# Maintainer: Brandon Milton <brandon.milton21@gmail.com>
pkgname=download-sweeper
-pkgver=1.0
-pkgrel=6
+pkgver=1.1
+pkgrel=0
pkgdesc="A stale file archive and removal tool"
arch=('any')
url="https://github.com/brandonio21/download-sweeper"
license=('GPL')
-depends=('python>=3' 'systemd' 'python-virtualenv')
-makedepends=('python-pip')
+depends=('python>=3' 'python-yaml')
source=("https://github.com/brandonio21/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('e54f13dc3d220295b1cd6ff17834dcfc')
-
-build() {
- cd "$pkgname-$pkgver"
- make
-}
+sha256sums=('87b93555a6f6b2bdf62c611c9336466bb3da134f8d95f9fb60048121d52fa4dc')
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ install download_sweeper.py usr/bin/
}