summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2016-06-20 13:53:37 -0300
committerRafael Reggiani Manzo2016-06-20 13:53:37 -0300
commitd1e49eabae9f8e50c58b54a59c331f792aed6f43 (patch)
treee6cb13357fc066f7aaf8c77273bb8297116f4d9e
parent75251d4dba405fe7cd8208e0ce82ad585f0dad11 (diff)
downloadaur-doxyparse.tar.gz
Update to 1.8.11
This improves integration to the latests doxygen dropping all required patches.
-rw-r--r--.SRCINFO14
-rw-r--r--Fix-Flex-version-compilation-restriction.patch212
-rw-r--r--PKGBUILD23
-rw-r--r--qtools.patch35
4 files changed, 10 insertions, 274 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 258f015d84fb..9dc5ad1b0e89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Dec 16 17:29:41 UTC 2015
+# Mon Jun 20 16:53:27 UTC 2016
pkgbase = doxyparse
pkgdesc = Parses source code and dumps the dependencies between the code elements.
- pkgver = 1.5.9_20090622
- pkgrel = 6
+ pkgver = 1.8.11_20090622
+ pkgrel = 1
url = http://analizo.org
arch = any
groups = analizo
@@ -11,12 +11,8 @@ pkgbase = doxyparse
makedepends = qt4
makedepends = git
makedepends = flex
- source = qtools.patch
- source = Fix-Flex-version-compilation-restriction.patch
- source = https://github.com/analizo/doxyparse/archive/upstream/1.5.9.tar.gz
- sha512sums = 8095af5f6ba616864be6389b4245ab7a3a3723298635831c4f714468d6768cf86a382802ad8189053414f7701654ef683d1342936a31b98208ebf78f5e92485a
- sha512sums = 362a68214fcd90a1f5cfcab6c0bb9c10fb2b51ecb0de1232f17d56b30e5713fcdc4dcb587a861b7629bdcff5a4ae3d28458d460ac2a9c6060eadcc33cef95da0
- sha512sums = 18d13d27f93f74636df457be36d1c27328051d586448d909042d2fcedd39170f396c3c7c4061a522f1e24fab69daf125d37a534d133d3083e7beb42cb8f7b6ac
+ source = https://github.com/analizo/doxyparse/archive/upstream/1.8.11.tar.gz
+ sha512sums = c1d45462deafde71b85d9db4af0f8fd564b45a16aebc0397b4ff2827dc4db5a5520d9e31328d262b41dca341594c2a4c65000e0af11c7c67c371ba4ec80bdfcf
pkgname = doxyparse
diff --git a/Fix-Flex-version-compilation-restriction.patch b/Fix-Flex-version-compilation-restriction.patch
deleted file mode 100644
index 3c5aed633eae..000000000000
--- a/Fix-Flex-version-compilation-restriction.patch
+++ /dev/null
@@ -1,212 +0,0 @@
-Index: doxyparse-upstream-1.5.9/src/code.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/code.l
-+++ doxyparse-upstream-1.5.9/src/code.l
-@@ -3494,7 +3494,7 @@ void parseCCode(CodeOutputInterface &od,
-
- void codeFreeScanner()
- {
--#if defined(YY_FLEX_SUBMINOR_VERSION)
-+#if defined(YY_FLEX_SUBMINOR_VERSION) || defined(YY_FLEX_MINOR_VERSION)
- if (g_lexInit)
- {
- codeYYlex_destroy();
-@@ -3504,11 +3504,11 @@ void codeFreeScanner()
-
-
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- extern "C" { // some bogus code to keep the compiler happy
- void codeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #endif
-
-Index: doxyparse-upstream-1.5.9/src/commentcnv.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/commentcnv.l
-+++ doxyparse-upstream-1.5.9/src/commentcnv.l
-@@ -785,7 +785,7 @@ void convertCppComments(BufStr *inBuf,Bu
-
-
- //----------------------------------------------------------------------------
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- extern "C" { // some bogus code to keep the compiler happy
- void commentcnvYYdummy() { yy_flex_realloc(0,0); }
- }
-Index: doxyparse-upstream-1.5.9/src/commentscan.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/commentscan.l
-+++ doxyparse-upstream-1.5.9/src/commentscan.l
-@@ -949,7 +949,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
- // but we need to know the position in the input buffer where this
- // rule matched.
- // for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
--#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
-+#if (YY_FLEX_MINOR_VERSION==5 && YY_FLEX_SUBMINOR_VERSION>=33) || YY_FLEX_MINOR_VERSION > 5
- inputPosition=prevPosition + yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf;
- #else
- inputPosition=prevPosition + yy_bp - yy_current_buffer->yy_ch_buf;
-@@ -2631,7 +2631,7 @@ static void groupAddDocs(Entry *e,const
- }
-
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- //----------------------------------------------------------------------------
- extern "C" { // some bogus code to keep the compiler happy
- void commentScanYYdummy() { yy_flex_realloc(0,0); }
-Index: doxyparse-upstream-1.5.9/src/declinfo.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/declinfo.l
-+++ doxyparse-upstream-1.5.9/src/declinfo.l
-@@ -346,7 +346,7 @@ int main()
- }
- #endif
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- //----------------------------------------------------------------------------
- extern "C" { // some bogus code to keep the compiler happy
- void declinfoYYdummy() { yy_flex_realloc(0,0); }
-Index: doxyparse-upstream-1.5.9/src/defargs.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/defargs.l
-+++ doxyparse-upstream-1.5.9/src/defargs.l
-@@ -470,7 +470,7 @@ void stringToArgumentList(const char *ar
- //printf("stringToArgumentList(%s) result=%s\n",argsString,argListToString(al).data());
- }
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- extern "C" { // some bogus code to keep the compiler happy
- void defargsYYdummy() { yy_flex_realloc(0,0); }
- }
-Index: doxyparse-upstream-1.5.9/src/fortrancode.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/fortrancode.l
-+++ doxyparse-upstream-1.5.9/src/fortrancode.l
-@@ -1006,11 +1006,11 @@ void parseFortranCode(CodeOutputInterfac
- return;
- }
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- extern "C" { // some bogus code to keep the compiler happy
- void fcodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #else
- extern "C" { // some bogus code to keep the compiler happy
-Index: doxyparse-upstream-1.5.9/src/fortranscanner.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/fortranscanner.l
-+++ doxyparse-upstream-1.5.9/src/fortranscanner.l
-@@ -1758,7 +1758,7 @@ static void scanner_abort()
-
- //----------------------------------------------------------------------------
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- //----------------------------------------------------------------------------
- extern "C" { // some bogus code to keep the compiler happy
- void fscannerYYdummy() { yy_flex_realloc(0,0); yy_top_state(); }
-Index: doxyparse-upstream-1.5.9/src/pre.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/pre.l
-+++ doxyparse-upstream-1.5.9/src/pre.l
-@@ -2517,7 +2517,7 @@ void preprocessFile(const char *fileName
-
- void preFreeScanner()
- {
--#if defined(YY_FLEX_SUBMINOR_VERSION)
-+#if defined(YY_FLEX_SUBMINOR_VERSION) || defined(YY_FLEX_MINOR_VERSION)
- if (g_lexInit)
- {
- preYYlex_destroy();
-@@ -2525,7 +2525,7 @@ void preFreeScanner()
- #endif
- }
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- extern "C" { // some bogus code to keep the compiler happy
- // int preYYwrap() { return 1 ; }
- void preYYdummy() { yy_flex_realloc(0,0); }
-Index: doxyparse-upstream-1.5.9/src/pycode.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/pycode.l
-+++ doxyparse-upstream-1.5.9/src/pycode.l
-@@ -1450,11 +1450,11 @@ void parsePythonCode(CodeOutputInterface
- }
-
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- extern "C" { // some bogus code to keep the compiler happy
- void pycodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
- #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
- #endif
-
-Index: doxyparse-upstream-1.5.9/src/pyscanner.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/pyscanner.l
-+++ doxyparse-upstream-1.5.9/src/pyscanner.l
-@@ -1650,7 +1650,7 @@ void PythonLanguageScanner::resetCodePar
-
- //----------------------------------------------------------------------------
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- //----------------------------------------------------------------------------
- extern "C" { // some bogus code to keep the compiler happy
- void pyscannerYYdummy() { yy_flex_realloc(0,0); }
-Index: doxyparse-upstream-1.5.9/src/scanner.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/scanner.l
-+++ doxyparse-upstream-1.5.9/src/scanner.l
-@@ -5720,7 +5720,7 @@ void CLanguageScanner::parsePrototype(co
-
- //----------------------------------------------------------------------------
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- //----------------------------------------------------------------------------
- extern "C" { // some bogus code to keep the compiler happy
- void scannerYYdummy() { yy_flex_realloc(0,0); }
-Index: doxyparse-upstream-1.5.9/src/vhdlcode.l
-===================================================================
---- doxyparse-upstream-1.5.9.orig/src/vhdlcode.l
-+++ doxyparse-upstream-1.5.9/src/vhdlcode.l
-@@ -1586,7 +1586,7 @@ void parseVhdlCode(CodeOutputInterface &
-
- void codeFreeVhdlScanner()
- {
--#if defined(YY_FLEX_SUBMINOR_VERSION)
-+#if defined(YY_FLEX_SUBMINOR_VERSION) || defined(YY_FLEX_MINOR_VERSION)
- if (g_lexInit)
- {
- vhdlcodeYYlex_destroy();
-@@ -1594,11 +1594,11 @@ void codeFreeVhdlScanner()
- #endif
- }
-
--#if !defined(YY_FLEX_SUBMINOR_VERSION)
-+#if !defined(YY_FLEX_SUBMINOR_VERSION) || !defined(YY_FLEX_MINOR_VERSION)
- extern "C" { // some bogus code to keep the compiler happy
- void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_SUBMINOR_VERSION<33 && YY_FLEX_MINOR_VERSION < 6
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #endif
-
diff --git a/PKGBUILD b/PKGBUILD
index bf0624b4d5c6..0a05644e6648 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
#PKGBUILD Maintainer: Rafael Reggiani Manzo <rr.manzo#gmail.com>
pkgname=doxyparse
-_actual_ver=1.5.9
+_actual_ver=1.8.11
_extra_ver=20090622
pkgver=${_actual_ver}_${_extra_ver}
-pkgrel=6
+pkgrel=1
pkgdesc="Parses source code and dumps the dependencies between the code elements."
groups=('analizo')
arch=('any')
@@ -12,34 +12,21 @@ url="http://analizo.org"
license=('GPLv2')
makedepends=('qt4' 'git' 'flex')
source=(
- "qtools.patch"
- "Fix-Flex-version-compilation-restriction.patch"
"https://github.com/analizo/doxyparse/archive/upstream/${_actual_ver}.tar.gz"
)
sha512sums=(
- '8095af5f6ba616864be6389b4245ab7a3a3723298635831c4f714468d6768cf86a382802ad8189053414f7701654ef683d1342936a31b98208ebf78f5e92485a'
- '362a68214fcd90a1f5cfcab6c0bb9c10fb2b51ecb0de1232f17d56b30e5713fcdc4dcb587a861b7629bdcff5a4ae3d28458d460ac2a9c6060eadcc33cef95da0'
- '18d13d27f93f74636df457be36d1c27328051d586448d909042d2fcedd39170f396c3c7c4061a522f1e24fab69daf125d37a534d133d3083e7beb42cb8f7b6ac'
+ 'c1d45462deafde71b85d9db4af0f8fd564b45a16aebc0397b4ff2827dc4db5a5520d9e31328d262b41dca341594c2a4c65000e0af11c7c67c371ba4ec80bdfcf'
)
build(){
cd "${srcdir}"
- cp "${srcdir}/qtools.patch" "doxyparse-upstream-${_actual_ver}"
- cp "${srcdir}/Fix-Flex-version-compilation-restriction.patch" "doxyparse-upstream-${_actual_ver}"
cd "doxyparse-upstream-${_actual_ver}"
- patch -p1 < qtools.patch
- patch -p1 < Fix-Flex-version-compilation-restriction.patch
- ./configure --with-doxyparse
+
+ cmake -Dbuild_parse=YES .
make
}
-check() {
- cd "${srcdir}/doxyparse-upstream-${_actual_ver}"
-
- make check || :
-}
-
package(){
cd "${srcdir}/doxyparse-upstream-${_actual_ver}"
diff --git a/qtools.patch b/qtools.patch
deleted file mode 100644
index 0cef15cbf9f1..000000000000
--- a/qtools.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/qtools/qglobal.h b/qtools/qglobal.h
-index 5417861..b8c5067 100644
---- a/qtools/qglobal.h
-+++ b/qtools/qglobal.h
-@@ -86,7 +86,16 @@
- # if !defined(MAC_OS_X_VERSION_10_5)
- # define MAC_OS_X_VERSION_10_5 MAC_OS_X_VERSION_10_4 + 1
- # endif
--# if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_5)
-+# if !defined(MAC_OS_X_VERSION_10_6)
-+# define MAC_OS_X_VERSION_10_6 MAC_OS_X_VERSION_10_5 + 1
-+# endif
-+# if !defined(MAC_OS_X_VERSION_10_7)
-+# define MAC_OS_X_VERSION_10_7 MAC_OS_X_VERSION_10_6 + 1
-+# endif
-+# if !defined(MAC_OS_X_VERSION_10_8)
-+# define MAC_OS_X_VERSION_10_8 MAC_OS_X_VERSION_10_7 + 1
-+# endif
-+# if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_8)
- # error "This version of Mac OS X is unsupported"
- # endif
- #elif defined(MSDOS) || defined(_MSDOS) || defined(__MSDOS__)
-diff --git a/qtools/qvaluestack.h b/qtools/qvaluestack.h
-index 3fb61fd..fe4462a 100644
---- a/qtools/qvaluestack.h
-+++ b/qtools/qvaluestack.h
-@@ -49,7 +49,7 @@ class Q_EXPORT QValueStack : public QValueList<T>
- public:
- QValueStack() {}
- ~QValueStack() {}
-- void push( const T& d ) { append(d); }
-+ void push( const T& d ) { QValueList<T>::append(d); }
- T pop()
- {
- T elem( this->last() );