summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortleydxdy2021-08-20 10:34:50 -0400
committertleydxdy2021-08-20 10:34:50 -0400
commitb95b70d73b58a96a9ac9171e9baca844cd50bf2c (patch)
tree42682b27f0c77973951eb5c0910a5aab451647b8
parent9f9c5103f03ab34c0dd9941df2b9df58b1bec982 (diff)
downloadaur-dracut-sb.tar.gz
add more hooks
-rw-r--r--.SRCINFO3
-rw-r--r--55-efi-key.hook3
-rw-r--r--90-dracut-install.hook7
-rw-r--r--PKGBUILD3
-rw-r--r--dracut-sb.install16
5 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3b3133307f8..bcd1ecfcce52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = dracut-sb
pkgdesc = dracut secure boot setup using efistub
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
+ install = dracut-sb.install
arch = x86_64
depends = dracut
depends = efitools
diff --git a/55-efi-key.hook b/55-efi-key.hook
index 1670bbdddeb2..477febe3d7b7 100644
--- a/55-efi-key.hook
+++ b/55-efi-key.hook
@@ -1,5 +1,5 @@
[Trigger]
-Type = File
+Type = Path
Operation = Install
Operation = Upgrade
Target = usr/lib/modules/*/pkgbase
@@ -9,4 +9,3 @@ Target = usr/lib/dracut/*
Description = Waiting for EFI signing key...
When = PreTransaction
Exec = /usr/local/share/libalpm/scripts/efi-key
-NeedsTargets
diff --git a/90-dracut-install.hook b/90-dracut-install.hook
index 962cca24467f..46daea1d7c47 100644
--- a/90-dracut-install.hook
+++ b/90-dracut-install.hook
@@ -5,13 +5,6 @@ Operation = Upgrade
Target = usr/lib/modules/*/pkgbase
Target = usr/lib/dracut/*
-[Trigger]
-Type = Package
-Operation = Install
-Operation = Upgrade
-Operation = Remove
-Target = dracut-sb
-
[Action]
Description = Updating dracut modules...
When = PostTransaction
diff --git a/PKGBUILD b/PKGBUILD
index 3d474cb343af..7ad376017074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=dracut-sb
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='dracut secure boot setup using efistub'
arch=('x86_64')
depends=('dracut' 'efitools' 'efibootmgr' 'sbsigntools')
backup=('etc/dracut-sb/efi-key.conf')
+install="${pkgname}.install"
source=('55-efi-key.hook'
'60-dracut-remove.hook'
'90-dracut-install.hook'
diff --git a/dracut-sb.install b/dracut-sb.install
new file mode 100644
index 000000000000..f4fa328b73b0
--- /dev/null
+++ b/dracut-sb.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "Edit the config at /etc/dracut-sb/efi-key.conf to contain the correct info,"
+ echo "plug in the drive with the keys, then Press Enter"
+ read
+ /usr/local/share/libalpm/scripts/efi-key
+ echo "" | /usr/local/share/libalpm/scripts/dracut-install
+}
+
+post_upgrade() {
+ /usr/local/share/libalpm/scripts/efi-key
+ echo "" | /usr/local/share/libalpm/scripts/dracut-install
+}
+
+post_remove() {
+ echo "" | /usr/local/share/libalpm/scripts/dracut-install
+}