summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit82e39e67914f7d6e2697915dec0cd9672fdc4cb3 (patch)
tree369241a00ae11f0d62f0929136b9b6895df94710
downloadaur-driconf.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--driconf_simpleui.patch13
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52a9365abf5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:57 UTC 2019
+pkgbase = driconf
+ pkgdesc = Graphical configuration tool for the Direct Rendering Infrastructure
+ pkgver = 0.9.1
+ pkgrel = 14
+ url = https://dri.freedesktop.org/wiki/DriConf/
+ arch = any
+ license = GPL
+ makedepends = imagemagick
+ depends = mesa-demos
+ depends = pygtk
+ depends = xorg-xdriinfo
+ source = http://ftp.debian.org/debian/pool/main/d/driconf/driconf_0.9.1.orig.tar.gz
+ source = driconf_simpleui.patch
+ sha256sums = 4849a43f6324498e943c03777bce571229b5446985b1cec596b365505e76f73f
+ sha256sums = a2f9c4fd50cb694cc743cdde0f4efe310cb11fbef347c1a1d5fbec9a99d3499b
+
+pkgname = driconf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b16e9a50fc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Giovanni Scafora <linuxmania@gmail.com>
+
+pkgname=driconf
+pkgver=0.9.1
+pkgrel=14
+pkgdesc="Graphical configuration tool for the Direct Rendering Infrastructure"
+arch=('any')
+url="https://dri.freedesktop.org/wiki/DriConf/"
+license=('GPL')
+depends=('mesa-demos' 'pygtk' 'xorg-xdriinfo')
+makedepends=('imagemagick')
+source=(http://ftp.debian.org/debian/pool/main/d/$pkgname/${pkgname}_$pkgver.orig.tar.gz
+ driconf_simpleui.patch)
+sha256sums=('4849a43f6324498e943c03777bce571229b5446985b1cec596b365505e76f73f'
+ 'a2f9c4fd50cb694cc743cdde0f4efe310cb11fbef347c1a1d5fbec9a99d3499b')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # Fix uninitialized variable (FS#36934)
+ patch -Np0 -i ../driconf_simpleui.patch
+
+ # Install into /usr instead of /usr/local
+ sed -i 's|/usr/local|/usr|' *.py driconf setup.cfg
+ sed -i 's/^Icon=.*/Icon=drilogo/
+ s/AdvancedSettings;//' driconf.desktop
+}
+
+build() {
+ cd $pkgname-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -dm755 "$pkgdir"/usr/share/pixmaps/
+ convert drilogo.jpg +set date:create +set date:modify "$pkgdir"/usr/share/pixmaps/drilogo.png
+}
diff --git a/driconf_simpleui.patch b/driconf_simpleui.patch
new file mode 100644
index 000000000000..814d64ad5cb5
--- /dev/null
+++ b/driconf_simpleui.patch
@@ -0,0 +1,13 @@
+--- driconf_simpleui-original.py 2013-09-14 18:28:51.783220606 -0600
++++ driconf_simpleui.py 2013-09-14 18:31:01.143223727 -0600
+@@ -266,8 +266,8 @@
+ j = i
+ break
+ i = i - 1
+- if i < chars/3:
+- i = chars
++ else:
++ i = j = chars
+ head, tail = head + tail[:i] + '\n', tail[j:]
+ return head
+