summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-04-15 21:26:47 +0200
committerChristopher Arndt2021-04-15 21:26:47 +0200
commit16089d27ffdde828917e57009e1b8dc2270894a9 (patch)
treea7640a5d2bf325beae59b134ad42832def793c73
downloadaur-drops.tar.gz
Add new package 'drops'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD38
-rw-r--r--drops-system-sfizz.patch33
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f70be80445b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = drops
+ pkgdesc = A sample player instrument LV2/VST2 plugin and stand-alone JACK program
+ pkgver = 1.0beta
+ pkgrel = 1
+ url = https://github.com/clearly-broken-software/drops
+ arch = x86_64
+ groups = pro-audio
+ groups = lv2-plugins
+ groups = vst-plugins
+ license = GPL3
+ makedepends = jack2
+ makedepends = libsndfile
+ makedepends = mesa
+ makedepends = sfizz
+ depends = gcc-libs
+ source = https://github.com/clearly-broken-software/drops/releases/download/v1.0-beta/drops_v1.0-beta.tar.gz
+ source = drops-system-sfizz.patch
+ md5sums = 65d6f03d60768858b52397d062526659
+ md5sums = b9be2ca33b9b7f322c34564659335fcd
+
+pkgname = drops
+ depends = gcc-libs
+ depends = libjack.so
+ depends = libsfizz.so
+ depends = libsndfile.so
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c7a9441edcde
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+dpf/
+drops-*.pkg.tar.xz
+drops-*.pkg.tar.zst
+drops_v*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e740319f0c2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname=drops
+_pkgver="1.0-beta"
+pkgver="${_pkgver/-/}"
+pkgrel=1
+pkgdesc="A sample player instrument LV2/VST2 plugin and stand-alone JACK program"
+arch=('x86_64')
+url="https://github.com/clearly-broken-software/drops"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('jack2' 'libsndfile' 'mesa' 'sfizz')
+groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
+source=("https://github.com/clearly-broken-software/${pkgname}/releases/download/v${_pkgver}/${pkgname}_v${_pkgver}.tar.gz"
+ 'drops-system-sfizz.patch')
+md5sums=('65d6f03d60768858b52397d062526659'
+ 'b9be2ca33b9b7f322c34564659335fcd')
+
+prepare() {
+ cd "${srcdir}/${pkgname}_v${_pkgver}"
+
+ # Use system-installed sfizz library
+ patch -N -r - -p 1 -i "${srcdir}"/drops-system-sfizz.patch || :
+}
+
+build() {
+ cd "${srcdir}/${pkgname}_v${_pkgver}"
+ make
+}
+
+package() {
+ depends+=('libjack.so' 'libsfizz.so' 'libsndfile.so')
+ cd "${srcdir}/${pkgname}_v${_pkgver}"
+ install -s -vDm 755 bin/drops -t "${pkgdir}"/usr/bin
+ install -vDm 644 bin/drops.lv2/*.ttl -t "${pkgdir}"/usr/lib/lv2/drops.lv2
+ install -vDm 755 bin/drops.lv2/*.so -t "${pkgdir}"/usr/lib/lv2/drops.lv2
+ install -vDm 755 bin/drops-vst.so -t "${pkgdir}"/usr/lib/vst
+}
diff --git a/drops-system-sfizz.patch b/drops-system-sfizz.patch
new file mode 100644
index 000000000000..b1085b4431c9
--- /dev/null
+++ b/drops-system-sfizz.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index 864c0d5..597f6b3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -8,8 +8,6 @@ include dpf/Makefile.base.mk
+
+
+ all: dgl plugins gen
+-plugins: sfizz-lib
+-include sfizz/dpf.mk
+ # --------------------------------------------------------------
+
+ dgl:
+diff --git a/plugins/drops/Makefile b/plugins/drops/Makefile
+index 651b4a0..0e930ec 100644
+--- a/plugins/drops/Makefile
++++ b/plugins/drops/Makefile
+@@ -57,13 +57,13 @@ FILES_UI = \
+ # Do some magic
+
+ include ../../dpf/Makefile.plugins.mk
+-include ../../sfizz/dpf.mk
+
+ # --------------------------------------------------------------
+ # Extra flags
++SFIZZ_C_FLAGS = $(shell $(PKG_CONFIG) --cflags sfizz)
+ BUILD_C_FLAGS += $(SFIZZ_C_FLAGS)
+-BUILD_CXX_FLAGS += $(SFIZZ_CXX_FLAGS)
+-LINK_FLAGS += $(SFIZZ_LINK_FLAGS) $(shell $(PKG_CONFIG) --libs sndfile )
++BUILD_CXX_FLAGS += $(SFIZZ_C_FLAGS)
++LINK_FLAGS += $(shell $(PKG_CONFIG) --libs sfizz) $(shell $(PKG_CONFIG) --libs sndfile)
+ BASE_FLAGS += -I. -I./widgets -I./external/src
+ #LINK_FLAGS += $(shell pkg-config --libs sfizz)